Previous 1 2 3 4 5 Next 74 Replies Latest reply: Apr 27, 2013 4:39 PM by -groovatious- Go to original post
  • Jason Heiser Level 1 Level 1 (0 points)

    I inadvertently let the Lion update install without undoing the comments I inserted into that plist. No adverse effects, fortunately; it appears the 10.8.2 update simply overwrote my edited plist. I won't know if the issue with my Belkin hub is resolved until I get home tonight. Given Mr. Gatwood's testimony, I'm optimistic it will work.

  • ThaBossog Level 1 Level 1 (0 points)

    The 10.8.2 update solved my situation for my 7 port Belkin HUB;

     

    Thanks for the updates...

  • boogieted Level 1 Level 1 (0 points)

    10.8.2 did NOT solve the problem with my Belkin USB hub.  It was working fine in Lion before I did a clean install of Mountain Lion.

  • explicitdt Level 1 Level 1 (0 points)

    My premium 7 port usb works fine after the 10.8.2 update, I was having troubles before that. It also works fine on windows7 after resinstalling the drive on the pc. now i can plug it in on either and it works perfect

  • David A. Gatwood Level 3 Level 3 (580 points)

    Try booting in safe-boot mode once, then rebooting again.

  • boogieted Level 1 Level 1 (0 points)

    David,

    safe-boot took care of my problem!!  The Belkin hub works once again!

    Thank you so much!

  • ReallyFunkyGibbon Level 1 Level 1 (0 points)

    David,

     

    the safe-boot followed by a restart sorted out:

     

    • USB functionality in the Apple 30" display which had disappeared since installing ML last night
    • made the bluetooth magic mouse stable again (previously it would connect and disconnect every 5-10 seconds)

     

    Thank you

  • benekk Level 1 Level 1 (0 points)

    I have a Belkin Class 2 Bluetooth USB Adapter (Version 2.0 + EDR) which I bought earlier this year. I've just decided to upgrade to Mountain Lion and my bluetooth keyboards stopped working... It was a bit strange because they worked for a few minutes, but then they dropped off and I wasn't able to re-connect again. Sadly I didn't know about this issue beforehand... Can anyone confirm whether this bluetooth device definitely won't work with the latest 10.8.2 update? For the time being I'm just doing a backup restore to go back to the old operating system. I have a Mac Pro 5,1 which, although it has bluetooth built-in, I found the connection so bad that I had to disconnect it and use the USB adapter instead... I'd rather stick with the stable bluetooth connection and older OS... Shouldn't've upgraded!

  • ytsentas Level 1 Level 1 (0 points)

    Try using SX Virtual Link software instead. Latest version can be downloaded from http://www.silexamerica.com/support/software/svl.html

    Works like a charm on 10.8.2

  • ericp7000 Level 1 Level 1 (0 points)

    Just fried a belkin hub, same model I was using for years with my older (2006) mbp.  It literally heated up and burned so much you could smell it.  The hub was bought new just 2 weeks ago.  Very glad it did not hurt my new mbp.  Upgraded to 10.8.3 yesterday.  This is after quickly burning up a 3rd party hub (also new) with 10.8.2 very quickly.  IMO, this is a hardware problem with the mbp.  This model is late 2011, intel i7. 

     

    I would read all 5 pages of this thread, but it looks like the problem is unresolved.  Maybe a powered hub would work, and I will test.  But underpowered usb is pretty lame, and adds an extra wall wart. 

     

    Makes me wonder if my initial problems trying to get an external ssd to work are related.

     

    grrrrr....

     

     

    ep

  • David A. Gatwood Level 3 Level 3 (580 points)

    No, the problem everyone else had is definitely resolved in 10.8.2 (and later).  If you're having a problem with the hub burning up, then your problem is completely unrelated to the (comparatively very simple) problem that everyone else here was having.

     

    Either:

     

    • The Belkin hub you just bought was defective or
    • Your MacBook Pro is putting out too much voltage on the USB port

     

    I assume you can return the hub and get a replacement.  If the replacement fails in the same way, contact Apple support immediately, because something is very wrong with your Mac—potentially dangerously so—and it needs to be repaired ASAP.

  • ericp7000 Level 1 Level 1 (0 points)

    Thanks for the reply, David.  I am beginning to suspect that charging my cell phone from the mpb is causing the problem.  I have burned up 3 usb hubs, 1 belkin and 2 generics.  But I MAY have had the phone charging during all the incidents, don't remember for sure. 

     

    Do you think it's possible that the phone pulls too much voltage and fries the hubs?

     

    Today I am trying a new Belking 7-port powered hub, and so far so good.  But I'm a little scared to plug in the phone...

  • David A. Gatwood Level 3 Level 3 (580 points)

    It's certainly possible if Belkin botched the hardware design really badly (e.g. using too narrow a trace for the amount of current that it advertises itself as being able to provide).  Such things shouldn't ever happen, but you know the difference between theory and practice....

  • JanSKay Level 1 Level 1 (5 points)

    I found this discussion while trying, once again, to find a fix for my long time issue with the Belkin hub. I just wanted to let you all know it is not exclusive to Mountain Lion. I'm still using Lion and the problem probably started about a year ago. I would assume from what I've found so far, Belkin just hasn't kept up with needed drivers.

  • -groovatious- Level 1 Level 1 (0 points)

    Just wanted to say I'm having this problem too.

     

    I have a Belkin 7-port hub which worked absolutely fine with my old Mac Mini.

     

    I recently upgraded to a Late 2012 Mac Mini and the USB hub becomes unresponsive after periods of time.

     

    A restart will fix the problem temporarily.

Previous 1 2 3 4 5 Next