Previous 1 2 3 4 5 Next 74 Replies Latest reply: Nov 26, 2014 5:35 AM by gecsonio Go to original post
  • ZM5W61Aki5 Level 1 Level 1 (0 points)

    I was having the same problem too, but after disabling Notes for all accounts except iCloud (in System Preferences > Mail, Contacts & Calendars) it now works fine

  • Miles Cortez Level 1 Level 1 (0 points)

    This worked for me.  Thanks Justin.

     

    1. click on mac HD/ libraray /caches. drag all the contents in the folder to the trash

    2. click on the finder click go, hold the option key and clikc on libraries (will not appear if you don't hold the option key). go to the caches folder again and again drag everything in the folder to the trash.

    3. click on the finder click go, hold the option key and clikc on containers. Drag com.apple.notes to the trash

    4. restart your computer.

    5. empty trash.

    6. try to open notes again

  • tpkatz Level 1 Level 1 (0 points)

    This was the solution for me. I just added outlook and as soon as I unchecked the notes for the outlook account in mail/contacts/calendars works again no problem.

  • NIKKIBRO Level 1 Level 1 (0 points)

    thanks

    having the same problem since last night

    notes would give me the spinning rainbow ball and I kept opening and reopening and force quitting

    no promlems now

  • Robet Rackl Level 1 Level 1 (5 points)

    This also worked for me as a last resort (but it deleted all notes!)

     

    ensure Notes was closed

    delete the contents of ~/Library/Containers/com.apple.Notes/Data/Library/Notes/

  • Garnet_Clark Level 1 Level 1 (0 points)

    Worked for me as well, had two ~/Library/Containers/com.apple.Notes/Data/Library/Notes/ folders and deleted one (Notes) to rid my self of the two icloud account problem.  Rechecked iCloud account and all notes returned.  Make sure to move all notes to active iCloud account and check sync before doing this.

  • teckboy Level 1 Level 1 (0 points)

    Thank you so much bcheang, your solution worked perfectly and has saved me a lot of agrovatoin.

  • Paul Taroli* Level 1 Level 1 (50 points)

    Process:         Notes [733]

    Path:            /Applications/Apple/Notes.app/Contents/MacOS/Notes

    Identifier:      com.apple.Notes

    Version:         1.5 (107)

    Build Info:      Notes-107000000000000~3

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [131]

    User ID:         501

     

     

    Date/Time:       2013-07-19 12:33:39.235 -0500

    OS Version:      Mac OS X 10.8.4 (12E55)

    Report Version:  10

     

     

    Interval Since Last Report:          359983 sec

    Crashes Since Last Report:           9

    Per-App Interval Since Last Report:  7 sec

    Per-App Crashes Since Last Report:   9

    Anonymous UUID:                      AE416A17-5C9A-DC6E-5228-DBA27EB4130D

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_CRASH (SIGABRT)

    Exception Codes: 0x0000000000000000, 0x0000000000000000

     

     

    Application Specific Information:

    *** Terminating app due to uncaught exception 'NSUnknownKeyException', reason: '[<SharingController 0x7f9cf3a360e0> addObserver:<NSKeyValueObservance 0x7f9cf3c09970> forKeyPath:@"delegate.sharedNote" options:256 context:0x0] was sent to an object that is not KVC-compliant for the "delegate" property.'

    abort() called

    terminate called throwing an exception

     

    Tried every solution I read in all support treads ... NOTHING WORKS!?!?!  ANYONE?!?!

  • Paul Taroli* Level 1 Level 1 (50 points)

    So I went to the Genius Desk today. They suggested that I reload Mountain Lion...after back up of course. So I did and it worked...Notes is now working again.

     

    There you go...took about 3-4 hours depending on your connection...I suggest ethernet when doing the Lion re-install.

     

    pt

  • rustic39 Level 1 Level 1 (0 points)

    This worked for me, too - unchecked notes in System Prefs>Mail, Contacts and Calendars>iCloud. Rechecked box, allowed sync from the Cloud, all is well.

  • Washington.Cabral Level 1 Level 1 (0 points)

    Cleaning the caches worked for me. Although this forum is over a year old. The same behaviour came up with last week Mac OS update. Thanks!

  • demeily Level 1 Level 1 (0 points)

    Looks for the folder 'com.apple.notes'

    You probably have two or more folders with the same name

    Delete all except the most recent of those folders

    Relaunch notes.

    You should be fine

  • three-d Level 1 Level 1 (0 points)

    I did all this, and then realized  (too late) that I was not backed-up by Icloud. Now -- Notes does open up (was continuously crashing), but all notes content is gone.   I did not empty trash with com.apple.notes and other files/ folder and now have on my desktop, but can't seem to place it back correctly to bring back Notes content when relaunching. 

     

    There are several of these com.apple.notes folders I see in various places in Container-- so perhaps I am not deleting newer ones, and putting old one back correctly -- and I can see the folders there currently do not have much in them (KB), indicating that they are not the original Notes data  (I had over 200 some notes).  Folders I do have  saved to put back is com.apple.Notes folder with file cache.db-wal which is 3.1MB in size.  Also Notes folder with a file NotesV1.storedata-wal which is 4.1MB size.

     

    Any advise on how/where to replace com.apple.notes and Notes folder mentioned above -- to restore original Notes data.   Before I emptied out the cache's and container folder -- I was at least able to find the individual  Notes documents via Spotlight search -- but now Notes program has not content, and nothing shows on Spotlight search.

     

    I hope the notes content is not lost forever.  Can you help?

  • silirap Level 1 Level 1 (5 points)

    I've had this happen to me twice in Mavericks. Once back in Decembr 2013 and then again today. Each time, the culprit was a Login item that was not playing nicely with the rest of the system. I simply deleted it and everything was fine.

     

    To do this, go into System Preferences --> Users & Groups and click the Login Items tab to see a list of applications that open automatically at login. At this point, you can either delete all the ones that are not from Apple and then restart, which should fix the problem. Or you can try deleting one at a time (restarting each time) to see which one is the culprit.

  • gecsonio Level 1 Level 1 (0 points)

    I noticed the same issue the first time I opened Notes after upgrading to Yosemite. I have two accounts with notes synced, i.e. Gmail and a corporate Exchange one. I suspected the problem came from the Exchange one, but I wasn't sure.

    The following worked for me:

    1) disabled the Notes syncing for both accounts in the Accounts settings in System Preferences

    2) moved ~/Library/Containers/com.apple.Notes to Desktop (could be moved to trash of course) as suggested above

    3) did a Logoff

    4) opened Notes to check: now it worked fine, but of course my notes were gone.

    5) closed Notes

    6) re-checked Notes syncing for Gmail in System Preferences: it worked fine after a couple of seconds 'spinning'

    7) try to re-check the Notes also for Exchange, but after a much longer 'spinning' the option was again unchecked. So I deleted the Exchange account entirely and re-created it with Notes checked: now it worked fine

    8) opened Notes again, and now all the notes from both accounts were back and the edit/sync worked fine.

     

    I think the point is that for some reason the data present in com.apple.Notes did not survive the upgrade to Yosemite: the cleanest way to recover it is to force the system to rebuild them by syncing with the servers from scratch.

    Hope this helps

Previous 1 2 3 4 5 Next