4 Replies Latest reply: Feb 13, 2013 8:28 PM by Wooky
Raja Hornstein Level 1 (35 points)

The recent section in the Aperture library is supposed to contain the last few months, the last import, the photo stream, etc. My recent section has started to have a mind of its own. The first item is a project from several months ago. I can't delete it, or move it, or do anything with it and I don't want it there. The second item is supposed to be Last Month. It is empty, although I've imported hundreds of photos in the last month. Also, when I change the preference for the range of months, nothing changes. Last Import is also empty. Photo Stream, Flagged, Rejected and Trash all work fine. How do I make this section work? This is completely flaky. I've tried trashing all the Aperture preference files to no avail. This was happening in Lion, but upgrading my system to Mountain Lion and Aperture to 3.3.2 didn't change anything. Help!

Aperture 3, OS X Mountain Lion
  • William Lloyd Level 7 (21,030 points)

    Two things:


    First, it's actually a bit confusing regarding the project at the top of the recent projects list.


    The way that project is set is if you go to the Projects view under library that shows the thumbnail views of all your projects.  If you double-click a project, then that project will be set as the "recent" project at the top of the list.


    This confused me as well until somebody told me how it worked.  Simply clicking projects in the sidebar won't set that.


    Second, as far as "last month" I was having some problems with that smart album in the 3.3.1 update.  It wasn't updating properly.  3.3.2 has resolved it for me.  Try going to Aperture's preferences and under General, click one of the arrows next to "Show next X month album" where you change X from 1 to 2 and back to 1.  See if this "unsticks" things.

  • Raja Hornstein Level 1 (35 points)

    Thanks for the double-clicking the project tip; it worked as you described. I had already tried changing the number for the "show last x months album" clicking it back and forth, off and on, but nothing changes and the album remains empty. So does the Last Import album, even after I tried to import some photos today just to see if the update for Mountain Lion might have gummed something up. By the way, in the smart album section, "in the Last Month" works just fine.

  • parish_chap Level 1 (15 points)

    Thanks for the explanation William.


    I did discover that if you open your Aperture album in iPhoto it will update the Recent Project in Aperture.


    Regarding the Last X Months Smart Album. It works for me, i.e. select it and there are photos there, but there is no count at the right hand side of the Inspector window. All the other items under Recent have a count. Is this normal?

  • Wooky Level 1 (0 points)

    Not sure if I can revive this chain but I have an issue with "Last Import" in the RECENT section of Aperture... it shows some count (like 44) but can't see any picture in there... what needs to be done or is it supposed to be like this? Can u give me some advice? Much apprecaited. Y