Previous 1 2 3 4 Next 53 Replies Latest reply: Apr 3, 2015 9:24 AM by CAPR Go to original post
  • rvjacobs Level 1 Level 1 (0 points)

    Hello you all,

     

    I also had the problem of a disconnecting wifi while my imac was sleeping. I did not have the reconnecting issue after sleep, but the lost connection issue during sleep which made it impossible to reach my imac for things like homesharing, apple tv or remote desktop. I have a late 2012 iMac with a clean ML 10.8.2 on it and wirelessly connected to an apple time capsule (same as an airport extreme). My partner has a mid 2007 iMac, also with an ML 10.8.2 on it.

     

    I tried every single solution I could find on the internet, such as changing the router's security from wpa2 to wpa, changing the MTU from automatic to manual 1453, router reboots, re-installations, re-configurations, keychain clean-ups, everything.

     

    Eventually I solved my problem with these steps and now it works as a charm. I can still find the iMac with the remote app, even after 12 hours of sleep:

     

    My time capsule router is set on automatic MTU and encrypted with WPA2 and I use  the 5Ghz network!

    1. Cleaned all the wifi passwords in keychain on my iMac

    2. Created a new network location in system preferences

    3. In this location I deleted the bluetooth pan and bluetooth dun connection.

    4. In this location I changed the preferred connection-order to wifi on #1 and ethernet on #2.

    5. Restarted my iMac.

     

    Now I still have a connection when it sleeps and I can wake it to low profile using the remote app (homesharing) and everything works fine.

     

    Hope more people wille be helped by this.

  • mike134 Level 1 Level 1 (0 points)

    This solution worked for me as well! what a relief! Its strange that its 1453. 1454 is too big! I thought it was based off my ISP.

     

     

    Thanks again!

  • rickjscott Level 1 Level 1 (0 points)

    This solved wifi disconnecting every 10 - 20 min (hmm like when energy saver goes to sleep?). Uncheck in energy saver 'put hard drives to sleep' and 'wake for network access'. After that I've never had an issue. Delete any profile you have after (Network(advanced), Keychain). Apple please fix this.

  • LYFE4ALYFE Level 1 Level 1 (0 points)

    This worked perfectly! Thank you for posting this.

  • webdaemon1@me.com Level 1 Level 1 (0 points)

    Im having thius same problem on my brand new MBA 13 2013 and this worked perfectly.

     

    Thank you for sharing your fix, it was really ******* me off.

     

    I have Comcast internet serivce if that means anything to anyone else.

     

    I recommend anyone with this problem try this, it won't even disconecct you when you make the change.

  • kinshuk_MBP_RD Level 1 Level 1 (0 points)

    Just made the changes to my setting. Hopefully it works as it had worked for so many users. Mine is the latest MBP 13" with RD running on OSX. Will keep you posted.

  • kinshuk_MBP_RD Level 1 Level 1 (0 points)

    I have the same network and the lates MBP 13. Just made the changes. Keeping fingers crossed.

  • Vitezslav Level 1 Level 1 (0 points)

    My solution is: set the static IP.

     

    My MBAir on Mountain Lion disconnects every 1 minute for about 20 seconds, that makes me crazy. Aftery this disconnection is gone.

    Thank you guys!

  • theo.c Level 1 Level 1 (0 points)

    I had a similar disconnecting problem.

     

    After all, I saw that Wifi had disconnected after I forced my router to accept many connections (I was in a Skype call, downloading stuff and had two other people connected to my network as well).

     

    It was all because of the 802.11g router I had. After replacing it with a newer one (802.11n) it worked well because it could manage several more connections at once.

     

    I realised this was the problem when I stopped my downloads and wifi didn't disconnect until I started them again.

     

    Hope that helps!

  • famora1979 Level 1 Level 1 (0 points)

    hi, i have the same problem whit my MBA 11 i7 2013

     

    change security to WPA2 PERSONAL only ....

     

    when wifi drops security was WAP/WAP2 PERSONAL

     

    apple please solve this

  • rickjscott Level 1 Level 1 (0 points)

    I bought an airport express and have never had a probem since. ever.

  • gibsy12 Level 1 Level 1 (0 points)

    i just bought my first mac and well that is not what i expected.. no real fix withing months for a obviously common error.

     

    im having both reconnects and an incredible bad ping - on most of my common networks.. i'm almost thinking apple is counting on us not to recognice the bad ping (most of us dont).

  • Mr_Mac_Guru Level 1 Level 1 (0 points)

    Applepro72 THANK YOU SO MUCH!! IT works like a charm!! You are the best!!

  • Applepro72 Level 1 Level 1 (0 points)

    Ok this worked for me. I had the same exact problem. GO into system preferences, then click network.

     

    After that click "Advanced"

     

    Then there should be sort of a toolbar of options. CLick the last name named "Hardware"

     

    Click the button that says "automatically" and switch it to manually.     (Configure)

     

    Then click the button below it and change Standard to Custom (MTU)

     

     

    Then the little number scale that says 1280-1500. Manually change the number to "1453"

     

     

    and BOOM!   It works perfect

     

    ps. your welcome

     

    See if this works if not tell me

  • n2_k Level 1 Level 1 (0 points)

    Guys, seriously. I AM GUILTY of trying to diagnose and fix this problem myself. I literally went through ten forums and tried 11 different things.

     

    EASIEST thing: CALL APPLE SUPPORT!!

     

    one step. I put some network folder in the trash and that cured everything for me.

     

    I regret not calling them sooner. Two min solution that these forums would have never led me to. I was getting super frustrated un-necessarily. They are experts for a reason.. lol. the rest of us should stick to our day job