Previous 1 2 3 Next 30 Replies Latest reply: Oct 19, 2013 8:42 PM by johnnygoodface Go to original post
  • John F. Whitehead Level 2 (380 points)

    I had a similar problem - items supposedly in iCloud (visible in iCloud under the Numbers File > Open menu) were not getting synced up to iCloud (not showing up on iCloud.com or shown in System Prefs > iCloud > Manage…

     

    They didn't display "Waiting" though, they showed the last modified time, so there was no indication that they weren't syncing.

     

    Deleting Networkinterfaces.plist and restarting fixed it for me.

  • PC-to-Apple Level 1 (0 points)

    The iCloud interface in iWorks has been working seemlessly for the past two weeks, when I originally upgraded to Mountain Lion. As of this afternoon, however, I've started seeing the same "Waiting" message next to most of my files, with an X at the upper right-hand corner, just like described above. A couple of files are showing up normally on the iCloud window, but also cannot be opened. I tried deleting Networkinterfaces.plist and restarting - this did not work. I've tried removing access from iCloud, restarting, then re-connecting - this also did not work.

     

    Luckily I was able to download all my files from the web interface, and they aren't damaged, so I haven't lost those documents. And if I upload them back to the iCloud in my browser, I can access them fine from my iPad and iPhone, just not the iMac. Unfortunately, I've lost the ability to do one of the major tasks that convinced me to upgrade to Mountain Lion - saving files from iWorks directly onto the iCloud. I'm really hoping Apple fixes this bug soon.

  • AshevilleBob Level 1 (0 points)

    My problem earlier was Intego VirusBarrier was blocking the sync. One I updated Intego, the problem was fixed.  Maybe you have a similar issue.

  • PC-to-Apple Level 1 (0 points)

    I don't have that running on my iMac, and I've made sure everything else is updated. Still not working.

  • AshevilleBob Level 1 (0 points)

    Have you tried booting in safe mode?  http://support.apple.com/kb/HT1455

     

    If cloud syncing works in safe mode, then something you've installed is interfering.  

  • PC-to-Apple Level 1 (0 points)

    Just tried...still not working.

  • AshevilleBob Level 1 (0 points)

    Did you upgrade Mountain Lion to 10.8.1 today?  If not, try that.  I did and my syncing still works fine

  • PC-to-Apple Level 1 (0 points)

    Just updated a few minutes ago, after trying the safe mode option. Still not working.

  • PC-to-Apple Level 1 (0 points)

    I've now switched to WebDav to move my iWorks files between devices. I love iWorks, and I love other iCloud shares, but I don't trust the iCloud for doc storage right now. Please get this working better, Apple - I miss it!!!

  • tonyshiver Level 1 (0 points)

    I just tried this, and, unfortunately it didn't work for me either.

    I upgraded to 10.8.1 yesterday hoping that it would fix my issue, but no luck.

     

    I guess I'll just have to keep waiting.

  • PC-to-Apple Level 1 (0 points)

    I just got off the phone with Apple Customer Support, who got iWorks working with iCloud again in less than 15 minutes. To troubleshoot, they first had me create a new user account on my iMac Computer. Once logged in to that new computer user account, I set it up to access my iCloud docs. iWorks accesssed iCloud on this new user profile with no problem. We logged back into my user account, where it (maybe not surprisingly) still didn't work.

     

    Next, to try and fix the problem in my normal user account, we opened the Finder, held the option key down until the "Library" option appeared, clicked on Library, opened the "Application Support" Folder and looked for a folder named "Ubiquity". We deleted the file and restarted the computer; iWorks now accesses the iCloud without a problem.

     

    The support technician said that this kind of problem can happen when files aren't completely uploaded on one device, subsequently opened on another and edited, creating a file conflict. The same thing has happened to me with Dropbox a few times, especially since mutliple users can access some of my shared files. Unlike Dropbox, Macs store the iCloud sync conflict in a folder as sort of an "unfinished conversation", and the program can't sync as long as that unfinished conversation is hanging around. He said any kind of syncing can cause this type of issue, but iCloud syncs should get better over time.

     

    In the meantime, I'm going to try and be much more diligent about making sure files are completely synced before closing apps on both my Mac and iOS devices.

  • tonyshiver Level 1 (0 points)

    I tried this and now ALL of my documents are now "waiting" where prior to this only a few were "waiting".

  • PC-to-Apple Level 1 (0 points)

    Did you try setting up a phone call with Apple Support? They might have the best ability to diagnose this issue - sounds like there are a few different places things can get stored away.

  • TubemanFin Level 1 (0 points)

    My Numbers and Keynote files from ML did not sync to iCloud at all and they were not visible in iOS Numbers or Keynote. Strangely the Pages files were all synced. The above mentioned "opened the "Application Support" Folder and looked for a folder named "Ubiquity". We deleted the file and restarted the computer; iWorks now accesses the iCloud without a problem." fixed the problem immediately.

  • Frank_Begin Level 1 (0 points)

    I tried everything above, nothing worked.

     

    Then I remembered I have "little snitch" installed. 

     

    Even if Icloud has all permissions, turning off little snitch allowed instantly Pages to download all my waiting files.