Previous 1 2 3 Next 31 Replies Latest reply: Sep 2, 2014 4:50 PM by LKPLKP Go to original post
  • CLWaltrip Level 1 Level 1

    How did you use DiskWarrior? I can't seem to find a way to get out of the Mountain Lion Install OS X screen.


    I am having the same problem as everyone else, except my drive fails to verify or repair and doesn't even list specific problems.  It also repeatedly locks the drive, but I've learned the Terminal command to unlock it.  I'm out of town (away from my backups), and I'm also about to buy a new MacBook Pro, so unwilling to spend money on an extra hard drive or other fixes.  I believe I already have DiskWarrior, if I can just get to it...


    Also, I only have 10 GB free on the hard drive.  Do I need to free up more space to get the install to work?

  • illinigldbear Level 1 Level 1

    I have had the same hard drive issue.  I first thought my hard drive was full and that caused the issues mentioned above.  I purchased a new 750 Gig hard drive, had the Apple Store install "Lion".  It worked fine for a few days so I tried to install Mountain Lion from a new download I received from the App Store.  It worked for 1 or 2 days then it started having issues with the system locking up.  I rebooted, tried the "Internet Recovery" option, no luck.  I tried the "Disk Utility", "Verify Disk"  Now I get the error that the hard drive has a problem.  So now I have reason to believe that the Mountain Lion Update is causing the system to think that there is an error for a new hard drive. 

  • JL70115 Level 1 Level 1

    I had the exact same issue. The Genius Bar jumped through the typical hoops and finally tried to re-partition the drive. As soon as the re-partition failed he said the drive was dead and he swapped it out with a new one. I was out of there in under 30 minutes with a new hard drive. Other than a lengthy update at home and restoring files from Time Machine, I'm as good as new.

  • trshephfromchesterfield Level 1 Level 1

    I also have a 2010 MacBook Pro and after a week of successful Mountain Lion use, yesterday I had the same issue as reported above.

  • PJL500 Level 1 Level 1

    Same here. After a week of ML use the machine suddenly just shut down cold - straight to a black screen. I can only get Lion to run. ML fails during install (after rebooting it shuts down right after the grey screen with the spinning wheel)- even after a clean Lion 10.7.4 install.

  • danhamilt1 Level 1 Level 1

    Don't expect your Mac to break down after one year?! My first ever Mac's Harddrive failed after 2 days! haha it made some brilliant noises, but I backed up from day one so a straight swap and Time Machine recovery and all was good!

    I always treat my harddrive data as though I have written a really important piece of information on some toilet paper.

  • Benfromkualalumpur Level 1 Level 1

    guys , my mac mini is having the same issues, to be clear, my hdd clicks and fail and my external disk keep disconnecting, I have connected 2 hdd externally and i fear that one external disk is failing. disk utility cannot recognize my external disk anymore.




    Apple please fix this.

  • cjago Level 1 Level 1

    Had the exact same problem. Could not install Mountain Lion so far - no matter what I try (disk repair, reset PRAM, external drive boot etc) it always comes up with this "hard drive corrupt" error.


    This is definitely a software problem and in NO WAY that your hard drive is bad or "on the verge of failure". Somehow the installer corrupts the permissions, and then considers the hard drive "corrupt" and "unrepairable". Unbelievable that such an error (which tons of people seem to have!) can happen with an Apple product. Well... not the same ever since Steve Jobs isn't at the helm anymore. :-(


    So, here at least is how to reboot your old system (without formatting the hard drive or taking it to the Apple store):


    When the error occurs, reboot, and while rebooting hold down "Command-R".


    Once rebooted and the "installation not complete" or "continue with installation" message appears, go to "Startup Disk" in the Apple menu and select your standard disk as startup.


    If it doesn't appear there, you might have to go to disk manager and repair it first.


    Reboot and you're back in your old system.


    You can then run a "permissions repair" with Disk Utility, and will see that tons of permissions are bad, even when they were completely fine before the installation.


    There is no problem with the hard disk whatsoever. And subsequent runs of "disk repair" or "permissions repair" will all work completely fine. It's the installer that screws it up.


    Apple, you have to fix this issue!

  • chuanist Level 1 Level 1

    FWIW a similar problem occurs on 2007 - 2008 iMacs when people attempt to intall Snow Leopard. The computer won't boot and disk utility (run from an installer DVD) reports a disparity between the number of folders and files. However, running 'repair volume' on D.U. does not resolve the error, which continues to be reported.


    I got this error on a client's 2008 iMac after installing Snow Leopard over Leopard and, assuming that the hard drive had failed, installed a brand-new 1 tb drive in the machine. Then I installed Snow Leopard again and got the very same error message with the brand new drive. So it ain't always indicative of a hard drive problem.


    Since this episode (which cost me quite a few hours to track down and verify) I have checked various forums and discovered that Apple's more recent OS's are all-too-well-known for this and other problems.


    Naturally none of us have received any advisories from Apple about this f-ed situation, let alone a fix.....

  • GoFastTurnLeft Level 1 Level 1

    Same problem here with my 2007 iMac. Tried to install ML Wednesday night and now I am hosed it appears.


    After installation it restarted and never booted. Just continued with the Apple logo and spinning icon. I restarted and it still would never boot. I did that a few times but no luck. Acted similarly when installing Lion but after a couple restarts it was fine. After looking online I tried recovery mode and attempted to install again. No luck. Got message about HD problems and attempted to repair with Disk Utility. Like the rest of you it said that I needed to backup and erase.


    After a few tries, neither the ML installer or ML recovery showed up any longer. I then broke out my Lion USB installer but it wouldn't install either.


    I went and bought an external drive to attempt backup. I tried to use Carbon Copy Cloner to clone it first so may I could put things back when it was all over. A little bit into the cloning everything fritzed out and the screen started scrolling all kinds of text and code. I shut down and called it a night. Again.


    My next attempt I found that the HD was not even visible for either installer or Disk Utility. I then installed Lion onto my external drive and installed a Time Capsule backup. I am in the process of backing up all the info from there just in case.


    For the last two days the HD has not been visible. Now this morning after starting from the external drive, my original HD showed up on the desktop. *** ?? And this is after erasing the drive a couple of times during all this process. But there it was ..... It appeared to contain all data before everything happened. I started copying directly from there to my other drive. While copying I got a message that disc was ejected improperly and now it is gone. BUT .... It is still continuing to copy files ......


    I'm about to give up and go buy a new one if I can't get this figured out. Hopefully someone can help me out.



  • sirfan98cs Level 1 Level 1

    I have macbook pro 17 inch OS X 10.7.8 Lion. Yesterday I logged in after few weeks and found there is a 1.23 GB software upgrade available, part of it is OS upgrade.


    I ran the software upgrade and it downloaded 1.23 GB on machine and ask for reboot, I did so.


    Since than the machine is not returned back to normal state.


    The problem is seviour and I dont know what could be further implecation.


    Machine is not booting beyond gray screen with apple logo.


    I already try following steps


    Starting in Safeboot and it didnt work


    Try pressing the option key and started in recovery mode


    Try searching online solution running disk utility all failed


    Disk utility is unable to move beyond "checking catalog file"


    Allmost done with everything and dont know what else to do.


    Some one said DiskWarrior could potentialy solve the issue, however in my case I may not be able to install any application.


    Any advice will be highly appreciated.


    Many thanks in advance.

  • Capt.Video Level 1 Level 1

    WOW, I think I'm glad I read all these posts.

    I have a 2010 iMAC with a solid state drive using a fully updated Snow Leopard OS. I back up regularly with time machine. In contemplating upgrading to ML, at the suggestion of David Pogue in his OSX Mountain Lion Missing Manual, I ran Disk Utility on my SSD prior to attempting any upgrade. I got the same messages as have been reported here.

    Missing thread record (id = 998690)

    Incorrect number of thread records


    Invalid volume file count


    The volume iMAC SSD was found corrupt and needs to be repaired.

    Error: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk.

    I have had absolutely no problem with my computer so am now petrified to try "fixing" the alleged problems or downloading and installing ML.

    Even though there are some benefits in ML, none come close to overriding the problems you all have described.

    Anyone have any advice? I plan to call Apple Care tomorrow or Friday for their take as I still have my protection plan. Until then, SL it is and SL it shall remain.


  • nigelman08 Level 1 Level 1

    I have the same issue. 2 days after installing and successful using of ML in a MBP mid 2009 with BootCamp and Win7, when I tried to start my machine, it crashed. I tried to repair it and Disk Utility showed the same error you have: "Incorrect number of thread records". Then, I tried to do a fsck, and the result was HD sector failure. I decided to buy a new HD. After installing it, doing a new ML installation and installing windows with BootCamp, and only with Firefox, Chrome, Office 2011 installed (in this order) on my OSX, I tried to install XCode and the system crashed and reset. ML started without problem and I retried to install XCode. All worked fine, and then I installed the Command Line Tools on XCode. I shut down my computer, and some hours later I tried to switch on my machine and the same issue again.

    In that moment I thought that the problem was XCode, but in a new installation in my OSX partition, I tried to install only XCode with tools and no problem. Now, after reading your posts, I know that ML is a delayed explosion bomb.

  • pcos Level 1 Level 1

    I had the same problem.  When upgrading from Lion to Mountain Lion the install fails and gives a disk error that it cannot fix;  whereas whenever I reinstall Lion  and run disk util it shows no disk errors.  Tried the install three times, with small changes but same result each time.  Then Contacted Apple support and we tried a few things (which again didn't work for me) and they suggesed booking an appointment to have the drive replaced.


    Before doing that, I disabled file vault and retried. Was then able to sucessfully run the upgrade from lion to mountain lion. My SSD was fine.

  • nigelman08 Level 1 Level 1

    A few days after that, my filesystem crashed again and I decided to return to Lion. No problem after that.

    Pcos: File Vault was disabled always in my installs, so this is not my problem. Maybe Maverick will work better...