Previous 1 2 3 4 Next 109 Replies Latest reply: Jul 29, 2013 11:40 AM by returnofthemac23 Go to original post
  • bigunyun Level 1 Level 1 (0 points)

    me, too... when I put in our internal server as "EXCHANGE02" and save the changes, Mail for some reason automatically switches the internal server to ""... but I am INSIDE our network...



  • cmsmith Level 1 Level 1 (0 points)

    So I found a temporary patch, but not a solution. First, make sure that your external server is set correctly in each app individually. For me, Calendar wouldn't update/authenticate. Mail would be ok on first open, but if I would switch to another inbox, all of my exchange messages would disappear when I came back.


    The patch is to open only one app at a time. Mail or Calendar, and I don't have any problems as long as I fully close out of one before opening the other.


    Like I said, it's not a fix. But at least may get you through until Apple can provide an update. I haven't tested this with notes or reminders in any configuration.

  • Ondray Wells Jr. Level 2 Level 2 (225 points)

    I'm having the exact same issue.  All of my Exchange enabled apps that worked fine in Lion now will not connect to the Exchange server in Mountain Lion.  I set all of these apps to use the EWS server for a reason.  That way it did not matter if I was at work on the corporate network or at home on my own network. All the apps just worked! Now Mountain Lion is trying to be too clever by half.  I went to System Preferences and selected my Exchange account and clicked Details ... hoping to be able to modify the server settings.  Unfortunately, you are only able to enter your name and password.  I've never used the internal server or entered its information on any app.  So ML must be getting that info automatically by using the domain name in the email address.  That was bad enough that my settings were changed.  It was downright infuriating to find out that when I changed it back ML decides to override what I explicitly told it to use.  I was able to enter the EWS server in the External Server setting.  I also checked the Use SSL checkbox.  That sort of works for Mail. If you aren't on the corporate network it still stupidly gives you an error message several times because it tries to connect using the Internal Server first instead of recognizing you aren't on the network and using the External Server by default.  But after clicking Continue it seems to behave itself.  Taking this same approach in Calendar and Contacts doesn't result in these error messages but unfortunately, these apps simply refuse to connect using the External Server at all.  The Reminders app has the same issue because even though it has its own UI it's still using Calendar under the hood. I don't use Exchange Notes so I can't speak to whether it works or not.


    Bottom line?  I can't work remotely outside of Mail.  There's simply no excuse for a major bug like this to make its way into a public release.

  • Luke Manhood Level 1 Level 1 (15 points)

    Same issue as well. Have Contacts, Calendar and Reminders working using the external server settings, but mail keeps changing the details of the internal server back, and even when set, isn't displaying read messages in any folders.


    Suggest everyone having problems select 'Provide Mail Feedback...' from the 'Mail' menu in


    Message was edited by: Luke Manhood - added details for providing feedback to Apple.

  • Ondray Wells Jr. Level 2 Level 2 (225 points)

    It appears the workaround of editing the /etc/hosts file as suggested earlier works.  For those less technically inclined this is how to do it:


    1. Close Mail.  Wait a few seconds and then open it back up.  Got to Preferences - Accounts.  Select your Exchange server entry and see what value ML insists upon putting in Internal Server.  Write this down somewhere.


    2. Open up Terminal.  Type "ping" (no quotes) where is the value that you previously used in the Internal Server setting for Mail.  If you're lucky the server will respond at least once.  Write down the IP address (


    3. Open up Finder.  Select Go-Go To Folder menu.  Enter /etc in the dialog and click Go.  Find the file named "hosts".  Copy it to the  Desktop. 


    4. Open up the "hosts" file on the Desktop in TextEdit.  At the end enter the Internal Server name you wrote down in step 1 on the left.  A few spaces over on the same line enter the IP Address you wrote down in Step 2.  Save the file and close TextEdit.


    5. Drag the updated "hosts" file on the Desktop back into the Finder window display the /etc directory from Step 3.  You will need to authenticate with your password.  Be sure to select the replace option.


    6. All the Exchange enabled apps should work now.


    What this does is tell the OS that "" should resolve to the IP address of the actual external server you want to use ... rather than the IP address it actually has.  You've basically "tricked" the system in order to get around this boneheaded change.  So far I haven't seen any issues.  Emails in the Exchange inbox sometimes disappear ... but I have the feeling that's a separate bug.  Switching from one mailbox to another and coming back often fixes this issue.  Restarting Mail seems to fix it consistently when it occurs.


    Hope this helps!

  • Jackson65 Level 1 Level 1 (0 points)

    I just bought a Mac Air less than a week ago and am not a programmer - this mail problem is very frustrating as I now basically have a paper weight .... I think I'm going to return the whole thing in exchange for new machine until they fix mountain lion - this is not right at all and consumers should. Not have to go through these types of back flips to get products to work !!!!  If any one has any simple help I would love to hear it -!  I appreciate the fix listed above but it's not for the faint of heart

  • Brian burrow Level 1 Level 1 (110 points)

    I have exactly the same problem. I change the server and save it and it will sometimes work for a few minutes. I can flip back and forth in the mail settings between accounts and the server will stay as I typed for a couple minutes, then suddenly mail stops working again and I'll check and the exchange server has updated itself..


    We have one server that we use for our computers and iphones and then we have an outlook web access website. These server settings keep being replaced with the url that I access webmail with.. It's not a domain that starts with owa (outlook web access), but rather a different domain.


    I can't remember, but didn't the exchange settings previously in Lion also have a box for a Domain? My iPhone does, but Mountain Lion doesn't..

  • cmbeetle Level 1 Level 1 (0 points)

    Has anyone been able to get a fix for you yet?  I have the exact same problem and it is driving me crazy!!!


    It makes no sense that I can get all of my mail on my iphone/ipad, but not the **** computer!

  • Ondray Wells Jr. Level 2 Level 2 (225 points)

    For those who find my fix above to be too daunting, the only other thing I can think of is to allow ML to auto-configure the Internal Server as it sees fit.  That should work fine when you are on your corporate network.  When you are not, try connecting to your VPN with whatever software your company has issued to you.  That will allow your machine to "see" that Internal Server from outside the corporate network.  It's a pain to have to do the extra step I know. Unfortunately, it's probably going to have to be this or the solution I outlined above.

  • Brian burrow Level 1 Level 1 (110 points)

    For me, the the fix isn't daunting, but probably impossible.. My job is on the road. I have no internal network. I have a work pc, which does require a vpn to access outlook, but on my Macbook air, with Lion, I just needed the server address and my mac would connect with outlook without a vpn. I used the same server address for my mac and my iphone and both worked great.


    Mountain Lion is, however, replacing the internal server with the actual url address that I use to access webmail. So, if I changed the hosts file, I would keep getting redirected when I wanted to access the webmail through my browser.


    I tried using the same server address for both internal and external.. This works for a few minutes but then the address resets for the internal server.

  • ospreytc Level 1 Level 1 (0 points)

    This is rediculous.  I have the same issue.  Exchange account not working.  It seems to change my server info.  I deleted and redid my account.  It worked for a minute and then stopped.  When I checked the account, I saw that it again changed my server info.


    Please fix ASAP.  I depend on this.  And this is very embassassing.  I may never hear the end of this.

  • ebeauzec Level 1 Level 1 (0 points)

    Has anyone received an official response/solution from Apple Support yet, or does anyone on this thread have a ticket open? If not I'll open a ticket and update the group.


    I'm still stuck with the problem, which basically means my new Air is now in the bottom of a drawer. Can't use it for work and will probably return it to the dealer as I dont see the point of rolling back to Lion to get it to work. It's really unfortunate as my whole reason for buying the Air is that my MBP is too bulky to carry around with me all the time (but at least it works).

  • smittyrocks Level 1 Level 1 (10 points)

    Some posts in other threads on this same issue report they did open a ticket and the response was "This is an Exchange issue" Which is going to be Apple Care's first response because they don't want to deal with it. I think going into the store and starting the process with a genius bar rep will be better becasue you can show them the actual issue, the server name chaning. Then if you avhe the ability to show them the same thing on Lion and how it doesn't change the name you will be better off and will get further. Keep in mind that if the genius bar tech can't fix it, then he opens teh ticket with level 2 Apple Care, then one thro to the developer team. I've done this before for other issues as I knew if I called in I would get the run around, doing it in person gets the point across a lot better.

  • dazzysima Level 1 Level 1 (0 points)

    I don't understand why they would change it. It worked in Lion, why tweak it?


    I've rolled back to Lion from ML because of this until it gets fixed.

  • XianNewman Level 1 Level 1 (5 points)

    I also noticed that when you edit subfolders, it will list them in some random order - not alphabetical as I would expect, and as it did in Lion. Makes it challenging to find the folders you are looking for - I now have to scan the entire list.

Previous 1 2 3 4 Next