Previous 1 2 Next 18 Replies Latest reply: Mar 15, 2013 10:21 AM by doraemon100
Loren Ryter Level 2 (495 points)

I continue to maintain a number of AppleScript Studio projects.  Yes, I am aware AS Studio is deprecated and totally unsupported.  It was however possible to install and run XCode 3.2.6 on Lion, which allows me to continue to maintain these projects.  I've been able to successfully build code signed version that will run just fine on Mountail Lion (dev previews).


On Mountain Lion, XCode 3.2.6 actually launches normally and seems at first glance to behave normally (with a couple glitches) and also to be able to build existing prjoects.


Most unfortunately, however, Interface Builder hangs while launching.  I am wondering if anyone has any bright ideas about how it could be made to work.


The first error is in the console:


7/26/12 10:29:28.628 AM Interface Builder[911]: Attempt to add read-only file at path file://localhost/Developer/Documentation/DocSets/ read/write. Adding it read-only instead. This will be a hard error in the future; you must specify the NSReadOnlyPersistentStoreOption.


I tried to make the relevant file read & write for everyone but that didn't help.


And then there is the hang/crash log (portion follows).


Given this log, is there anything at all (ie, frameworks, etc.) that I might try installing from Lion or Snow Leopard to make IB 3 run on ML?




Date/Time:       2012-07-26 10:09:35 -0400

OS Version:      10.8 (Build 12A269)

Architecture:    x86_64

Report Version:  11

Command:         Interface Builder

Path:            /Developer/Applications/Interface Builder

Version:         3.2.6 (851)

Build Version:   34

Project Name:    InterfaceBuilder

Source Version:  8510000

Parent:          launchd [282]

PID:             815

Event:           hang

Duration:        2.11s

Steps:           22 (100ms sampling interval)

Hardware model:  MacPro4,1

Active cpus:     8

Free pages:      1376856 pages (+2933)

Pageins:         0 pages

Pageouts:        0 pages

Process:         Interface Builder [815]

Path:            /Developer/Applications/Interface Builder

Architecture:    x86_64

Parent:          launchd [282]

UID:             501

Task size:       7629 pages (+1)

  Thread 0x813d     DispatchQueue 1          priority 46       

  22 ??? (Interface Builder + 7140) [0x100001be4]

    22 NSApplicationMain + 869 (AppKit) [0x7fff92ed9656]

      22 -[NSApplication run] + 124 (AppKit) [0x7fff92f34a7a]

        22 ??? (Interface Builder + 8579) [0x100002183]

          22 -[IBPluginController loadPluginAtPath:error:] + 2948 (InterfaceBuilderKit) [0x100114531]

            22 IBUpdateCreateVersionMenuItemToReflectDestinationTargetRuntime + 594 (IBCocoaTouchPlugin) [0x10a7306c9]

              22 -[IBPlugin didLoad] + 1809 (InterfaceBuilderKit) [0x100115a73]

                22 -[IBLibraryController loadLibraryObjectsForPlugin:] + 588 (InterfaceBuilderKit) [0x10011671d]

                  22 -[IBLibraryController createAssetsFromTemplatesInNibNamed:forPlugin:topLevelObjects:] + 108 (InterfaceBuilderKit) [0x100266039]

                    22 -[NSBundle(IBAppKitBundleAdditions) topLevelObjectsInNibNamed:owner:] + 127 (InterfaceBuilderKit) [0x1001faac5]

                      22 -[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 150 (AppKit) [0x7fff93119ee3]

                        22 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 219 (AppKit) [0x7fff92edd0a9]

                          22 loadNib + 227 (AppKit) [0x7fff92eddb23]

                            22 _decodeObject + 226 (Foundation) [0x7fff95429fe4]

                              22 _decodeObjectBinary + 2741 (Foundation) [0x7fff9542ac39]

                                22 -[NSIBObjectData initWithCoder:] + 2025 (AppKit) [0x7fff92ede44a]

                                  22 _decodeObject + 226 (Foundation) [0x7fff95429fe4]

                                    22 _decodeObjectBinary + 2741 (Foundation) [0x7fff9542ac39]

                                      22 -[NSArray(NSArray) initWithCoder:] + 538 (Foundation) [0x7fff9542bf88]

                                        22 -[NSKeyedUnarchiver _decodeArrayOfObjectsForKey:] + 1189 (Foundation) [0x7fff9542ba16]

                                          22 _decodeObjectBinary + 2741 (Foundation) [0x7fff9542ac39]

                                            22 -[NSNibOutletConnector initWithCoder:] + 344 (AppKit) [0x7fff92edf1d8]

                                              22 -[NSNibConnector initWithCoder:] + 363 (AppKit) [0x7fff92edf34e]

                                                22 _decodeObject + 226 (Foundation) [0x7fff95429fe4]

                                                  22 _decodeObjectBinary + 2741 (Foundation) [0x7fff9542ac39]

                                                    22 -[IBLibraryObjectTemplate initWithCoder:] + 52 (InterfaceBuilderKit) [0x100116d08]

                                                      22 -[NSView initWithCoder:] + 99 (AppKit) [0x7fff92ee7cf4]

                                                        22 -[NSResponder initWithCoder:] + 99 (AppKit) [0x7fff92ee9595]

                                                          22 _decodeObject + 226 (Foundation) [0x7fff95429fe4]

                                                            22 _decodeObjectBinary + 2741 (Foundation) [0x7fff9542ac39]

                                                              22 ??? (CocoaPlugin + 5633) [0x102684601]

                                                                22 -[NSCustomView initWithCoder:] + 601 (AppKit) [0x7fff92ef7526]

                                                                  22 -[NSView initWithCoder:] + 976 (AppKit) [0x7fff92ee8061]

                                                                    22 _decodeObject + 226 (Foundation) [0x7fff95429fe4]

                                                                      22 _decodeObjectBinary + 2741 (Foundation) [0x7fff9542ac39]

                                                                        22 -[NSArray(NSArray) initWithCoder:] + 538 (Foundation) [0x7fff9542bf88]

                                                                          22 -[NSKeyedUnarchiver _decodeArrayOfObjectsForKey:] + 1189 (Foundation) [0x7fff9542ba16]

                                                                            22 _decodeObjectBinary + 2760 (Foundation) [0x7fff9542ac4c]

                                                                              22 IBPopulateMarshalledStateFromIBIntegrationState + 5203 (IBCocoaTouchPlugin) [0x10a743f47]

                                                                                22 IBIsManagedByTabBarController + 1096 (IBCocoaTouchPlugin) [0x10a7968fb]

                                                                                  22 IBPopulateMarshalledStateFromIBIntegrationState + 7922 (IBCocoaTouchPlugin) [0x10a7449e6]

                                                                                    22 IBPopulateMarshalledStateFromIBIntegrationState + 7673 (IBCocoaTouchPlugin) [0x10a7448ed]

                                                                                      22 IBBuildMarshalledDescriptionOfObject + 178 (IBCocoaTouchPlugin) [0x10a7420f1]

                                                                                        22 IBBuildMarshalledDescriptionOfDocument + 2093 (IBCocoaTouchPlugin) [0x10a741482]

                                                                                          22 IBReplaceClassNamePrefixWith + 1588 (IBCocoaTouchPlugin) [0x10a73d64d]

                                                                                            22 IBIPhoneSDKVersionForSDKIdentifier + 1775 (IBCocoaTouchPlugin) [0x10a7b84df]

                                                                                              22 IBIPhoneSDKVersionForSDKIdentifier + 1708 (IBCocoaTouchPlugin) [0x10a7b849c]

                                                                                                22 IBIPhoneSDKVersionForSDKIdentifier + 2796 (IBCocoaTouchPlugin) [0x10a7b88dc]

                                                                                                  22 IBAskClassInTargetRuntimeForValueForKeyPathUsingResultMarshallerWithContext + 147 (IBCocoaTouchPlugin) [0x10a740af3]

                                                                                                    22 IBAttachToCocoaTouchTool + 1669 (IBCocoaTouchPlugin) [0x10a742a20]

                                                                                                      22 IBAttachToCocoaTouchTool + 1060 (IBCocoaTouchPlugin) [0x10a7427bf]

                                                                                                        22 +[NSThread sleepUntilDate:] + 176 (Foundation) [0x7fff9547288d]

                                                                                                          22 __semwait_signal + 10 (libsystem_kernel.dylib) [0x7fff9762d386]

                                                                                                           *22 semaphore_wait_continue + 0 (mach_kernel) [0xffffff8000233e90]

  Thread 0x8147     DispatchQueue 2          priority 48       

  22 _dispatch_mgr_thread + 54 (libdispatch.dylib) [0x7fff92830a2a]

    22 kevent + 10 (libsystem_kernel.dylib) [0x7fff9762dd16]

     *22 ??? (mach_kernel + 3471600) [0xffffff800054f8f0]

  Thread 0x8156     priority 46       

  22 thread_start + 13 (libsystem_c.dylib) [0x7fff8cbd01c1]

    22 _pthread_start + 327 (libsystem_c.dylib) [0x7fff8cbe3782]

      22 __NSThread__main__ + 1345 (Foundation) [0x7fff95471842]

        22 IBProcessRequestsWithProvider + 3617 (IBCocoaTouchPlugin) [0x10a735913]

          22 IBAttachToCocoaTouchTool + 1060 (IBCocoaTouchPlugin) [0x10a7427bf]

            22 +[NSThread sleepUntilDate:] + 176 (Foundation) [0x7fff9547288d]

              22 __semwait_signal + 10 (libsystem_kernel.dylib) [0x7fff9762d386]

               *22 semaphore_wait_continue + 0 (mach_kernel) [0xffffff8000233e90]

  Binary Images:

         0x100000000 -        0x100011fff 3.2.6 (851) <D7FF2306-4C69-D27E-7051-BD4CE988362C> /Developer/Applications/Interface Builder

         0x100111000 -        0x1003a1fff 3.2.6 (851) <A512A9BB-8C3B-5C9D-AA09-762EEDB290AF> /Developer/Library/Frameworks/InterfaceBuilderKit.framework/Versions/A/InterfaceBuilderKit

         0x102683000 -        0x102788fff 3.2.6 (851) <BD71AD21-A75D-9A68-0D7B-E94D6830B9FB> /Developer/Platforms/MacOSX.platform/Developer/Library/Interface Builder/Plug-ins/CocoaPlugin.ibplugin/Contents/MacOS/CocoaPlugin

         0x10a71e000 -        0x10a816fe7 4.3 (141) <9229634D-8737-3F2B-818F-B087749AC5DE> /Developer/Platforms/iPhoneSimulator.platform/Developer/Library/Interface Builder/Plug-ins/IBCocoaTouchPlugin.ibplugin/Contents/MacOS/IBCocoaTouchPlugin

      0x7fff8cbcf000 -     0x7fff8cc9bfef  libsystem_c.dylib <16B6B86C-53EE-36E8-AC2B-4AADC1008098> /usr/lib/system/libsystem_c.dylib

      0x7fff9282c000 -     0x7fff92841ff7  libdispatch.dylib <0B6B6E7F-4D8A-3F3B-A4BF-6CF34638DBBB> /usr/lib/system/libdispatch.dylib

      0x7fff92de7000 -     0x7fff93a11fff 6.8 (1187) <C9309F5C-9441-3E5B-A120-B03FEDDA63F9> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit

      0x7fff953dc000 -     0x7fff95738ff7 6.8 (945) <0C972F73-0C07-3384-98F2-B176E0289494> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation

      0x7fff9761b000 -     0x7fff97636ff7  libsystem_kernel.dylib <E0447BF5-E104-35B0-B28B-4156887D58F1> /usr/lib/system/libsystem_kernel.dylib

*0xffffff8000200000 - 0xffffff800073d30c  mach_kernel <8D5F8EF3-9D12-384B-8070-EF2A49C45D24> /mach_kernel

Mac Pro, Mac OS X (10.7.4), iPhone 4 (5.0.1)
  • Level 1 (5 points)

    I'm facing the same issue. FWIW, you can compile and maintain your AppleScript Studio projects in Xcode 4 (except for Interface Builder part). Xcode 4 doesn't support AppleScript syntax - which, in my opinion, is  huge disrespect to the users on Apple's part - but you can probably just open and edit your .applescript files in Xcode 3 (I didn't try yet).


    Hopefully, we'll find a solution to run Interface Builfder on Mountain Lion soon.

  • Loren Ryter Level 2 (495 points)

    Good to know it's not just me here.  I've got another thread open on the Developer Forums, and while we're a way off, there is some progress on getting IB to work.  It might be helpful if you could describe your experience in terms of how closely it conforms to what I posted above.


    Also, when you say you can compile and maintain AS Studio projects in Xcode 4, what do you mean if it doesn't support AS syntax?  I found that I could open a project and the syntax hilighting was correct, but builds that succeeded on XCode 3 failed on XCode 4 (without any changes).  Please note that this question is actually a separate one to the main one in this thread.

  • Level 1 (5 points)

    Thanks for the link - I followed the instructions and could open Interface Builder. Didn't try to use it yet.


    Regarding AppleScript: what I meant is that Xcode doesn't support AppleScript code syntax coloring - whether it's AS Studio or AppleScriptObjC. It does support AppleScript itself. You can still write and compile the code but it will be a mjor pain without proper color formatting. But you can just use external editors.


    There could be several reasons why your builds failed, but you just need to check the exact error reported by Xcode 4. When you open an Xcode 3 project in Xcode 4 certain settings can be  different even without changing anything. Some settings just didn't exist in Xcode 3 and the Xcode 4 defaults in your project should be changed. Can be related to SDK, architecture etc.


    Once you fix the errors reported by Xcode 4, you should be able to compile your projects with no problem.

  • Diana Kirtley Level 1 (0 points)



    I had the same error.


    I fixed it by creating a /Developer/Platforms/temp directory and moving everything from /Developer/Platforms/ to the new directory. (Move everything but /Developer/Platforms/MacOSX.platform).



  • Diana Kirtley Level 1 (0 points)

    Oops... apparently you already found the fix. My co-worker helped me with this, so I cheated!

  • Loren Ryter Level 2 (495 points)

    Drat! Got my hopes up there. Yes, that allows IB3 to launch, but there are no connections, or object names, present in the inspector for objects in the AppleScript pallatte. Are you using AS Studio? If so, have you found a work around for that?

  • Level 1 (5 points)

    Just add the IBEnableAppleScriptStudioSupport key to your Interface Builder preferences and set it to YES (boolean).

  • Loren Ryter Level 2 (495 points)

    Thanks, but unfortunately that's not it.  That key is YES already.  This is what I see in IB for a button in an existing project, that's supposed to have a name and a "clicked" connection:



  • Level 1 (5 points)

    You need to select a script to see any handlers. Although I don't know if it solves your problem entirely because the Name should be there regardless.

  • Loren Ryter Level 2 (495 points)

    Of course I know that. I am double clicking on an existing .nib file from the sidebar of XCode 3.2.6 on ML. The names and connections and script selections should already be saved for all objects (from file last opened on XCode 3.2.6 on Lion). However, they are not. It's as if all connections are simply broken.


    I cannot tell you right now for sure what happens when pulling down the "Script" menu on ML, as I'm on my Lion production volume now.  But I recall there was no option to select any existing script.

  • Level 1 (5 points)

    Ok then it looks like something is broken on a different level indeed...

  • SERBIAN_123 Level 1 (5 points)

    If you opened your AppleScript Studio project with XCode 4.x.x and then opened the .nib file, all of your AppleScript conections are lost .. Just do not open AppleScript Studio .nib files within XCode 4 and all should be fine .. I installed XCode 3.2.6 on fresh 10.8.2 manually /without iPhone packages/ and everything is working just fine .. Make sure NOT to install CHUD package or your system will freeze and after it wont boot until you delete all of the CHUD files inside sys folder .. 

  • Loren Ryter Level 2 (495 points)

    That's an enouraging finding indeed.  Unfortunately I am on the way out of time and won't have the time to check this until next week, when I will be sure to do so.  But to my knowledge, the .nib files of the projects in question were never opened in XCode 4.x; I was working only with fresh copies from my Lion system (current production & boot volume), where they work normally with XCode 3.2.6.  So something else must be going on.  Do you have XCode 4.x installed anywhere on your system? Is it installed on your fresh 10.8.2 volume?  What process did you use to install XCode 3.2.6 and in what path?  (DId you need to set back the system date?)  It's also possible that something was fixed between 10.8.0 and 10.8.2.

  • SERBIAN_123 Level 1 (5 points)

    Yes, I do have XCode 4.5.1 installed, but without CLI tools ...I didnt install those since I was afraid that those will mess up 3.2.6 tools.. For Xcode 3.2.6 I just enabled Finder to show hidden files and then found hidden folder with packages on XCode 3.2.6 install .dmg .. Basically, install everything except CHUD tools and iPhone packages .. If you dont know what to install open main metapackage with Pacifist app for example and you'll figure it out what needs to be installed... Since those individual packages are not metapackages, first create folder named Developer and then install in it .. Except packages which goes to various system folder .. Default installer for 3.2.6 checks the sys and it wont work on 10.8 at all .. So you have to do it manually .. My 10.8 sys is updated to latest version - 10.8.2 ..


    I dont know what happened to your .nib files if you didnt open those in XCode 4.x.x. but the fact is if you open it all of your connections in IB will be lost..So dont do that..


    Under 10.7 all is working fine if you upgraded from 10.6, but 10.8 is diff. story regarding AppleScript ...


    I hope that helps .. If you need more help please contact me via .. I'll be more than happy to help you ..

Previous 1 2 Next