1 2 Previous Next 23 Replies Latest reply: Mar 18, 2014 6:31 AM by SnowyJoey Branched to a new discussion.
spstanley Level 1 Level 1 (15 points)

I use Google's calendar and can view it from Calendar (previously iCal) on my Mac.  However, Google's calendar either sends me a SMS text message or an email, or both, depending on how I have my alert set up for the specific event.  Before upgrading to Mountail Lion, iCal suddenly started launching Mail.app to send me an additional alert email.  I turned that off in iCal.  Now with Mountain Lion, the behavior is back, but there's no equivalent setting in Calendar to turn off.  How do I stop Mountain Lion from using Mail.app to send me alerts for Calendar events?


MacBook Pro, OS X Mountain Lion, iPhone OS 5.1.1
  • 1. Re: How do I stop Mail.app from emailing alerts?
    SomeoneAnyone Level 1 Level 1 (0 points)

    This is driven by Google Calendar and your default notification settings there - follow this and your issue will stop.  I agree its annoying and it would be NICe if there was a setting in iCal that let me say "never emil reminders" for a given calendar, but it's not there so you can stop it over in Google.

     

    http://support.google.com/calendar/bin/answer.py?hl=en&answer=37079

  • 2. Re: How do I stop Mail.app from emailing alerts?
    spstanley Level 1 Level 1 (15 points)

    This won't work for me, because if I turn off emailing notifications in Google Calendar and that does stop Calendar.app from sending me email, it will also stop Google Calendar from sending me email, which means instead of email from two sources for the same event, I'll receive none.  I suppose the only thing I can do is deactivate my Google Calendar in Calendar.app, which means I won't see my Google Calendar events in Calendar.app or in Notifications, but at least the email from Calendar.app should stop.

  • 3. Re: How do I stop Mail.app from emailing alerts?
    spstanley Level 1 Level 1 (15 points)

    Whoops, I answered my own question by digging around for settings.  "Ignore alerts" is probably what I want.

    GoogleCalendar.jpg

  • 4. Re: How do I stop Mail.app from emailing alerts?
    chrisfromdc Level 1 Level 1 (0 points)

    I'm having the same issue. Where do you go to get that window to enable ignore alerts?

  • 5. Re: How do I stop Mail.app from emailing alerts?
    spstanley Level 1 Level 1 (15 points)

    In Calendar.app, click Calendars to show your calendars in the left sidebar.  Then right-click the calendar in question, choose "Get Info", and voila!

  • 6. Re: How do I stop Mail.app from emailing alerts?
    allenfromnashville Level 1 Level 1 (0 points)

    Perfect, that did the trick! I had setup my Google Calendar on an iMac and Air, so I was well alerted!

     

    Thanks for sharing your solution.

  • 7. Re: How do I stop Mail.app from emailing alerts?
    jefftheDO Level 1 Level 1 (0 points)

    Jesus H....!!!

     

    I was having the EXACT same problem spstanley. After hours searching the web and my computer, YOU are the one that solved my problem. Amazing. As much as I love mac and always will, I am still amazed at times like this, when such a seemingly important setting is hidden away in such a spot that even the most clever mac-nerds would have trouble finding it.

     

    THANK YOU again!!! Lifesaver!

  • 8. Re: How do I stop Mail.app from emailing alerts?
    riderback Level 1 Level 1 (0 points)

    I keep thinking I can ignore this problem, solve it later, or at least find a solution 'later' but it wasn't until today that I found this post.

     

    THANK YOU!

     


  • 9. Re: How do I stop Mail.app from emailing alerts?
    SleeveMonkey Level 1 Level 1 (0 points)

    I did this but still I keep receiving email notifications.

    Actually, I get 2 for each Calender event I create;

     

    The first email says:

    “New Event” added to Agenda...

     

    The second email that comes straight after the first says:

    My Calendar text” updated in Agenda

     

     

     

    It is also send to all my (6) collegues who I share this agenda with. It drives them nuts. When they add something to the agenda we do not get any emails.

     

    I have been searching for solutions for months now but nothing helps;

    - changing the setting through the web version of iCloud.

    - disable sharing, change settings and re-invite all people

     

    I have this since iCloud started and have meanhile switched to a new computer and updated the OS numerous times.

    It only happens with 1 of my agenda's. I have 6. 4 of them shared and they work smoothly.

     

    Any ideas? They are more than welcome.

     

    Thanks,

    Hans

  • 10. Re: How do I stop Mail.app from emailing alerts?
    kcpilotguy Level 1 Level 1 (0 points)

    Thanks for the info...I was having the same issue.  I have my wife's calendar on my mac so I can see her work schedule and when I added it she started getting emails every day she worked.  She was not pleased.  I was going through and manually deleting the reminders out of the Calendar app until I found the ignore alerts thing on this forum.

     

    Hope that solves the problem.

     

    Thanks agian.

  • 11. Re: How do I stop Mail.app from emailing alerts?
    generaleditor Level 1 Level 1 (0 points)

    A twist...

     

    I don't mind the notifications popping up in the righthand corner - it shows me the activity of those in my company's various departments - but I DON'T want the emails clogging up my mailbox.

     

    For anyone in this position... here's what I did.  Hope it helps.

     

    1.  Create a "rule" in Mail to block these notification emails.  Here's how I set it up:

     

    go to Mail / Preferences / Add Rule :

     

    > If [ any ] the following conditions are met:

         [ From ] [ contains ] [ "noreply@icloud.com"]

     

    > Perform the following actions:

         [ Move Message ] to mailbox: [ Junk ]

     

    2.  In iCal...

    Leave "Ignore Alerts" UN-checked

  • 12. Re: How do I stop Mail.app from emailing alerts?
    sebseb81 Level 1 Level 1 (0 points)

    Major thanks for solving this issue!

     

    Apple really should address the poor discoverability of this setting.

  • 13. Re: How do I stop Mail.app from emailing alerts?
    NZBred Level 1 Level 1 (0 points)

    Thanks so much. Your suggestion worked. Its been bugging me for about a week now - and ever since I moved from PC to Mac (which I'm loving by the way)  So far, so good and only receive GMAIL alerts. Given the number of meetings I have in a day, was getting double notifications for no reason. Thanks again...

  • 14. Re: How do I stop Mail.app from emailing alerts?
    sbHere Level 1 Level 1 (0 points)

    This is NOT a solution!

     

    The indicated "This fixed my issue" does not fix the issue. It doesn't stop mail from opening when Calendar gets an event that also has a mailed reminder. It simply stops the reminder from being emailed!!!

    If I'm not in front of my iMac, then this doesn't send me an indication ... i.e. if I'm logged into a work computer running windows and even if I have my gmail window open, I still won't get an email reminder.

     

    So your "solution" is not a solution.

1 2 Previous Next