Previous 1 2 Next 18 Replies Latest reply: Feb 10, 2013 7:18 PM by Lawrence Acker Go to original post
  • Lawrence Acker Level 1 Level 1 (15 points)

    I tried just about every solution I could to fix the problem of Silverlight telling me that there already was a more current version of Silverlight on my computer (a Mac Mini) than what I was trying to load.  Netflix told me to remove Silverlight from Hard Drive-->Library--> Internetplug-ins. 


    Other advice I saw also had removals from Library-->Receipts and Library/ApplicationSupport/Microsoft/Silverlight.  Althugh this advice may have helped I was still unable to dowload Silverlight because it still told me there already was a more current version of Silverlight on my computer. 


    I was just about to cancel my account with Netflix when I thought I'd try one more thing:


    I plugged a flash drive into another Apple computer and copied Silverlight from Hard Drive-->Library--> Internetplug-ins and then after ejecting the flash drive went over to the MacMini, and copied Silver light into the MacMini's Hard Drive-->Library--> Internetplug-ins.


    I'm pleased to report I can watch Netflix again. 


    That said, three Netflix tech support people and one Micosoft tech person all of whom were very polite, but never suggested this approach and I haven't seen it suggested in other user forumes either.  I hope it offers some help t others.

    Have a good holiday.

  • netsoup Level 1 Level 1 (0 points)



    I will keep that in mind to try if I have more issues.  I had to give up for the nght and start again in the morning with a fresh mind.  I thought it was very non-macish for it to be so hard just to reinstall an internet plugin that was crashing.

    NetFlix and Microsoft instructions seemed to indicate just deleting the silverlight* files in '/Library/Internet Plug-Ins' then reinstall.  Others said install a third party app called EasyFind to search for hidden files and delete everything with SilverLight in the name which I did, no go since it must have missed some.  I looked through the hidden user Library folders and couldn't find anything.

    Finally found the script at the other link I posted:

    rm -rf /Library/Internet\ Plug-Ins/Silverlight.plugin

    rm -rf /Library/Receipts/Silverlight*.pkg

    rm -rf ~/Library/Application\ Support/Microsoft/Silverlight


    This finally worked consistently for me.

    I think I was overlooking the files in /Library/Receipts I think.  The thing that kept bugging me was although I was using the one directed from Netflix and Microsoft, the install kept saying a newer version was installed, even though it was a letfover file somewhere from an older version, since i was trying to install the latest version...

  • Karl Schulz Level 1 Level 1 (0 points)

    I spent hours and hours on this mess.  Ultimately, the only solution that worked was the copy and drop of the silverlight plugin by  Acker two post above.Thanks Lawrence Acker.

  • Lawrence Acker Level 1 Level 1 (15 points)

    You're very welcome. I'm glad it worked for you.

Previous 1 2 Next