8 Replies Latest reply: Oct 12, 2012 3:14 AM by brandonfromwashougal
BarrettF77 Level 1 Level 1 (45 points)

I put my wife's email account which is in iCloud on mail with a couple of other iCloud accounts.  To identify who's iCloud account is who's, In the preferences on the account where you edit the description from the default "iCloud" to User's Name  iCloud and after you hit save I get an error saying The "Incoming Mail Server" field cannot be empty.  Yet is has p04--imap.mail.me.com in the field that is greyed out and I cannot edit the fields contents and therefore doesn't allow me to change the email account's description.  I've tried deleting the accounts, logging out of icloud, etc.  Nothing has fixed this yet.

 

 

 

On a side note, one of my other email accounts from iCloud keeps popping up with it needing the password field to be entered.  No matter what I try, it doesn't take the password.  I can log into it just fine through safari. 

 

 

 

So it seems like iCloud is having issues as well as Mail and contacting Apple twice and escalating to tier 2 both times has yeilded the person saying they didn't know and then hanging up on me.  Does anyone else know what I might try?

  • MChannel Level 1 Level 1 (0 points)

    Same happed to me no way to ad a new icloud account without getting the same error message

  • Ramboxman Level 1 Level 1 (0 points)

    I am having the same issue as well.

  • Thorkona Level 1 Level 1 (0 points)

    Also had the same problem. My solution was to delete my iCloud account in the Mail Account Prefs then add it back. Now it works fine.

  • MChannel Level 1 Level 1 (0 points)

    Try to manage all the icloud accounts not from Mail preferences any more, instead do it from System Preferences > Mail, Constacts & Calendars

  • BarrettF77 Level 1 Level 1 (45 points)

    Thanks. I've tried that too.

  • ftwducman Level 1 Level 1 (0 points)

    Regarding passwords dropping out, be sure that the box is checked for "Use this server only" for outgoing Mail.  This may be a problem as I was trying to set this on my wife's MacPro and got the "Incoming server field cannot be empty" message, even though the server path was in there, just grayed out.  I couldn't change it and it wouldn't take the "Save" when I tried to leave Mail Preferences.

     

    Anyone know why my incoming server setting on my MacPro is p01-imap.mail.me.com but my wife's is p04-imap.mail.me.com?  Both machines running OS X 10.8.1.

  • Eric Rasmussen Level 1 Level 1 (20 points)

    Okay, I had this problem and solved it as follows:

     

    1. Deleted any non-functioning iCloud-IMAP accounts from Mail's Preferences. I had two that were working fine, so I left those in place. One of those was the primary iCloud account on my Mac, i.e., the account used for "Find My iPhone/Mac/iPad" and iCloud storage, etc.

     

    2. Then I quit Mail and restarted my computer.

     

    3. Went to my other devices and made sure the primary account was the same one there. [Note: It was not -- the primary iCloud account was different on my iPhone versus my Mac, I think this discrepancy might have been the source of the problem, but I don't know.]

     

    4. I also made sure my wife's Mac uses a different primary iCloud account, one that is not on my machines, although we share one secondary iCloud Mail account (which is not the primary on any device -- it is always a secondary account).

     

    5. Then, following MChannel's advice upthread, I went into System Preferences > Mail, Contacts & Calendars, and added the formerly problematic iCloud accout that way. I have everything turned on for my primary iCloud account. All of the secondary accounts only have Mail turned on (although I don't think that matters -- you can turn on the other features that are available there if you like).

     

    6. Opened Mail and voila! -- everything is working fine. Accounts are all set up properly without me even opening Mail's Preferences.

  • brandonfromwashougal Level 1 Level 1 (0 points)

    I had the same problem and spent alot of time tracking it down and Barrett is right about setting it up using your primary apple id and me thinks that when @me was replaced by @icloud when IOS 6 was released it has something to do with the p01-09-imap.mail.me.com on both the incoming and outgoing mail server.  So the incoming server hs to be p02-imap.mail.me.com and the outgoing setting must be the same but with the p02-smtp.mail.me.com.  Start fresh when you update to 10.8.2 and start by archiving your mailboxex's and setting up icloud with your apple ID and not an alias in system pref's>users&groups>mail,contacts,calenders.  Setup Assistants sends you to ICloud setup first but unless you go to mail first it won't set up your mail account..first.  then go to users and groups> and add any alias's.  The p0#-has something to do with the number of alias's you have and it identifies each acount holder.  just my guesss.  Oh and even though you might have beem given an @icloud alias when you upgraded to IOS 6  it doesn't mean that your mail account is ready for it.  So the safest bet is to stick with your apple id and the @me .com alias's.