Previous 1 5 6 7 8 9 Next 197 Replies Latest reply: Nov 8, 2015 8:17 PM by PaulaBlanchard Go to original post
  • Terry Plowman Level 1 Level 1

    This is driving me crazy, because there's nowhere in that link to enter a comment. I can enter name, email address, subject, operating system, etc. But no comment box.

  • j-rad Level 1 Level 1

    Have you tried different browsers?

  • baconwrapped Level 1 Level 1

    It's not a browser issue... it's built into the Mountain Lion Notifications... no way to customize snooze settings...

  • Terry Plowman Level 1 Level 1

    He means different browsers for my inability to post a comment to Apple. No, I have not yet tried Firefox, because I assumed that an Apple form would certainly work on Safari! Wouldn't you think?

  • Terry Plowman Level 1 Level 1

    OK, that's weird: In Firefox, I have a comments box on the Apple feedback page! But not when I use the same link in Safari! How can that be?

  • baconwrapped Level 1 Level 1

    Sorry.... my mistake. I've posted complaints/comments to Apple using Safari with no problems.

  • j-rad Level 1 Level 1

    It's probably some browser plug in that's creating the havoc... My Safari seems to be working OK on the feedback page.  You could try disabling your plugins, or you could try creating a different user and seeing if the problem persists.


    In any case, glad you stuck with it to get Apple the feedback... Not being able to Snooze is going to force me to a solution that can snooze... I'm embarrased to admit how many calendar events I've missed or been late for, not being able to snooze alarms.

  • avantsweater Level 1 Level 1

    Yup sounds exactly like Ad Blocker or something being a little over-eager.


    Hopefully the snooze will be back soon.

  • Terry Plowman Level 1 Level 1

    Yes, j-rad, I'm embarrassed to admit how much I've come to rely on iCal alerts! I recently turned off all alerts so I could watch a movie on my iMac, and then missed numerous appointments and tasks when I forgot to turn the alarms back on! I set alarms for a myriad of tasks, large and small, business and personal. I even forgot to take the trash to the curb because I had iCal alarms turned off. Now, I have alerts popping up every 15 minutes, driving me crazy! Help Apple!

  • Terry Plowman Level 1 Level 1

    Yes, Adam, it was a Safari extension called Shut-Up, which blocks YouTube comments, which I often find annoyingly rude and crude. I can toggle them on if I want to see them, but they are off by default. Anyway, Shut-Up was causing the comments box to be hidden on the Apple feedback page. Once I disabled the extension, the comments box appeared. (But I have already filed a comment via Firefox.)

  • One13Truck Level 1 Level 1

    That's too bad that Thunderbird won't be developed anymore. It was just starting to grow on me in place of the iCal. But as long as I can I'll still use that and the paper calander in place of iCal until this snooze issue is fixed. As it is right now iCal is no use to me without the snooze feature.

    And yes, I agree. Providing feedback is important. I too have left them many, I just submitted another one before posting this. Each time I make sure I tell them that because of this feature being gone I no longer have a use for it and that I have replaced it with other options until this is fixed. Maybe they won't care that it inconviniences us but they should care that because of the change it pushes us to products made by their competition.

  • polishedstaple Level 1 Level 1

    Maybe the fix to this snooze issue will be found in the next release, 10.8.3.


  • Terry Plowman Level 1 Level 1

    Well, everyone on this thread would sure be happy if 10.8.3 solved this maddening problem.

  • Hawfinch Level 1 Level 1

    I tried MS Outlook (as I had Office installed already). It has some great snooze options in the alarm popups, including options like "remind me tomorrow morning", and it can sync with Apple calendars that are stored on the same Mac, BUT it doesn't work with iCloud-based calendars so there's no syncing across devices. That rules it out for me.


    I'm also trialling the new release of BusyCal (2.0.1). It now has its own snoozable alarms as an alternative to Notification Center, apparently introduced in response to this  problem that we've been complaining about.



    From a quick test it seems to work well, syncing dynamically (both ways) with iCloud calendars, and does indeed provide variable snooze (though you have to type the snooze time rather than selecting it from a popup). The Notification Center popups can be turned off in system preferences, leaving you with an experience much like the alarms in Lion, but with more adjustable snooze options. BusyCal is expensive, but it looks like the best solution I've found so far for this annoying problem.

  • Julatron Level 1 Level 1

    Busy Cal is expensive? Not compared to Outlook, surely?

    Isnt it around $50?


    Not fussed if it doesnt sync via cloud anyway, I didnt have luck doing the sync via iCal so have to rely on directly synching via the mac and itunes.

Previous 1 5 6 7 8 9 Next