Previous 1 2 Next 24 Replies Latest reply: Apr 3, 2014 11:39 AM by Eric Root Go to original post
  • Cthulhu Level 1 Level 1 (60 points)

    Hence the first part of my post :-)


    I would be interested in anyone's experience in Mountain Lion. A few dozen of us here at work were looking for a solution, but we are on Lion and not considering upgrading until January or February.


    If the preferences editing works in both places, I or someone else could perhaps provide a simple script to do it. I would, however, need some help from a ML user to get it working for all of us on both versions. Might help a lot of people, since Google brings us here for a solution.

  • douglasfromboise Level 1 Level 1 (0 points)

    I ran into this same issue on Mountain Lion. I have six email accounts but I want all my new emails to be sent from a default address. No matter what, my @me email appears at the top of the list and no, contrary to some comments in this thread the email accounts cannot be reordered by dragging in Mountain Lion, I believe that was true for prior OS X versions but NOT mountain lion.


    My solution was to go to the "composing" button under prefereances and then select the email address I wanted as my default from the drop down list under "Send New Messages From:"

  • FreddyL Level 1 Level 1 (0 points)

    Same problem here. Mailboxes order goes back to some Apple criteria after changing Preferences. Not confortable editing .plist files, so I did not try that one!


  • pspiegel2 Level 1 Level 1 (0 points)



    See solution proposed by Raine2jz, reposted below.  Mountain Lion doesn't let you reorder in Preferences.  Instead, go the main Mail window (Message Viewer), unhide mailboxes on the left side, drop down to see all inboxes, reorder them in the usual fashion by sliding them around, then close Mail and restart.  Restarting is important to lock in the changes.  It worked fine for me.




    Actually I stumbled upon how to do it after reading this thread - in the main Mail window, with the mailbox column open on the left side, just drag and reorder the mail accounts, just like you would reorder the hard drives and folders in the Finder.

  • FreddyL Level 1 Level 1 (0 points)

    You are right, but as I and others in the thread pointed out, whenever you make a change in Preferences (e.g. update a password, any other) it reverts back to the unwanted order.


    I just tried before replying....So the bug is still there.


    Thanks anyway!



  • pspiegel2 Level 1 Level 1 (0 points)

    So you need to reset the mailbox order again every time you make a Preferences change?  OK.  It's a pain in the ***, and I'm sure they'll fix it.  I guess the answer is to get your preferences set right and not change them often.

  • Pondini Level 8 Level 8 (38,715 points)

    FreddyL wrote:


    You are right, but as I and others in the thread pointed out, whenever you make a change in Preferences (e.g. update a password, any other) it reverts back to the unwanted order.

    Hmm.  It doesn't do that for me.  If I change the order of mailboxes by dragging them in the Mail sidebar, then quit and restart Mail, the changed order is preserved.


    If that's not happening for you, it sounds like the preferences file may be damaged.  About the only ways to fix a corrupted preferences file are to restore an earlier, uncorrupted version from your backups;  or delete it and re-enter the preferences.  With one as complex as Mail, of course, re-entering everything is a major pain and mistakes are very easy.


    If you know when this started failing, and haven't made any significant changes since then, and have backups, quit Mail and restore this file:


    <your home folder>/Library/Containers/ il.plist


    (Note: that's the location on Mountain Lion only; on earlier versions of OSX, it's <your home folder>/Library/Preferences/

    If you want to tackle replacing the file, screenprint or write down everything on the Mail > Preferences windows, especially the server names, passwords, etc., then quit Mail.  Move the file named above to your desktop, just in case there's a problem;  you can move it back if you have to.


    Then open Mail, and enter all the information.

  • Maz K Level 1 Level 1 (0 points)

    Hi there,


    I'm not sure whether you managed to solve this but I had this problem and I managed to solve it (for me). I hope this works for you.


    It all depends on mouse position when you are dragging the folder. If you select the folder and drag it to the position you want but make sure that the mouse is as far left as possible, i.e. under for example, the arrows to the left of the main folder icons. In my case, when this wasn't the case, it was moving them inside other folders creating subfolders. Ensuring it was as far left as possible created main folders under "ON MY MAC" in the order I preferred.


    Hope this works for you...




  • FreddyL Level 1 Level 1 (0 points)

    The problem remained in the past as I updated to Mavericks, as released.  Could not try Pondini'd and others' detailed suggestions with ML.


    However, to this an similar responses to other threads/problems:

    pspiegel2 wrote:

    I guess the answer is to get your preferences set right and not change them often.

    I find that Apple should not count on that. That's soooo Bill Gatish / windowish. Rules, Signatures, Junk Preferences and much stuff users might change more often than accounts themselves are all under Mail Preferences.

    Best and thanks!

  • Eric Root Level 8 Level 8 (38,710 points)

    Apple doesn’t routinely monitor the discussions.


    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.




    Mail/Provide Mail Feedback

Previous 1 2 Next