Previous 1 9 10 11 12 13 Next 235 Replies Latest reply: Jul 25, 2013 1:42 AM by stevefromorpington Go to original post
  • Sea S Level 1 (0 points)

    thank for leting me know! I'm going to try the same as you did But I still have one concern: I had a 7 years old Linksys Wireless-G DOCSIS 1.0 router before. 8 months ago, Camcast infomed me that I didn't get what I paid $ for due to my router is too old, which only locked 1 upload channel (1 M) and 1 download channel (5 M) and 54 M for WiFi. So, I bought new router Motorola SBG6580 DOCSIS 3.0, which locked 3 upload channel (3.29 M) and 6 download channel (25 M), also WiFi can be up to 300 M if Wireless-N enabled (i.e. set to auto, instead of 802.11x). If set it to 802.11G, WiFi will be 54 M. If up-down load rate is 1-5 M, then WiFi 54 M should be good enough. But if up-down load rate is 3-25 M, then is this WiFi 54 M going to be a problem for router's performace? What is your router's up-down load rate?

  • itmachines Level 1 (0 points)



    I also struggled with this as soon as I had upgraded to ML ... I had also the next day bought a new Router as I was having problems with the old one - but the new router also gave me the same wireless issues.


    Apple has updated the firmware of my mac, which I updated... but this then made me not "see" my router at all... untill I changed the settings in the D-Link DSL-2750U ... In the Advanced - Security Settings, at the bottom ...


    Wireless Security Mode - WPA2 Only (selected from drop down)

    WPA/WAPI Encryption - TKIP+AES (changed - this was selected on AES)

    Screen Shot 2012-11-30 at 16.46.25.png


    Hope this helps/works for others!!


    Otherwise I am still on the N settings, and everything else is factory settings.




  • wclyffe Level 1 (5 points)

    I have the same situation as you and have not been able to solve it. New MacBookPro 2012 running ML OS 10.8.2 works perfect at home on an Airport Extreme router, but at work we have a Cisco WAP 4410N and it drops out every few minutes especially if I try to download something or backup to the cloud. No one else has a problem and I am the only one running ML. Have you figured anything out since you posted in August?

  • jackflint Level 1 (0 points)

    The router you are connecting to must be set up to use WPA or WPA2 security. That is the ONLY solution at the moment. I had to get my ISP to change my router settings as it was not possible to access that area without admin permissions. This is all Apple's fault but, as they seem to be ignoring all requests for a fix, this is our only option. For people who travel around a lot and connect to many different wireless networks it is an absolute nightmare with no viable solution.

  • wclyffe Level 1 (5 points)

    It's setup as WPA2 Personal for security already and I've tried everything listed except a clean install. This is absolutely ridiculous on Apple's part.

  • wifiguru Level 2 (240 points)

    This was an issue that a lot of folks complained about when ML was released. Updating to the latest firmware on the Cisco 4410 WAP router resolved the issues for almost everyone I saw reporting this issue. So try that.

  • wclyffe Level 1 (5 points)

    I wish it was a simple thing like it being my router, but there's a whole IT department and I'm the only one having any trouble. Gotta love Mountain Lion!

  • 3gs LS Level 1 (0 points)

    I only have this problem with my mid 2011 iMac running ML. My mid 2011 mac book pro works fine which is also running ML.

  • mark64.5 Level 1 (0 points)

    A brand new shiny OS 10.8.2 imac 21.5", ML pre installed,.  A beauty on my desk, the new screen is to die for, BUT, the wifi started cutting out 2 days after I pluged it in. I have to rejoin my wifi network (retype the wep password) everytime I wake the computer up from sleep .   I just plugged it back into the wall, that *****  !!!!!    Hope Apple comes up with a fix soon.  

  • CT Level 6 (17,545 points)

    Can't confirm.

  • Zacharias Beckman Level 1 (100 points)

    Yes, same problem here. It is a widely experienced problem by a host of users that upgraded to 10.8 (it's unclear if it started with 10.8 or 10.8.2). E.g.: MacRumors has a long discussion on this, and it's just one of the many sites with many complaining users:


    Here's what I've figured out so far, and this is after living with the problem (and trying to fix it now) for many weeks, and perusing many online resources:

    1. The problem in question (that I'm discussing) is one where your Mac network connection completely hangs. Attempts to open a web browser, for instance, hang for about a minute, and then you get the "cannot find the web site" page. Likewise, any network access (ssh, telnet, email, ping) are all completely blocked, as if you had no network at all -- and yet, at the same time, you've got 5 bars on your wifi status and a solid connection to the router. Network status in your settings all looks fine.
      1. The most common fix at this point is to either 1) turn off wifi and restart it, which almost always works, or 2) go ahead and restart the router, which annoys the heck out of everyone else in the office but also works fine.
    2. The problem is probably related to an update to the 10.8.2 network stack. Ignore anyone that says something like "reset your router," this is not the issue. This can be verified easily enough: Are any other devices on the router impacted? No? Then the router is fine (here we have about a dozen computers, iPads, and an AppleTV, and a VOIP phone system on the router -- they all keep working fine, it is only the MacBooks that were updated to 10.8.2 that exhibit the problem.
    3. The problem is apparently specific to the 802.11 'n' protocol. We successfully reconfigured our router so that it supports two different networks, one 802.11g "Boss Logic" and one 802.11n "Boss Logic 5Ghz." In other words, we switched it up so that you can use a 'g' network ("Boss Logic") or an 'n' network ("Boss Logic 5Ghz"). All the PC users are happily using the higher speed 5Ghz network -- and all the Mac users are now, unhappily, using the older 'g' network. If your router supports this (having a dual configuration, such as the Apple Airport routers do) then it's a great fix... at some performance cost. We've done this here, and yes, it did absolutely work, no hangs since switching over.
    4. I have read elsewhere that you might be able to continue using the 'n' network, if you change your MTU size to a non-1500 settings. I'm giving this a shot and will see how it goes. (Just go into settings and change your wireless network 'hardware' tab to use an MTU of, say, 1495). Good luck if you try this.


    Hope this helps and let's all cross our fingers and hope Apple starts paying attention. It seems like it's been an eternity... but it's probably only been a month or two. But hey getting booted off the network a few times a day can be a really, really annoying experience.

  • 3gs LS Level 1 (0 points)

    When I told the store about this forum the guys just disregarded the fault and said it isn't a common problem. Surly not hey? I upgraded the firmware on my dual band Cisco router last night but if it continues to drop today I shall be ringing the store. It is strange that I only have this problem with my mid 2011 iMac running ML. When the store had my iMac for repair I had to use my mid 2011 mac book pro which is also running ML and was used in the same location as the iMac except it didn't drop once.

  • CT Level 6 (17,545 points)

    Can't confirm.

  • tweetzero Level 1 (0 points)

    That response from the Apple store is classic and it is to no surprise, the default.  They are trained to act oblivious when listening to customers plead for mercy as they explain, "I'm not the only one with these issues".

    ML is a mess and they know it. My MBP 2009 is a mess after installing ML.  Same WiFi problems, slow,  drops off, page not found, etc., on a regular basis. The double whammy for me  is not being able to wake my screen from sleep (unless I am standing right next to it and am able to strike a key before it slumbers off). It sounds like it's all tied together, the bugs that is, or more appropriately should we call them Tics?


    I've been on so many posts over the past week and didn't realize that the connectivity problems are because of ML, and not because of Comcast.  When I run Speedtest ( , my download speed is 32mbps and upload 8.5mbps as it should be, but you wouldn't believe how sluggish and unreliable the performance has been. What I've found miserably intriguing is to see the rang in inconsistencies of problems shared by posters, especially those with more than one Apple computer. One seems to be fine, the other one is not.

      My MBP, late 2011 is running like a champ on ML, it's my MBP 2009 that's facing all the issues. I've tried so many recommendations and to no avail. The problems are not limited, either, new ones accumulate  throughout the day.  Most disheartening is to see how long ago some of these posts began, many of them back to July and August, 2012.  That's too long without a fix! I have had to power off so many times, it's my only option to waken the screen and at the same time, the machine is running so hard, a race it cannot win. That get's expensive, Off/On, Off/On.

    I haven't been this miserable since the 2008 NVidia graphics card debacle. The Apple store denied that one too.  When I explained the problems I was having (along with millions of others), the Genius Bar said it was the first they had ever heard of it?  I said, "look, if I know about it, the whole world knows about it, because I can barely find the on/off switch! Not to mention, it made front page news of The New York Times!" 

    I guess we can only wait for 10.8.3, whenever that is.

  • 3gs LS Level 1 (0 points)

    Fair enough bugs appear even after testing. What gets me is that Apple never want to admit to being at fault. A simple "yes we know there are issues with some models and we are working on a fix" would be helpful.

Previous 1 9 10 11 12 13 Next