Previous 1 2 3 4 5 Next 235 Replies Latest reply: Jul 25, 2013 1:42 AM by stevefromorpington Go to original post
  • biochemgineer Level 1 (5 points)

    sure thing



    click on "Support Resources" and choose your revision number

  • biochemgineer Level 1 (5 points)

    any way to remove duplicate posts?

  • spflan Level 1 (0 points)

    I had the same problem.  I upgraded from Snow Leopard to Mountain Lion and immediately had Wifi problems on my iMac.  It would connect but then drop out - sometimes within a couple of minutes, other times lasting maybe half an hour or so.  I kept having to use Network Preferences > Diagnostics to reconnect.  Other devices (MBP running Snow Leopard and iPhones etc have had no problems).


    POSSIBLE SOLUTION: I have an old router (BT Home Hub v1.0) and was running WEP security.  I have switched it over to WPA2 protocol and so far no problems.  Wifi has been connected now for a few hours without dropping.


    I had previously tried the MTU 1300 change (above) but that didn't fix it for me.

  • barcapat Level 1 (0 points)

    Cheers for the info.

    Switching to WPA2 security has also worked for me - at least so far (30 mins test)

    Maybe its Apple forcing us to the more secure WPA2, but they should tell us first!

  • fastway Level 1 (0 points)

    Hey there spflan,

    I'm having the exact same problem. But here's the twist, my router was already set up to WPA2 long before I even updated my MacBook White late '09 to Lion.


    Any tips? 'Cause since I was already working with WPA2 I shouldn't be having any trouble, right?


    Any way, I'm lost here...

  • seanreynolds Level 1 (5 points)

    Yeah, thats great except you cant make every network you connect to upgrade their router and security!


    As of yesterday I was disconnecting 'infrequently' maybe 3 times in 8 hours.

    I went home and my connection was Flawless.... Though I do have 30 MB speeds at home.

    At work I can MAKE it fail by downloading a large application through the app store, when I do this, ALL of my other connections fail... including safari and even Ping in terminal cant get to my host!!!! EVEN THOUGH the connection is still there and the app is STILL DOWNLOADING!


    SO I went home formatted my drive and reinstalled my opperating system....

    This is the topic for another thread but the Mountian Lion install from my recovery partition failed over and over and over. I thought my computer would need to be brought in. When I installed without formatting everything was fine, but after formatting my drive the install failed after asking for my apple ID to confirm my purchase. MY computer is registered to my Wife, and was purchased using Lion, but I do have Mountain Lion purchased on my apple id! After taking my credentials it just closed the popup and did nothing... if I clicked again it would do the same thing. I Screwed with my disk and formatted it using every setting available till FINALLY I Broke my Restore Partition.... It booted to nothingness...


    Then In a stroke of brilliance It did apple recovery and redownloaded the recovery partition from the BOOT screen. Then it installed Lion.


    NOW back to this thread.

    It installed Lion... FRESH!

    Fresh install of lion, I updated, then installed Mountain Lion. Everything still worked at home.

    I came into work this morning and... Back to the same way it was. Internet connectivity cuts out if I do any large download. My home is WPA2 Personal but my work is WPA Personal... Youre telling me that I need to MAKE MY WORK change their setting for my ONE laptop? THATS BS!


    It worked before, works with my iPads... works with everyone else. Does not work with Mountain Lion, but does work with Lion on my laptop.

    This is a software bug!


    I personally think they are doing something with multithreading downloads and prioritizing system downloads over user connectivity. SO when it's downloading from say the app store it trumps my user experience.

  • Icegold Level 1 (0 points)

    Hopefully, this situation gets resolved quickly.


    As fyi, my late '10 17" MBkPro has the same issues as many are describing (i.e. phantom disconnects, very slow speeds, connectivity issues after sleep....).


    All of the problems noted regardless of me having lastest router firmware, using WPA2 security, complete clean install of ML,  & resetting PRAM.


    I've had to resort to using Caffeine to prevent the sleep issues; unfortunately, there is still the occassional wifi connectivity problems.


    Searched other forums and it does appear common thread is older machines--it does seem hit or miss as far as the problem AND some of the various resolutions I've seen (some fixes work in certain instances -- some don't)...anyone out there with any other ideas until we get the official update?? 

  • BesiegedByDesign Level 1 (0 points)

    Same issues here and my machine is brand-spanking new. I'm running a 2012 MBP w/ retina display and everything worked fine when I got it in June with Lion installed. Upgraded to ML and my internet starting cutting out. Because I was attempting to download updates from the app store at the time, I was able to notice it gets to the same amount of downloading every time... about 40mb's... before dropping the wifi signal across ALL apps... even though it shows as still connected to wifi (and all other machines in the house work fine on the wifi network). Can anyone else confirm the 40mb's??? That may be why sometimes it takes a while... depending on what you're doing on the web it may take a while for your cache to hit 40mb's... or it may happen quickly if you're attempting a download. I found that it worked fine (ML on my laptop) when I brought it into the Apple store. It's just my network at home. Pinging the google site seems to work for me... although it's a slower connection than I'd like. If I stop pinging, I'll lose the web again. Turning wifi on/off seems to do the trick to re-start it... but COME ON... this has obviously been an ogoing issue that they knew about. Wish they'd addressed this before the release. Will check back for fixes, but so far... I have none. Just temporary patches...

  • softwater Level 5 (5,370 points)

    Try making a new network connection and renewing the DCHP lease as detailed here:



  • BesiegedByDesign Level 1 (0 points)

    Thanks - but it didn't work. I thought it worked... but alas, internet cut out as soon as my first download began. This is a major pain in the butt... nothing but "pinging Google" seems to work. Would really rather not buy a new router for no reason other than ML is being a finicky snob...

  • seanreynolds Level 1 (5 points)


    Even after Reinstalling ML still does not work... the Apple guy has called me 3 times.


    It works on my router at home, but not at work.

    My work router is cisco wap4410n with an older firmware from 2009 with WPA personal.

    WHY IS IT the routers fault? It's like they dont realize how big of a pain it is for businesses to upgrade things like router firmwares. If there is an issue with the upgrade it would **** off more people than me with my finicky OS.


    Every other OS works with this router including Windows, IOS and Lion!

    Why does Mountain Lion have to take their toys and go home?

    Just PLAY NICE!

  • silexicon Level 1 (10 points)

    Even though I am still having Wi-Fi drops, I am NOT having them as much as I was AFTER I reset my PRAM.


    Since resetting the PRAM on my iMac that was (and still is) giving me a **** of a time with the Wi-Fi dropping, it is definitely not dropping like it was before and is staying on a lot longer too.  Just FYI - hopefully this might help others, but it's always a crap shoot and definitely NOT a guarentee, that's for sure.  But what harm can it do if it does help?  I read that some people were having better success with their Wi-Fi after doing this, so after I reset mine, it did SEEM to help...


    To reset your PRAM:


    Upon restarting / rebooting your machine, as soon as the screen goes dark and right before it's starting to start up, hold these keys until the grey apple appears and you should have just reset your PRAM and hopefully it MIGHT help your Wi-Fi stay connected a bit longer than before.

    Command • Option • P • R


    More on PRAM:


    Hope that helps! 

  • Pottypotsworth Level 1 (0 points)

    Well nothing is working for me, i've tried...


    1) Setting my router to WPA2 only

    2) Chaning the MTU packets to a lower value

    3) Setting up a new location in network pref's


    The only thing left to try is resetting the PRAM but I honestly can't see this helping.


    The weird thing is that I don't have the problem in my office, just at home. All my other devices have no issue on my home network though, so I have no idea why Mountain Lion is having problems


    The only way I can stop my connection from droping is by constantly pinging

  • silexicon Level 1 (10 points)

    There is a new tip written up for the Wi-Fi connection problems over at - Hopefully it may help some people get their Wi-Fi rolling steady and stable again - especially Fix #2...


    Here's the article:



    Fix OS X Mountain Lion Wireless Connection Problems ms/


    Check it out - can't hurt and if it fixes your Wi-Fi issues, than you've only gained better connectivity!



  • Pottypotsworth Level 1 (0 points)

    My last post was based off solutions from that article, nothing works for me

Previous 1 2 3 4 5 Next