11 Replies Latest reply: Oct 19, 2012 3:41 AM by Alexanderre
childsc Level 1 (5 points)

When I installed Server everything worked fine.....until I exposed sevices in Airport using the Server Admin App.  I did everything it asked ie. passwords etc., now when I open the Server app I get an error msg saying   "An error occurred on the server while processing a command.  type 'getIGDPortmaps' in plug-in 'servermgr_network'. "


I went into Airport Utility and everything seemed to be working correctly.  Port mapping was checked and the services were mapped.  The setup I have is 1 Airport Extreme connected to Server by ethernet with Tunneling enabled through internet options.  Then I have 2 Airport Express' extending the network and those are set to "Local link only".


My question is....could I have double Port Mapping happening somehow?  and how do I fix it so everything is handled through Server Admin App?


Thanks for the help!

Mac OS X (10.6.7), Mac OS X 10.6.7 Server
  • cavalieredona Level 1 (0 points)

    Weel i am sorry but i do not have a solution.


    Yet i have a similar problem.


    I mean my Upgrade went very well, but Server App asks me to type the password ofmy airport extreme, but all the times did not work.


    Thus i decided to reset the airport extreme. All connections works great, but Server App needs the password. Once again i type it but there is an error, as if the password was uncorrect.


    Now if i do not fix this issue i cannot use my server because i cannot connect to it.


    Thanks for the help



  • cdolan92 Level 1 (15 points)

    I dont know if this would carry over to Airport, but whenever I had an "Error Reading Settings" for Wiki service or Profile Manager, it was related to the Postgre service being off/having bad permissions on the server.


    Check around the discussion boards, and maybe open up your console and see if you are getting reoccuring errors (every 20-30 seconds or so, if Postgre is having a hard time launching)


    Might help, might not. I just spent a few days investigating it and gave up, exported my services/settings, and remade my Lion Server.

  • Michael @ Aspire Auctions Level 1 (0 points)

    I am getting an exact same error. Also mail filtering settings are not being saved.

  • Timothyk43 Level 1 (0 points)

    I am having the same issue.


    I manually added the necessary port mappings using the airport utility and everything now seems to be working but my server is still returning the same error message. On the rare occasions it is able to see the timecapsule/airport port mapping it is not recognising any of the manually added port mappings and is only showing those that originated from the osx server interface.

  • childsc Level 1 (5 points)

    Unfortunately the only way I could fix the problem and bring it back to normal was to do a clean install.  Prior to the clean install I tried Restoring from a Time Machine backup to the backup made just after I installed it to no avail.  I also tried restoring my airport Extreme/express' back to factory defaults thinking it was something with those.As in anything else....when all else fails.....


    Thanks everyone!!

  • Tho615 Level 1 (10 points)

    I too had this issue after the upgrade. I just close server app and delete the network folder under /Library/Server/Network. Reopen server app and it reconfig itself

  • cavalieredona Level 1 (0 points)

    Hi to everybody, i think i have fixed doing what it is written on the Post "Server cannot Access my AEBS".


    Best Regards



  • brian.s.s Level 1 (0 points)

    @Tho615 … I was considering a clean install even though I just did one and as a last effort tried this and it worked. Thank you.

  • childsc Level 1 (5 points)

    After doing a Re-install, everything was working again.  Then.........happened again!  I figure there must be a bug somewhere.  Anyways doing the solution from Tho615 fixed the situation until the next time.  However, after doing what he said I had to re-boot my system to fix it.  Thanks for the help!

  • childsc Level 1 (5 points)

    Even though this fixes the issue at first.  I continue to get the reading when I triy to add multiple Public Services using OS X Server.  I think there is still a bug between Server & Airport Extremme.

  • Alexanderre Level 1 (5 points)

    thx, mate, helped me out