1 2 3 4 Previous Next 461 Replies Latest reply: Jul 5, 2014 10:20 AM by clundie Go to original post Branched to a new discussion.
  • 15. Re: Mouse cursor disappears.
    geepaw89 Level 1 Level 1 (0 points)

    I just updated to OS X & have the problem..was fine b4 update

  • 16. Re: Mouse cursor disappears.
    pdostal_cz Level 1 Level 1 (0 points)

    I`ve also the same problem: http://youtu.be/H3OAZix1ryg

  • 17. Re: Mouse cursor disappears.
    Hoka Hey Level 1 Level 1 (10 points)

    I have a similar problem with Adobe Acrobat. The mouse pointer disappears when I do anything that brings up a dialog box.

     

    I have found that is cured temporarily by clicking on the window for another app like Safari. It wrks until I open another Adobe dialog box.

     

    Adobe programs are the only ones where I have this problem. Adobe had 6 months or so to fix this problem from the time that the Mountain Lion beta was released to developers. I am surprised that they did not get it done prior to the July release.

  • 18. Re: Mouse cursor disappears.
    groovyd Level 1 Level 1 (0 points)

    I do not have photoshop but i do have the accesability option of a larger mouse pointer enabled on my 27" cinema display.  i have a 2011 macbook pro with a fresh install of mountain lion on it and my mouse pointer dissappears all the time.  infact it even did it while entering this forum.

  • 19. Re: Mouse cursor disappears.
    dwin_ph Level 1 Level 1 (0 points)

    Update:

     

    I think I may have a temporary solution for this. I've removed all of the additional 'Spaces'  keeping only the primary. I've also unchecked 'Show Dashboard as a space' on Settings>Mission Control, and so far I haven't encountered the missing mouse cursor. The mouse being off on the center while zoomed issue has seem to be non existant as well.

  • 20. Re: Mouse cursor disappears.
    mstockman Level 1 Level 1 (0 points)

    My workaround for a missing cursor *was* to go to the Login window and log back in. Always worked, for a while, but it had the side effect of closing down my VPN connection to work.

     

    So, the workaround I stumbled on based on some thoughts in this thread, was to go to System Preferences > Accessibility, and turn on "Use scroll gesture with modifier keys to zoom". With that setting turned on, control-scroll wheeling to zoom my screen in and out brings the cursor back now.

     

    This workaround's much easier, so thanks everybody for leading me there.

     

    The update this morning to 10.8.1 didn't change anything about this bug, nor did the PRAM reset or Mountain Lion re-install that Apple Support had me doing.

     

    Incidentally, Apple Support rep said my call was the first he'd had about this, so make sure you contact support so they can fix this.

     

    Hope this helps someone.

  • 21. Re: Mouse cursor disappears.
    Vyper007 Level 1 Level 1 (0 points)

    Well 10.8.1 has been released, I've just installed it and as expected this rather annoying bug has not been addressed, the problem still remains.

     

    As other people have hinted the only kind of half solution is to just use the one screen and effectivly give up on Mission Control, as soon as you start trying to use multiple screen space in combination with the zoom feature  the cursor disappears as you move from screen to screen and zoom around a bit, if you just stay on the one window this doesn't seem to happen (at least its not happened to me as of yet)

     

    I wish someone from Apple would actually read this thread and at least acknowledge the problem so we could possibly get a fix for 10.8.2. If anyone calls Apple in the mean time please direct them towards this thread, I'll obviously do the same.

     

    Fingers crossed 10.8.2 will yield better results.

  • 22. Re: Mouse cursor disappears.
    Vyper007 Level 1 Level 1 (0 points)

    Just one other thing too, please submit feedback on this bug to Apple via their feedback portal too which is at

     

    http://www.apple.com/feedback

     

    <Scroll down to the Mac OSX link towards the bottom of the page to log the bug report>

     

    If enough of us complaint about it, maybe one of us will get through to them.

  • 23. Re: Mouse cursor disappears.
    StigBull Level 1 Level 1 (10 points)

    I have the same problem, after upgrading to Moutain Lion last week.

    Everything has been fine untill today, when twice the mouse cursor has disappeared.

     

    Contrary to what people has said here fixes it, none of those works for me. I have to reboot the computer.

     

    Nothing is in /var/log/* when I grep for 'mouse' in the logs.

  • 24. Re: Mouse cursor disappears.
    Stuffit Level 1 Level 1 (0 points)

    I've encountered the same problem as well since I have a new Macbook Pro with Lion on it and I use a Wacom Intuos 3 when using Adobe software, mainly being Photoshop. The cursor disappears on the second monitor on a regular basis. I installed the latest Wacom driver this week to no avail, it has even goten worse; as soon as I start up the computer my pen acts as a mouse. I have to take out the USB plug and re-insert it to get rid of the problem. Hope this problem gets solved soon but it seems that it's unclear who's to blame. It is strange though that my older Leopard Macbook never had this problem nor has.

     

    My current workaround is pressing Command + Tab, if you tap that twice fast, you switch to the following application and at the second time return to Photoshop. Hope that helps others out for the time being.

  • 25. Re: Mouse cursor disappears.
    brianric Level 1 Level 1 (0 points)

    If you stop drinking Apple Juice you may realize it is Apple's fault. I keep all my software updated. I've had the disappearing cursor show up even in Safari. I didn't have this problem until I installed Mountain Lion. Sloppy bera testing on Apple's part.

  • 26. Re: Mouse cursor disappears.
    seegoer Level 1 Level 1 (5 points)

    Minor workaround brings back the cursor/pointer: Go to System Preferences > Accessibility > Zoom to ensure that "use with scroll gesture with modifier keys" is on. Then when cursor/mouse dissappears, you can bring back the cursor by zooming in/out.

     

    I have the same problem on new macmini purchased last week. Occurs when awaking from sleep after use in Photoshop CS6, Safari, finder, etc. No luck with resetting pram or clean re-install. Only option is to re-boot. No fix, so far. But the workaround mention in my previous paragraph works, so far.

     

    I called tech support and they claim they have seen no reports on this — eventhough I read other threads where people have called in. They won't do anything unless there is an out-cry. So, please, all of you, call-in and insist they write this one up for a bug fix.

  • 27. Re: Mouse cursor disappears.
    SteveKir Level 3 Level 3 (545 points)

    You are not alone having mouse disconnection problems. I was cursed with sometimes several times a day in Lion, along with many other glitches, over 9 months. The whole problem was solved by the Apple Centre doing an erase and install of N.Lion, and replacing the Airport card (and earlier, the mouse and keyboard). It took three visits to the Centre: "Reinstall Lion", "Hear's a new mouse and Keyboard". No change.

     

    I suggest you take it to an Apple Centre, in person if you can, sending them an email before the appointment with a daily log of all that is happening (as I did). I got the chief Genius's attention and he kept it for 8 days doing rigorous tests. Since then, 5 days on, all is OK.

     

    The point is that mouse disconnections are very common and there is a lot of folklore about on how to fix. Wandering around in anguish and applying one sticking plaster after another doesn't seem to work. I think the problem needs radical expert attention. 

  • 28. Re: Mouse cursor disappears.
    Vyper007 Level 1 Level 1 (0 points)

    Thanks for the update SteveKir, however I dont for a mminute think this is a hardware fault, this is clearly an OS fault, for the following reasons

     

    1. This only started happening to me after I did a Clean Erase and Install of Mountain Lion (I didn't upgrade from Lion)

    2. Loads of other people are having this issue, this thread proves that.

    3. I never had this issue in Lion

    4. It only happens when I go from one screen to another and then zoom in, if it were a hardware fault it'd happen even on the single screen I'm now foreced to use cos Mission Control is now useless to me.

     

    This is clearly a software bug that Apple need to address

  • 29. Re: Mouse cursor disappears.
    seegoer Level 1 Level 1 (5 points)

    Glad you got the problem solved but it's not likely a hardware problem. From what I've read in other threads, it happens on old and new Macs running Mountain Lion.

     

    I also changed the mouse from wireless to a spanking new wired mouse. I think (not sure) but I'm fairly certain I tried it on both wired and wireless keyboards.

     

    Seems random.  I'm business user with Mountain Lion running on a several macs. Problem only happens on one of three new Mac Mini computers purchased over the last two weeks. No issue when I upgraded my Macbook to Mountain Lion either.

1 2 3 4 Previous Next