Previous 1 29 30 31 32 33 Next 491 Replies Latest reply: Apr 29, 2015 7:01 AM by Dave Garley Go to original post Branched to a new discussion.
  • SteveKir Level 3 Level 3 (545 points)

    DMQ1202 wrote:

     

    I just experienced this problem for the first time. The cursos disappears on while using Citrix. The last time I used Citrix was before the update to Mavericks (and 10.9.1). The Citrix I used before was an older Windows version (Don't know if this makes a difference..)

     

    Glad to see i'm not the only one having this problem...

     

    Is it possible that my Mac is too old for Mavericks? (Mini 2 GHz Intel Core 2 Duo / 4 GB 1067 MHz DDR3)

     

    I don't know. However, the mouse cursor problem affects many users and is well known. It first appeared in 2011 with Lion, then Mountain Lion, and now in Mavericks.


  • xgretsch Level 1 Level 1 (0 points)

    I have a new iMac with Mavericks, and I get occasional cursor disappearances on the magic mouse, mainly when using Netbeans (which is a Java application).

     

    I also have a frequent problem with the right click being intermittent - it will often get interpreted as a left click. The "use it as a paperweight and revert to six year old non-Apple mouse" solution is beginning to look attractive.

  • CT Level 6 Level 6 (17,245 points)

    Usually caused by a third party software conflict.

  • nickjb Level 1 Level 1 (0 points)

    I've had the "disappearing cursor" issue for ages now, but just started having a much more serious and harder to deal with problem

    Photoshop CS5.1

    Mac Pro, OS 10.8.5

    Wacom tablet and Apple mouse.

    Issue is only happening (as far as I can tell) with Photoshop (possibly in Illustrator and InDesign, but I don't use them as much and the tool/cursor in those work differently to Photoshop).

     

    Cursor sitting on image, my hand not even touching the mouse or wacom pen, and the cursor is "jumping" between the tool selected (hand tool, healing tool, brush tool) and the black arrow select tool.

    If I zoom in and attempt to use the healing, clone, tool or brush tool, the "clone from" and "clone to" tools disappear, so I can't tell where I'm working. Same thing with the Brush tool. The round cursor disappears completely so I'm working blind.

     

    I've reset the tool preset, changed between the wacom tablet and an Apple mouse, closed PS, rebooted machine etc, Reset PRAM, pulled Preferences onto desktop, still having the issue. So very different from the "cursor disappears till you cmd-tab to a differnt program or go to the dock cursor issue".

     

    I'm kind of stuck now. Not sure I want to upgrade to Mavericks as I'm not convinced it's an Apple problem and not an Adobe problem, but not sure what to do now.

  • derdado Level 1 Level 1 (0 points)

    The problem was gone for a long time, but now it is back. :-(

  • Slab Ghost Level 1 Level 1 (0 points)

    Same here! Just started happening again after a long absence.

     

    It seems to be when I am using mail.com, but pressing cmd+Tab has at least solved it again for now.

  • Aphrodit-E Level 1 Level 1 (0 points)

    i have the same exact problem.  the mouse cursor only started disappearing on me when i upgraded to mavericks and the issue mostly arises when i use citrix for work.  this has frustrated me to no end and have tried all the remedies recommended in all the threads i have read but nothing works.  it's making working from home impossible!

     

    i read this article where the author was recommending an app called pinpoint mouse enhancer.  it enhances the cursor with whatever you select (a circle, a larger arrow, etc...) and it stays on the screen when your cursor disappears.  it's $4.99 which ****** me off to have to spend, but now i can work from home and that makes it worth it for me.   

  • Aphrodit-E Level 1 Level 1 (0 points)

    Until apple finds a solution to this problem (if they ever will), this app has truly saved the day for me!  I have no need for the animated graphics so I just use the larger arrow.

     

    Pinpoint Mouse Enhancer

    https://itunes.apple.com/us/app/pinpoint-mouse-enhancer/id408265505?mt=12

     

    Description:  Pinpoint displays an animated graphic around your pointer.  It can help locate the pointer on your screen or multiple screens.  It is also a great way to enhance your pointer with fun animated graphics!

  • Michael Paine Level 2 Level 2 (330 points)

    Neat - thank you

     

    The cross-hairs feature is useful for aligning objects.

  • rociorod Level 1 Level 1 (0 points)

    My pointer started to disappear only after downloading Maverick. I had my Macbook pro for 2 years no issues. Ran smoothly and great. 

    The problem began after 6 weeks of Maverick installation. After communicating via one email and 2 phone calls to Apple Care my problem was not solved, the customer assistance folks tried to be helpful but got no real answers. In fact, the 3 people I communicated with had not ever heard of the problem until I told them to google it. (hard to believe given all the mac users in the world and that this is happening to a lot of people).

    I then made appt. with genius bar. My 'genius' was very nice and attentive and was the first person to acknowledge that the problem exists since he himself has had it on his computer. He said 'glitch in the software' probably having to do w/permissions etc. Did a diagnostic made a couple of suggestions...I already knew about command tab, and force quit (how you get your cursor back) but I still have my problem.

    Right now its happening once a week when I am on safari or chrome and I am hoping to God that this will not get worse. Several articles have been written about this and can be found on a quick search on google. I am very surprised and somewhat disappointed that this has not been taken care of by Apple since so many are experiencing this annoying glitch.

  • SteveKir Level 3 Level 3 (545 points)

    Join the club. My mouse pointer, and/or mouse disconnection, has been going on for 3 years now, in Lion, Mountain Lion and now Mavericks. Its good that I have a Magic Trackpad which I can use to navigate to System Prefs > Mouse and ask it to come back. Very disruptive. No soluton found. (I have other mouse problems too.)

  • clundie Level 1 Level 1 (0 points)

    My cursor used to disappear after using iTunes in full-screen mode. I had to uninstall XQuartz, which I must have installed years ago for something that I don't use anymore.

     

    http://xquartz.macosforge.org/trac/wiki/X11-UsersFAQ#UninstallSnowLeopardorLater

  • TinPigeon Level 1 Level 1 (10 points)

    Changing

    Settings > Accessibility > Display > Cursor Size

    worked for me.

  • SteveKir Level 3 Level 3 (545 points)

    I tried this several times over the last two years and it didn't work. I have now tried it again. We'll see.

  • bulvio78 Level 1 Level 1 (0 points)

    Hi, I'm new here.

    I am italian, and italians are famous for their very good english, so... sorry.

     

    Is there a similar discussion for Yosemite? I have your problems with pointer, specially with photoshop and VmWare Fusion in fullscreen mode.

    No solves with reboot, pram reset, cursor size setting, and other stuff...

    Sometimes it works fine changing window and returning again on it (for photoshop), but it works only for few minutes...

    sad.....