12 Replies Latest reply: Sep 16, 2013 1:55 PM by Kettle4
qbfiji Level 1 Level 1 (0 points)

Since I downloaded the new OS I've had issues with the system preferences window. Each time I access my preferences tab I am unable to click on many of the icons. For example if I click on the iCloud icon an error message pops up saying "To use iCloud preferences pane, System Preferences must quit and reopen". When I click "OK" it restarts the System Preferences and the same error message pops up again.

 

The icons that have the same error message are:

 

- Desktop & Screensaver

- Security & Privacy

- Notifications

- iCloud

- Mail, Contacts & Calendars

- Date & Time

- Software Update

- Dictation & Speech

- Time Machine

- Startup Disk

 

How can I access these preferences?

 

Thanks in advance for any help you can offer.

 

qbfiji.


MacBook Pro, OS X Mountain Lion
  • 1. Re: System Preferences issues
    Therabyte Level 4 Level 4 (1,070 points)

    First thing you should try is creating a new user, log in with it and see if the problem replicates.

  • 2. Re: System Preferences issues
    David A. Gatwood Level 3 Level 3 (580 points)

    And if that doesn't work, reinstall.  This sounds like an installation hiccup, in all likelihood.

  • 3. Re: System Preferences issues
    Joseph Delaney Level 3 Level 3 (550 points)

    Did you ever muck about with 32-bit or 64-bit kernel settings when Leopard, Snow Leopard, or Lion came out? There were some "hacks" that people were talking about, and if you tried any of them you might be stuck in the wrong mode. System Preferences will offer to restart when it runs across a 32-bit preference pane and it's in 64-bit mode (or the other way around) - and if you had forced it into one mode long ago and then forgot about it, it might not work correctly now.

  • 4. Re: System Preferences issues
    psychotic1 Level 1 Level 1 (10 points)

    Thanks!  If it hadn't been for your comment, I might never have solve this same problem. It turns out that I had chosen to always open System Preferences in 32-bit mode. To correct this, I uses the Get Info command on the System Preferences app in the Applications folder. I unchecked the "Open in 32-bit mode" box, and voila, all the System Preferences work.

  • 5. Re: System Preferences issues
    qbfiji Level 1 Level 1 (0 points)

    Thanks very much for all the advice guys! I ended checking the 32 bit mode problem and it actually was checked. I don't even remember doing that, but once I unchecked it I could access all the preferences again.

     

    Appreciate all the help.

  • 6. Re: System Preferences issues
    David A. Gatwood Level 3 Level 3 (580 points)

    That's definitely a bug.  I'll file one for you.

  • 7. Re: System Preferences issues
    psychotic1 Level 1 Level 1 (10 points)

    Thanks!  I can't find there bug report submission instructions (maybe it's just for developers now?)...if you could also report this I'd appreciate it:  Ambrosia Software's previous version of the Easy Envelopes widget consumes 100 percent of CPU processes...thanks!

  • 8. Re: System Preferences issues
    David A. Gatwood Level 3 Level 3 (580 points)

    Do you mean the $10 version from the App Store or the free Dashboard widget?  If the former, you should report the bug to Ambrosia.  If the latter, that might be an OS bug—hard to say.  Reporting bugs to Apple requires a free ADC (developer) account, and the website is http://bugreport.apple.com/.  Or you can always send feedback to Apple through http://www.apple.com/feedback/.

  • 9. Re: System Preferences issues
    psychotic1 Level 1 Level 1 (10 points)

    The free one...I use it so infrequently that I had no idea it no longer works...I did report the problem to Ambrosia...I found it by terminating my dashboard processes and turning my widgets on one-by-one while monitoring the CPU activity...when I added Easy Envelopes my CPU use shot to 100 percent and stayed there...thanks for the tip about reporting the bug to Apple...

  • 10. Re: System Preferences issues
    brady.gower Level 1 Level 1 (0 points)

    Based on what Joseph Delaney said, I would have gone through the entire, long process of reinstalling the OS X (EDIT:  I will clarify by adding that without his response, however, we may never have figured out the issue to be a 32/64 bit problem).  So, thanks Joseph!  And, thanks, psychotic, for the added tip that turned out to be an easy fix.  This worked for me as well and saved me a great deal of time!

  • 11. Re: System Preferences issues
    monokia Level 1 Level 1 (0 points)

    Hello guys,

    I have the same problem with system prefs on 10.6.8, but when I checked this 32 bit mode thing with the get info, the little box was unchecked. So this is not an option to me. Can you help me? :-o

  • 12. Re: System Preferences issues
    Kettle4 Level 1 Level 1 (0 points)

    I have a Mac Mini off 2007,because I am waiting till the new one comes out.

    The computer gave a pop up delete some files not enough room.

    So I asked about Automator,and prctically everyone did not use it,and that it was safe to delete it.

    I went into the Libaruay and deleted all the folder`s to do with Automator.

    Later on when I opened up System Preferences to change the Energy Saver a pop said can`t load so I checked them all. The ones that did not work were Desktop & Screen Saver,Energy Saver,Spotlight,and Desktop Preference Pane all the rest worked.

    I am 64 yrs old and not very technically minded could you please help. Thanks In Avance