Previous 1 2 3 Next 87 Replies Latest reply: Apr 3, 2013 8:03 AM by ohkami
Monkiineko Level 1 (0 points)

I own my own domain, under which I have several email addresses configured that all wind up being forwarded to a single account.  With Mail in Snow Leopard and Lion, when I would reply to a received e-mail, the "from" field would be set corresponding to the e-mail address the original message had been sent to, making it easy to ensure the correct address is used.  But in Mountain Lion, it appears that when I reply to any message, the "from" field of the reply is now being set based on the account which received the message.  As such, I must now remember to manually change the "from" field everytime I reply to a message, or it will be sent out using my single account e-mail ID, which I actually never want to use.

 

Does anyone know of a way to get Mail from Mountain Lion to default the "from" field in a reply based on the "to" field of the message being replied to, as older versions of Mail used to do?


Mail, OS X Mountain Lion
  • laurafrommedford Level 1 (0 points)

    Just to elaborate or say the same thing in different words: I forward mail from various private and work accounts to iCloud, so I receive and read all my emails in my iCloud inbox. The problem is that I never want to reply to messages using my iCloud email address (which no one knows) but the default "from" address when I reply to my messages is now the iCloud address (@me.com), so I have to manually choose in the "from" menu the account to which the email sender originally wrote. Every time.

     

    Mail settings allow to choose the default "from" field (outgoing mail server) for new messages you compose, but I don't see any options changing preferences for outgoing mail servers when replying to a message.

  • parna Level 2 (295 points)

    Boy those posts confused me. If I understand correctly, you want to send from the same email address the original was sent to. The only way I think you can to do this is to set up individual accounts, then they set the "reply from field" to the same as the "sent to field". If you redirect stuff through iCloud then it will default to resending from iCloud.

     

    Perhaps someone else may have a solution.

  • laurafrommedford Level 1 (0 points)

    Yes, you understood correctly. But I didn't have this problem using the exact same configuration in Lion. There seemed to be a default setting in Lion that the "from" field would be the same as the address to which the email was sent, regardless of the inbox where it ended up when I was reading it. The change came when I switched to Mountail Lion yesterday.

  • toonetown Level 1 (5 points)

    Yes - just to verify.  I am having this same exact issue.  When replying to an email, the "From" field used to be set to the address that the original email was sent to.

     

    So - if I have 3 accounts, a, b, and c - and I got an email addressed to b, replying to that message in Leopard and later would set the from field to b.  In Mountain Lion, it sets the from field to a (which is my default account).

     

    This is a real pain...

  • parna Level 2 (295 points)

    That is not happening for me. I have an iCloud account and 3 other accounts. If I select an email in any of those accounts and reply to it, then it replies from the account it was sent to.

  • toonetown Level 1 (5 points)

    Perhaps, in my case, it's due to the fact that I am using multiple email *addresses* - and not actual multiple *accounts*.

     

    That is - all my email addresses forward to a single email account, which is downloaded (via POP), and I have set up that account to be associated with multiple addresses...as is described at http://email.about.com/od/macosxmailtips/qt/Use_Multiple_From_Addresses_with_a_M ac_OS_X_Mail_Account.htm(amont other places)

     

    The big problem is this "just worked" since at least Leopard (possibly earlier) - but no longer works in Mountain Lion.

     

    BTW - I get the same behavior in iOS as well.  Maybe they are also porting bugs "Back to the Mac"...

  • parna Level 2 (295 points)

    Sorry, so many links to links in that link you provided I quickly got lost and don't know what you were referring to.

  • laurafrommedford Level 1 (0 points)

    This has always been a problem with using iCloud in iOS but it wasn't a problem in Mail when I was using Lion. So the difference is related to Mail in Mountain Lion.

  • toonetown Level 1 (5 points)
  • Andreas Amann Level 5 (7,815 points)

    I guess we all have to go ahead and file bugs with Apple:

    https://bugreport.apple.com (for registered developers only) or

    http://www.apple.com/feedback/macosx.html (everyone)

     

     

     

    Andreas

  • parna Level 2 (295 points)

    toonetown wrote:

     

    Sorry - lookalike the forum messed up my link - the link is http://email.about.com/od/macosxmailtips/qt/Use_Multiple_From_Addresses_with_a_M ac_OS_X_Mail_Account.htm

    Ah, now I understand. This is a pretty non-standard way of setting up email accounts, so probably nobody beta testing would have had such a configuration.

  • nautilus2104 Level 1 (0 points)

    This is happening to me too. I have several gmail address with different accounts and I can only reply to any of them with one email address. So everytime I reply I have to manually change the from field. I major pain if I'm replying to something like a Yahoo list because the replying email is not registered with that list. Didn't happen previous to ML being downloaded.

  • parna Level 2 (295 points)

    toonetown

     

    I just set up my iCloud account as per those instructions, with 4 different email addresses all listed in the one email field, as all these accounts are routed through iCloud, and when I selected them in the iCloud inbox and hit reply, they all replied to the address they were sent to, not the iCloud account. So this is still working in Mountain Lion. Perhaps you need to remove yours, save, then re-add them? They may work then.

  • toonetown Level 1 (5 points)

    I've rebuilt everything for my mail (re-imported all my messages, recreated all my accounts, redid all my settings)

     

    The only difference is I'm routing everything through a gmail account - not iCloud.  Maybe I could try routing everything through iCloud instead...

Previous 1 2 3 Next