Previous 1 2 3 4 5 6 Next 87 Replies Latest reply: Apr 3, 2013 8:03 AM by ohkami Go to original post
  • hi-tech Level 1 (0 points)

    Thanks for the plist edit tip (think I did the same prior to under leopard/snow leopard years back). I'm now back to normal under mountain lion. Was going crazy trying to remember to check the email addy sent from with the correct from name and from signature. Adding the email alias address alone as (also KB by Apple) others mentioned is definetly not the same.

     

    This is more of "multiple identies" under one account, not just multiple email address aliases. 

  • Kawanaut Level 1 (50 points)

    If you haven't already, I strongly suggest that you add your bug report here (just requires an AppleID to login, not developer or anything): http://bugreport.apple.com

     

    The more of us who do that, hopefully the bigger chances we'll have of getting this fixed.

     

    My temporary fix is like this...

     

    My setup is to have Google Apps (lets just call it gmail) download mail from multiple work-related POP3 accounts, into my personal gmail account, so I have everything in one place. Same Mac/iPhone for personal/work anyway. This has always worked fine, but with Mountain Lion, when I reply to mails sent to work, it will select my private address as "from", which is the whole problem in this thread.

     

    My temporary fix then goes like this: In Mail.app, setup a rule for each work mail address, so that when mail arrives on my Gmail account, that was originally sent to my work account, it will be moved back to the work accounts folder in mail.

     

    This does several things:

     

    1) I can no longer see the mail on any other device, it's only stored locally on my Mac, since it's now gone from gmail imap. *****!

     

    2) When I reply to it, Mail will now select the correct "from" address. Yay!

     

    3) Any junkmail sent to my work addresses that makes it through the server spam filter AND gmail spamfilter BUT is being caught by Mail.app junkfilter, is still being shown in my inbox, because I can't figure out how to tell my Mail.app rule to only move mail that is NOT junk, the rule will only allow "IS junk", which wouldn't work here. Luckily it's just a few mails a day. Annoying!

     

    4) Few times a week I have to manually open my work account folders on my Mac, and move the mails back to my Gmail account, once I have dealt with them. This uploads the mail back to Gmail IMAP and the mail is now again accessible on my all devices and stored in the same place (plus on gmail). Inconvenient!

     

    So basically: Apple, please fix it !!!

  • psychdoctor Level 1 (0 points)

    bugreport.apple.com would not allow me to sign in, and said I needed to be an Apple Developer. 

     

    sigh.

     

    Jeff

  • Blaine Damage Level 1 (0 points)

    I've noticed its for messages "On My Mac".   If you reply from the Mac Inboxes up top, no problem at all.   I have rules set up to move the messages from those mailboxes to ones below "On My Mac".   Once the messages are down there the always reply via the default address, and copy the receiving address.  Extremely annoying!

  • James Sheffer Level 1 (0 points)

    I also have this problem with the exception that I do not use iCloud with my mail accounts.

     

    I have several accounts I use (Business and Personal) and mailing lists I belong to.  It has become a HUGE annoyance as I have to check every single email I send or reply to!  No matter which mail box I am responding from, all my emails go out from the default email address, even after choosing "Use the same message format as the original message" box.

     

    I have tried all the usual suspects in terms of fixing this - quitting and restarting mail and computer, changing hte setting/turning it off and on, etc...  None of which have made a bit of difference.  Almost ALL of my accounts are unique (not being distributed from one mailbox account to other accounts - the accounts are all seperate on the mail server.  They are all POP accounts, with no forwarding form g-mail/Yahoo type accounts.

     

    I hope Apple gets this fixed soon or I will have to change email clients and I would HATE to have to do that!

  • Blaine Damage Level 1 (0 points)

    The only sure fix for this, as far as I can tell, is to cancel all rules moving messages from the Mail inboxes up top to folders "On My Mac" down below.

     

    If you reply from a mail in the boxes up top, Mail uses the correct address.   So you're all good.   I've been replying and manually moving each mail to a box for filing below "On My Mac."    A pain?  Yes.  But at least I'm sure that the address I am replying from is the correct one for the account.   A word of caution--if you are searching for an old email it may include relsults from both places, resulting in replies from the wrong account!

     

    If this keeps up much longer I may have to give up and return to Entourage.  Once upon a time PCs were considered computers for "business" and Apples were somewhat of playtoys.   It seems that the Apple don't want to be heavy hitters in the world of email, and may relegate themselves to "toy" status with this latest incarnation of Mail.

  • Chrispcritters Level 1 (15 points)

    Upgrading to 10.8.1 does not appear to resolve the issue.

  • Kawanaut Level 1 (50 points)

    Seriously?! That *****, big time!

  • toonetown Level 1 (5 points)

    Yeah - that *DOES* suck.

  • FreddiePie Level 1 (0 points)

    I really hope that Apple fixes this bug ASAP. It is amazing that nobody from Apple is even responding to this issue.

  • Kawanaut Level 1 (50 points)

    Apple does not monitor this forum - this is a "user to user discussion board". Maybe sometimes an Apple employee finds his way in here but they are not, officially, monitoring the forum. The best you can do is to submit feedback and a bug report. The more people who do it, hopefully the bigger chances we have of catching their attention.

    FreddiePie wrote:

     

    I really hope that Apple fixes this bug ASAP. It is amazing that nobody from Apple is even responding to this issue.

  • OC User Level 1 (0 points)

    Thanks, going to Mail>Preferences>Composing and changing "Send new messages from:" and selecting from a drop down list the account I would like to have as default account fixed my problem. The issue is that the Accounts tab no longer allows the draging of the accounts and changing their position the first on the list, hence the default account. Seems like in Mountain Lion, this functionality got lost but composing screen has the capability anyway.

  • megalaser Level 1 (10 points)

    Neither of the things you have said make any sense, the thread is about the fact that the reply to address no longer changes in accordance with the email account the mail is sent to (you have responded to this by explaining how you change the default 'from' address for new messages), then you said that you can drag the order of sending accounts within the composing screen and this is not the case. Thanks

  • Ed Level 1 (60 points)

    Same problem here ... sent in a bug report just now.

  • Bill Haag Level 1 (20 points)

    I came here to see if anyone else was having this issue and see I'm not alone. I have the same problem as I just replied to a customer and message went out through our home e-mail address instead of the business account. I got in a hurry and didn't check the address before clicking the send button.

     

    I will be sending a bug report to Apple too.