Previous 1 2 3 4 5 6 Next 87 Replies Latest reply: Apr 3, 2013 8:03 AM by ohkami Go to original post
  • Tommytune72 Level 1 (0 points)

    Just wanted to say thanks for posting these scripts.  After refusing to spend the time to set up an applescript for this bug, and all the while hoping Apple would fix it themselves, I've finally thrown in the towel and installed these two scripts, which work beautifully and are already saving me time and mishaps.  My only hiccup was putting a shortcut for reply-all, finally settling on control-option-command-R, which is a fistful, but only one fistful.

  • windermerelodge Level 1 (0 points)

    Well I can see that I too am going to have to do this as I've already managed to have a couple of annoying and embarrassing incidents due to this bug.

     

    I have to say as someone who only converted to Apple quite  18 months ago and this has really rocked my faith. People said Apple is great because it "just works" and I have to put up with a bug like this for months which just er "doesn't work" and should never have got through even the most basic QA. Add to that the fact that it came in an upgrade that stopped a perfectly good scanner and TV tuner card from operating and I wonder why I ever bought a Macbook.

     

    It's quite shameful Apple (if you are reading, which you obviously are not)

  • Andrew Shalit Level 1 (5 points)

    When I use the reply-to-all script, I get multiple copies of the quoted text in the new message.  Is anyone else seeing that?  Anyone have a fix?  Other than that it works great.

  • Chrispcritters Level 1 (15 points)

    It appears that 10.8.3 fixes this issue on messages received after 10.8.3 has been installed.

  • Tommytune72 Level 1 (0 points)

    Absolutely right!  Yay.  And just as I was about to dive into Applescript for Dummies!

  • megalaser Level 1 (10 points)

    Not for me!  updated to 10.8.3 and mail 6.3 and the problem is the same, it does not default the reply from the account that the message is sent to, it still sends from the default account in mail unless you change it manually.

     

    So you guys that say it's fixed, more info please, is this something you have heard or tested for yourself?

     

    Thanks

  • Andrew Shalit Level 1 (5 points)

    It appears mostly fixed from my testing.

     

    It used to be the case that if I moved a message out of my inbox into a local folder, then replies to that message would be sent from my default account rather than from the account that received the message.  That now longer happens.  Now when new messages come in, I can move them out of my inbox to a local folder and when I reply the reply still come from the correct account.  In addition, if I have old mail that was sent directly to me (i.e. not to a mailing list; my e-mail address appears in the headers), then I can reply to that and the reply comes from the correct account.

     

    It still doesn't work for old e-mails that were sent to e-mail lists; replies to those e-mails still come from my default e-mail address.  But it's 95% fixed.

     

    So, I've gone and removed the AppleScript services that I installed yesterday.  They were fun while they lasted!

  • megalaser Level 1 (10 points)

    you receive an email sent to you at fred@123.com

     

    you leave the message in your inbox and hit reply and it sends from the programs default address instead of fred@123.com

     

    You have to do something manually to be able to reply from the same address you received it.

     

    It's not fixed.

  • Andrew Shalit Level 1 (5 points)

    megalaser wrote:

     

    you receive an email sent to you at fred@123.com

     

    you leave the message in your inbox and hit reply and it sends from the programs default address instead of fred@123.com

     

    You have to do something manually to be able to reply from the same address you received it.

     

    It's not fixed.

     

    That's not what I'm seeing.

     

    When I reply to an e-mail message, the reply comes from the account that received the message.  This works if I leave the message in my inbox or if I move it somewhere else.

     

    I'm not doing anything special.

     

    The problem is fixed for me.  I don't know why it's not fixed for you.

  • Tommytune72 Level 1 (0 points)

    Yup, me too, not what I'm seeing - working for me too.  I have two email addresses, let's call them 'fred@123.com' like you submitted above, and then let's say 'fred.mercury@mac.com'.  123.com is my work addy, and mac.com is home.  All emails are received via the mac.com address through iCloud.  Default outgoing server is 123.com.  Since the 10.8.3 update, replying to a 123 email automatically uses the 123 server and address, and replying to a mac.com email automatically uses iCloud and the mac.com address.  This holds true whether the email remains untouched in the inbox or has been relocated and organized to one of my gazillion personal folders.

     

    Sorry you're having trouble.  I would make sure in your settings found in Mail/Preferences/Accounts/123.com that you have specified 123.com as the Outgoing Mail Server, and that you have 'Use only this server' checked.  In other words I would go back to check troubleshooting on this issue from threads about Lion and see if any of that advice works for you. If I have any eureka moment about this I'll pass it on via this thread.  If I remember.

     

    Best and good luck,

    TT

  • Athtart Level 1 (0 points)

    Hooray! At last I can agree with a post here! After updating to 10.8.3 I can finally reply to an email no matter where it resides and it will use the correct address for the reply, namely the one it was sent to originally. The good times are back! ;-)

     

    Thanks Apple! (but what took you so friggin long!)

  • megalaser Level 1 (10 points)

    OK thanks I'll try it!

  • ohkami Level 1 (0 points)

    @Andrew Shalit:

     

    Indeed, I also sometimes get multiple copies of the quoted text in the new message. It took me a while to notice this because it's sporadic. I.e., most of the time the reply-to-all script will work fine and not do this. But sometimes it does.

     

    What makes this sporadic behavior really bizarre is that it happens even when replying to the same message! E.g., try to use the reply-to-all script several times in a row to reply to the same message. Most times it will produce only one copy of the quoted text. But then every once in a while it will create a reply message with multiple copies of the quoted text. Again, I use exactly the same script on exactly the same message - but I get different outcomes. It's really strange.

     

    @All:

     

    OS 10.8.3 update solved the issue described in this thread for me, too. I.e., all replies are now sent from the email address to which the replied-to mail was actually sent. So, this behavior is back to where it was before 10.8 and where it should have stayed to start with.

     

    Unfortunately, what was still not solved was the other issue described e.g. here: https://discussions.apple.com/message/19113964#19113964, which is equally annoying. That is, Mail often places your own address in the cc or to field when doing a reply-to-all, so you have to remove it manually.

     

    If I may be allowed a general rant here: I do wonder how these kind of severe regressions can make it into a customer release of such a key program as Mail in such a supposedly software-pro company as Apple. It's a bit sad, isn't it?

Previous 1 2 3 4 5 6 Next