Previous 1 2 Next 15 Replies Latest reply: Oct 16, 2012 5:44 PM by wayodi
J-P McNown Level 1 Level 1 (0 points)

So, I've got a Mac Mini 2011 with a 256 SSD, and 16GB Ram. I've got 3 partitions on the fixed disk, a MAC OSX 10.8 boot partition, an ExFat Backup partition, and a 3rd Windows 7 Bootcamp partition.

 

From within MacOSX, I can setup file sharing fine, and enable SMB so that I can access the shared content via Windows 7. When I share out the ExFat partition, I can see it from Windows 7, but not access it. From another Mac on the network, I have whatever permission I've set up for the share, as intended. I can share my Mac OSX boot volume, and have no problems accessing it from windows or another mac on the network, and have whatever permissions I set up in the sharing options. To verify that this appears to be an issue related to ExFat and OSX, I also set up several USB thumb drives with various partition configurations, and the only way I could access them from Windows, is if the volume is formatted as Mac OSX journaled. Furthermore, I can have an ExFat partition shared out on a Windows 7  PC, and it can be accessed perfectly fine from any PC or Mac on the network, as it should be.

 

Please spare me the 3rd party workarounds, and rhetoric that involves dumping Windows. Can someone please just tell me, why can't a share be set up with an ExFat partition in Mac OSX,  so that it's accessible to Windows PC's? Thanks.


Mac mini, OS X Mountain Lion
  • steve359 Level 6 Level 6 (12,160 points)

    That is a strange fact of mac-world that you need to live with.

     

    My SL could not make an exFAT acceptable to Windows, but Windows 7 made an exFAT acceptable to my SL. 

     

    Unfortunate to find out now that you have so much in your Mac-used exFAT, but know you just need a temporary exFAT disk/partition to hold those files ... maybe a 32 GB thumb drive or an external drive.

  • J-P McNown Level 1 Level 1 (0 points)

    The second partition, which is ExFat, can be accessed perfectly locally from OSX as well as when I boot into Windows. It's only inaccessible shared over the network if using a Windows PC. I can actually boot into Windows 7, where the ExFat partition os also shared, and access it fine from any Pc or Mac on the network. I actually have this secondary partition set up with my home folders from both OSX and Windows in the same location. All my pics/music/docs/etc are in the same place, and accessible, from either OS.

  • steve359 Level 6 Level 6 (12,160 points)

    I can only tell you that a thumb drive I use for file-share works as exFAT for both when Windows formats it, but Windows fails to read it when OSX formats it.

     

    Cannot explain why, just can say it does.

     

    I hope this helps in some small way.

  • J-P McNown Level 1 Level 1 (0 points)

    Yes, I've also experienced that, though not recently, so hopefully that's been addressed. I think this is something a bit different. Good looking out though, thanks.

  • J-P McNown Level 1 Level 1 (0 points)

    So, after a lengthy call to Apple support, I was advised, it has been determined that OSX can NOT share exfat partitions over a network with a Windows pc, only other Macs. This of course makes no sense at all because why would you use exfat on a Mac, if not to make that volume accessible to Windows? The problem many have experienced with an exfat partition created by OSX being inaccessible by Windows was apparently addressed by OSX 10.6.6, so I've been told. I'm running OSX 10.8, and I'm hoping that a future update will enable osx to share exfat with windows. Granted, everyone I spoke with could also have been mistaken, and theres always hope someone will figure out the problem. Thanks.

  • duncanmkz Level 1 Level 1 (0 points)

    Incredible. I've just been tackling the same problem, after purchasing a Mac a week ago, and I thought there was something I was missing in my grasp of Mac networking. I am shocked by the degree of incompatibility that still exists between Mac and Windows - Apple advertising emphasizes the smooth interoperability between systems, but it seems to me that things have barely improved since I last owned a Mac Quadra 840AV in the early 1990s. Not only is a modern the Mac unable to write NTFS drives, it cannot share the only file format (exFAT) which can be used on both systems. I guess the only option is to copy all my terabytes of files off the drive, and reformat it as an HFS+ drive. (Windows can read the drive using third-party software.) It's a really bad solution, though.

  • J-P McNown Level 1 Level 1 (0 points)

    It was suggested by Apple support, that perhaps because I'm using an Apple TimeCapsule as a router, that it could be the reason for the inability to share. There is an admitted incompatibility with usb drives attached to a TimeCapsule formatted as NTFS or ExFAT. So I tried this setup on 2 other non Apple routers, and removing ALL security on the routers, the problem remains. I also attempted to connect directly over CAT5e through each of the routers, and adhoc directly to the mac. The problem remains. It doesnt appear to matter if the ExFAT drive/partition is on a local drive or USB, for whatever reason, OSX does not want to allow a Windows PC access to ExFAT over a network. Ridiculous. Just for s&g, im going to copy all my data off my Backup(exfat) partition, then let windows format it(i originally let osx 10.8 do it) to see what happens. Neither OS has any problem accessing the partition locally, but screw it, I'm bored.

  • duncanmkz Level 1 Level 1 (0 points)

    I doubt that the problem is linked to the TimeCapsule, because I don't have one, but I am experiencing what appears to be the same problem accessing exFAT drives. My setup uses an Ethernet network and a Netgear router. My exFAT drive was formatted on a Windows 7 system, and works fine locally on the Mac, but attempting to connect to it from a Windows system just gives a delay and then an error. I tried another brand of external drive. This is also inaccessible. I can, however, access (read-write) all shared folders on the Mac's main hard disk.

     

    I'm now copying over the drives content so I can see what happen when it's formatted as an HFS drive, but the transfer will take six hours to move between drives on the PC using USB 3.0, and then the same files will have to be sent from the PC to the the Mac over the network, which will take considerably longer.

     

    By far the easiest solution would be to set up a Windows (or Linux) system as a server for the Mac. Sharing in that direction doesn't present any technical challenge, and Windows is more chivalrous than Mac in sharing its information with the enemy. In this case, however, I am using the Mac (Mini) as an entertainment server, and I want the media files to be local so I can take advantage of the Mac's quiet operation and impressively low power consumption.

  • larrycura Level 1 Level 1 (0 points)

    Try this: make sure your SystemPreferences->Network->Advanced->WINS->Workgroup setting on your Mac is the same as your Windows workgroup. You may have to set up a new location (instead of Automatic) to accomplish that, but you need to do it so Windows can access the drive. Once they're the same, you can access the drive and read/write from/to it in Windows. I have an external 1.5TB connected via USB to my Mountain Lion Mac Mini and can use it from my Windows 7 Ultimate for everything except Windows Backup. Backup will see the drive on the network, but denies me access to it...even though I just copied files over and back to/from it on the Windows machine. Go figure. Someone figure out the Windows backup thing & we're in business!

     

    BTW, the USB external drive is exFAT...

  • duncanmkz Level 1 Level 1 (0 points)

    Thanks for the tip, Larry - I will try it with one of my other USB drives. For now, I've reformatted my Mac's external drive as HFS, and it was immediately accessible, with read-write access, on my Windows network. I tried moving files around, and moving and deleting folders on the Mac from a Windows machine, and everything works as it should. It's strange that the network configuration would have to be different with exFAT (assuming that's the problem). Re your Windows Backup issue, this sort of thing is usually caused by the backup program running under a different account from the account you use. I highly recommend Cobian Backup, which is free, has a professional set of features, and does a great job of scheduled backups. I like that Cobian stores files as files (rather than in an archive) which makes it much easier to get at your data in an emergency. If I've deleted a file by accident, I just go into the backup folder, rather than having to open a backup program. Cobian is usually pretty good at backing up files over a network, between different file systems.

  • larrycura Level 1 Level 1 (0 points)

    ...now mine's not working...(/facepalm)

  • larrycura Level 1 Level 1 (0 points)

    OK, let's start over (/remove facepalm)...I now have my Mac Mini's USB external drive formatted as HFS by Mountain Lion. All 1.5TB in 1 partition. Windows 7 Ultimate has R/W access to the drive over the network (like duncanmkz). Windows Backup works (sort of), but only after I disable Comodo firewall. With C fw on, WB says the drive isn't available even tho Windows Explorer just R/W to it in a separate window (yes, I closed the WE window before Backup). Now, when WB starts, it chokes on the selection of the initial selection of the external drive on the Mac with "The specified network location cannot be used." After closing the dialog box and clicking OK on the Select Backup window (which now shows the previously-selected location as valid), click Next and Next and "Save Settings and run backup", and it starts! Backup progresses until about 93%, writing to the external drive on the Mac the whole time, then fails with error 0X8007054f. The external drive appears to have a complete backup on it, but it's not recognizable from the Windows machine for restore purposes. I've tried this 3 times with identical results. Anyone got any ideas on 1) why the Comodo firewall interferes the way it does, and 2) why Windows 7 Ultimate won't see a backup set it (apparently) created?

  • J-P McNown Level 1 Level 1 (0 points)

    I ended up giving up and setting my backup partition from ExFat to HFS. I installed Paragon for HFS on the Windows 7 partition, so I can read/write and store my pics/docs/etc on the backup drive, in the same location as the OSX home folder.

     

    Doing this allows me to share the backup drive across the network from both OS's, and it eliminates volume incompatibility workarounds needed for apps like iPhoto, and Aperture, etc. Accessing the HFS volume across the network from a Windows machine of course does not need the Paragon drivers loaded, only when accessing it locally. I still use ExFat for USB drives, I just accepted that Apple isn't interested in letting anyone share ExFat out across a network, which is when I boot into Windows, and do it without issue.

     

    Screen Shot 2012-08-28 at 1.13.jpg

  • J-P McNown Level 1 Level 1 (0 points)

    As an added bonus, by setting up my backup partition as HFS, and installing Paragon for NTFS on the OSX side(to enable read/write of ntfs from OSX), I can simply use TimeMachine to maintain a backup of the ENTIRE disk.

     

    I now have an external 1TB USB drive setup with an OSX Mountain Lion Recovery Disk  bootable recovery partition(1GB), and a 256GB Time Machine partition to maintain the entire drive. This is a freaking sweet setup, and works beautifully. With regular time machine backups, and online backups to my SkyDrive, I've got little concern for losing my stuff. To set up a usb drive with a Mountain Lion Recovery Disk Assistant partition, download it from here-http://support.apple.com/kb/HT4848 I used Disk Managment in Windows 7 to first set up the partitions on my 1TB USB, because Disk Utility in OSX wanted to kill the whole drive to repartition, and i've got data I didn't want to lose. Then I went back into OSX>Disk Utility and erased/formatted the 1GB and 256GB Then I used the Mountain Lion Recovery Disk Assistant to create a recovery partition on the 1GB. This is just incase I need to boot into recovery to restore a TimeMachine backup.

Previous 1 2 Next