Previous 1 10 11 12 13 14 Next 1,478 Replies Latest reply: Dec 19, 2014 1:42 PM by fegm Go to original post Branched to a new discussion.
  • Christopher Murphy Level 3 Level 3 (555 points)

    BIOS is to MBR, and (U)EFI is to GPT. And (U)EFI computers can sometimes have a CSM (compatiblity support module) to emulate BIOS, which is how Macs boot Windows for the moment, instead of natively EFI booting it. So at first glance it's GPT vs MBR. Because GPT is newer, there had to be a way to inform old MBR tools that the disk was reserved for GPT usage, so that they wouldn't inadvertenly think the disk wasn't used for anything else. So part of a normal GPT disk is to include an MBR also, but with a single "protective" entry that basically says "this whole disk, all of its sectors, are defined in the GPT, go look there". A hybrid MBR is a totally non-standard thing that has additional entries. And it gets really complicated...and mind numbing.

     

    The creator of GPT fdisk (gdisk) has more info on hybrid MBRs.

     

    And yes, the former one was replaced. There is only room for one hybrid MBR. It takes up exactly one sector on the disk, which happens to be the first sector (LBA 0).

  • dpwiese Level 1 Level 1 (0 points)

    I want to first thank Christopher and the other users in this thread for the discussion and advice. I think I was able to correctly figure out what I needed to do to bootcamp OSX 10.8 and Windows 7 on my new retina pro, with an additional shared partition. My intention was to have three equal sized partitions formatted as follows:

    1) HFS for OSX

    2) NTFS for Windows

    3) exFAT for shared data

    My goal was to be able to essentially use the exFAT data drive as an external hard drive that could be swapped between a Mac and a PC. Everything was working great for the first few days, but I think some Windows updates seem to have unmounted this data drive.

     

    When I boot into Windows, the Mac OS drive is still visible in explorer. The data drive shows up in the disk manager as empty unformatted space. In OSX the disk utility shows the data drive as being unmounted, and titles it `disk0s4'.

     

    I am hoping all of my data is still there, and that somehow the Windows update messed it up, although I am not even sure this is possible. In any case, I was hoping someone could offer some advice with the hope that I only need to enter a few commands to repair whatever happened, and my data will still be there.

     

    Thanks in advance!

  • Christopher Murphy Level 3 Level 3 (555 points)

    I don't have any idea without seeing the GPT. The normal case of OS X 10.8 + Windows means already four partitions. An exFAT partition would be partition 5. So your case is already not usual.

     

    Also, exFAT is more for flash media than hard drives. It's actually less robust than FAT32 which has two FATs, whereas exFAT/FAT64 has one FAT. If it gets corrupt, it's much more difficult to repair. You really need to use NTFS to share data between Mac OS and Windows if FAT32 isn't going to work.

  • dpwiese Level 1 Level 1 (0 points)

    Thank you for the reply, Christopher. I hope the following command provides the information you wanted to see.

    sudo gpt -r -vv show disk0

    It returns:

    gpt show: disk0: mediasize=751277983744; sectorsize=512; blocks=1467339812

    gpt show: disk0: Suspicious MBR at sector 0

    gpt show: disk0: Pri GPT at sector 1

    gpt show: disk0: Sec GPT at sector 1467339811

           start        size  index  contents

               0           1         MBR

               1           1         Pri GPT header

               2          32         Pri GPT table

              34           6        

              40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

          409640   488886712      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

       489296352      263712        

       489560064   488884224      3  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

       978444288   488894464      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      1467338752        1027        

      1467339779          32         Sec GPT table

      1467339811           1         Sec GPT header

    The additional exFAT partition was added as a fifth, but I created a dedicated USB drive on which to store the recovery utility, and deleted the recovery partition. I hope this is OK, and won't cause issues down the line when OSX updates are released, or something.

     

    I do not know too much about the different file systems, but it seemed exFAT would be the best choice for read/write access between Windows 7 and OSX without having to use any third-party software. The disk in my MacBook is SSD, if that matters at all. In any case, I am completely open to reformatting the data partition with any other file system of your recommendation. I have all of the data that was on there backed up so I won't lose anything. As long as I can have a shared partition reliably between OSX and Windows 7, I will be very happy.

     

    At this point, is there any other information I can look at to determine what the trouble is? Or should I go ahead and reformat the data partition in FAT32 using GPTdisk in OSX and continue from there.

     

    Thank you again for the help and advice.

  • Mobzy3000 Level 1 Level 1 (5 points)

    I am also experiancing this issue, I tried creating an extra FAT parition and when I rebooted I got this error. Disk Util looks like this now:

     

    /___sbsstatic___/migration-images/200/20038122-1.png

     

    also, here are the results from sudo gpt

     

    Disk: /dev/disk0geometry: 30515/255/63 [490234752 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

    ------------------------------------------------------------------------

    1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>

    2: AF 1023 254  63 - 1023 254  63 [    409640 -   87932512] HFS+       

    3: AB 1023 254  63 - 1023 254  63 [  88342152 -    1269536] Darwin Boot

    4: 0B 1023 254  63 - 1023 254  63 [  89612288 -  146442240] Win95 FAT-32

    Administrators-MacBook-Air:~ administrator$

     

     

    ----------------------------------------------------------------------------

                  

    gpt show: disk0: mediasize=251000193024; sectorsize=512; blocks=490234752

    gpt show: disk0: Suspicious MBR at sector 0

    gpt show: disk0: Pri GPT at sector 1

    gpt show: disk0: Sec GPT at sector 490234751

          start       size  index  contents

              0          1         MBR

              1          1         Pri GPT header

              2         32         Pri GPT table

             34          6        

             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

         409640   87932512      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

       88342152    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

       89611688        600        

       89612288  146442240      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      236054528  254179328      5  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7

      490233856        863        

      490234719         32         Sec GPT table

      490234751          1         Sec GPT header

     

  • Mobzy3000 Level 1 Level 1 (5 points)

    Also, when i try to run "sudo gdisk /dev/disk0", I type my password in and get a message stating that the command can not be found? Is it worth deleting the parition that I made? I just really need the data from the bootcamp parition and I need it to work. I can't seem to mount it and it won't even let me make a back-up.

     

     

     

    Thanks,

    Mo

  • Christopher Murphy Level 3 Level 3 (555 points)

    I need to see the results from this command also:

    sudo fdisk /dev/disk0

     

    There is no advantage to deleting the Recovery HD, because it's in between two partitions. So you now have unusable free space in between. The GPT itself appears to be properly formed. That the disk is not visible/usable in Mac OS X is not a good sign.

  • Christopher Murphy Level 3 Level 3 (555 points)

    Also, when i try to run "sudo gdisk /dev/disk0", I type my password in and get a message stating that the command can not be found?

     

    gdisk, a.k.a. GPT fdisk, is found here.

     

    Is it worth deleting the parition that I made?

     

    Doesn't matter.

     

    I just really need the data from the bootcamp parition and I need it to work. I can't seem to mount it and it won't even let me make a back-up.

     

    Obviously you need to reconsider your backup strategy, that you're in this situation without a viable/current backup. Just saying.

     

    I take it Mac Evans 2 is the Boot Camp volume? It should mount as read-only in Mac OS X for you to get your data off of it, without booting into Windows. You should do that first. Then you can use gdisk to create a new hybrid MBR, adding partitions 4 and 5, and making 5 bootable.

  • dpwiese Level 1 Level 1 (0 points)

    Thanks again for the reply. The results of the command

    sudo fdisk /dev/disk0

    returns

    Disk: /dev/disk0geometry: 91337/255/63 [1467339812 sectors]

    Signature: 0xAA55

             Starting       Ending

    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

    ------------------------------------------------------------------------

    1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>

    2: AF 1023 254  63 - 1023 254  63 [    409640 -  488886712] HFS+       

    *3: 07 1023 254  63 - 1023 254  63 [ 489560064 -  488884224] HPFS/QNX/AUX

    4: 07 1023 254  63 - 1023 254  63 [ 978444288 -  488894464] HPFS/QNX/AUX

    And here is a screenshot of the disk utility with the unmodifiable disk0s4 data partition.

    Screen Shot 2012-10-16 at 3.07.20 PM.png

    Thanks again!

  • Christopher Murphy Level 3 Level 3 (555 points)

    The MBR and GPT match up. The problem is not with the partition maps. I'd boot in Windows and see if it can repair the exFAT volume. I don't know if Apple's Disk Utility can repair exFAT. The thing is, exFAT is inherently fragile as it lacks duplicate FATs like other file systems, and it lacks a journal to recovery more quickly/easily from abrupt crashes or power loss, so I'm not sure what the likelihood is for successful repair or recovery.

  • dpwiese Level 1 Level 1 (0 points)

    OK, I will try that, Thanks! If I am unsuccessful at repairing the exFAT data partition in Windows, your next recommendation for my needs would be to try to reformat as FAT32? Or format it as NTFS or HFS+ and use one of the third party utilities to enable read/write between operating systems?

  • Christopher Murphy Level 3 Level 3 (555 points)

    Well my recommendation is to not use Boot Camp. I'd use a virtual machine, in which case you can share files between environments very easily and safely without having to mess around with partitions and file systems.

     

    FAT32 will take a long time to repair if it gets particularly full with many files and you ever have a crash or power failure, because it lacks a journal. It also has a file size limit of 4GB, and volume limit of 2TB. So if those are problems you'll need to use HFS+ or NTFS. Between NTFS and HFS+ it's a coin toss. If these are just ordinary data files like word docs, spread sheets, images, movies, I would pick the 3rd party support solution that's the least expensive.

  • Mobzy3000 Level 1 Level 1 (5 points)

    Hey Chris,

     

    When I tried to make another Parition and I restarted my PC, It wouldn't boot into windows. When I made the partition, I called it Bootcamp2, when I booted up OSX when it wouldn't boot into windows I found MAC Evans 2 and disk0s4, I believe that disk0s4 is where bootcamp is stored, I checked this out with gdisk and partition 5 was marked as Bootcamp while 4 was marked as Mac Evans 2.

     

    Mac Evans 2 is also empty and disk0s4 is unaccesable.

     

    What I really want to ask is that if I follow your method on the first page, will it keep my data? When I was going through the steps at the end it tells me that it needs to delete all partitions?

     

    I just want to make sure, and as for backing up, I can;t seem to backup disk0s4 with disk utility as it doesnt want to mount?

  • Christopher Murphy Level 3 Level 3 (555 points)

    Please report the results from:

    gdisk -l /dev/disk0

     

    My suggestion is that you don't just start following directions meant for someone else, especially when I still don't have any idea how you got into this situation, or the state of your disk.

  • Mobzy3000 Level 1 Level 1 (5 points)

    Here you go:

     

    Administrators-MacBook-Air:~ administrator$ sudo gdisk -l /dev/disk0

    Password:

    GPT fdisk (gdisk) version 0.8.5

     

     

    Partition table scan:

      MBR: hybrid

      BSD: not present

      APM: not present

      GPT: present

     

     

    Found valid GPT with hybrid MBR; using GPT.

    Disk /dev/disk0: 490234752 sectors, 233.8 GiB

    Logical sector size: 512 bytes

    Disk identifier (GUID): 7CBAB763-7A10-4350-8803-0677E5B843FD

    Partition table holds up to 128 entries

    First usable sector is 34, last usable sector is 490234718

    Partitions will be aligned on 8-sector boundaries

    Total free space is 1469 sectors (734.5 KiB)

     

     

    Number  Start (sector)    End (sector)  Size       Code  Name

       1              40          409639   200.0 MiB   EF00  EFI System Partition

       2          409640        88342151   41.9 GiB    AF00  Mac Evans

       3        88342152        89611687   619.9 MiB   AB00  Recovery HD

       4        89612288       236054527   69.8 GiB    0700  MAC EVANS 2

       5       236054528       490233855   121.2 GiB   0700  BOOTCAMP

    Administrators-MacBook-Air:~ administrator$

Previous 1 10 11 12 13 14 Next