Previous 1 13 14 15 16 17 Next 1,499 Replies Latest reply: Feb 11, 2016 3:07 PM by SN225 Go to original post Branched to a new discussion.
  • Mobzy3000 Level 1 (5 points)

    Ok, I've tried a couple of things today and still no good. It seems that when I get into the Recovery Menu when booting off the Windows 7 disk, It doesn't detect the Windows OS on the partition and it asks that I should load drivers . Disk Utility still reports the same format but I've given up on that because it is just stupid.



    If anyone can give me any advice, it would be much apprciated! I tried making a copy of the hardisk with Acronis but it doesn't work if the drive is on a GUID format


    If I can't get this working, I'm just going to have to accept that I've lost all my data on Windows, fml.

  • Christopher Murphy Level 3 (555 points)

    when booting off the Windows 7 disk, It doesn't detect the Windows OS on the partition


    I suggest you start from the Windows 7 install disk, and use chkdsk, followed by chkdsk /f to make sure the partition even contains a valid, clean, NTFS volume. Nothing else matters unless that's true. Then you can try to do manual repairs. In order of bootloading: fixmbr, fixboot, rebuildbcd. There is a fourth, multi-step way to totally rebuild the bcd which is buried in this document.


    it asks that I should load drivers


    No idea.


    Disk Utility still reports the same format


    I don't understand what this means. Disk Utility has no idea what NTFS is, it cannot repair NTFS.


    tried making a copy of the hardisk with Acronis but it doesn't work if the drive is on a GUID format


    Disk Utility (asr) can make a sector copy of a partition so long as the volume (the file system) on that partition is not mounted. If that doesn't work something like:

    dd if=/dev/disk0s4 of=/Volumes/MyExternalDrive/folder1/windowsbackup.img bs=256k

    will make a sector partition copy. It will produce a file as large as the partition, every sector including the ones that don't contain information, so it will be a big file. Bigger than the amount of data you've got on that Windows partition.

  • Mobzy3000 Level 1 (5 points)

    Thanks Chris,


    I couldn't select the drive from the Recovery Options menu but I went straight to command prompt and I ran chkdsk, It's weird as only 29 file records where processed and 0 large file, EA records where processed. It detected the file system as NTFS;



    Windows has checked the file system and found no problems.


    3086 KB total disk space.

    4 KB in 9 indexes.

    0 KB in bad sectors.

    2485 KB in use by the system.

    2058 KB occupied by the log file.

    597 KB available on disk.


    512 bytes in each allocation unit.

    6173 total allocation units on disk.

    1195 allocation unites available on disk.

    Failed to transfer logged messages to the event log with status 50.



    I'm trying to figure out if I can select the Bootcamp partition using diskpart and run chkdsk and chkdsk /f on the selected partition. Running chkdsk /f on the hdd comes up with the message that it cannot write onto the disk.



    I know I have been a pain and that there is only so much you can do, so If I can't this figure out I'm just going to assume that the data on the bootcamp partition is gone. Maybe I'll wipe the HDD and try recovering it using a data recovery program.



    Thanks so much for your help.

  • Mobzy3000 Level 1 (5 points)

    I see that I am also missing the boot partition for windows.

  • Christopher Murphy Level 3 (555 points)

    It's found a 3MB file system according to those numbers. That doesn't make sense. I think the MBR contains incorrect start and/or end sector values, or the file system is irreparably corrupt. Probably the former.


    When you say you're missing a boot partition for Windows, this doesn't make sense given your original partition table you posted. And it's non-standard on a Mac because Boot Camp only creates a single partition for Windows to install into. The Windows installer will create a ~200MB boot partition (I think they call it a system partition actually) when it's installed onto a whole disk. But that's not what happened here. If you are positive you had a Windows boot partition, then the partitioning is wrong and that's why it's not finding the file system. The only practical way to proceed is to stop making any file system changes to any non OS X partition, and image those sectors. You might be able to use hexdump C and grep to find the start of the NTFS volume header, and from that find the proper start sector for this NTFS volume that's missing in action. This is quite tedious. But then you free up the drive to start over and get back to work.


    The sectors to image look like 89611688 through to the end of the disk. This can be done with the dd command also, where you add skip=89611688 flag along with if=/dev/disk0. So that will start imaging disk0 at sector 89611688 to the end of the disk.

  • AiOO Level 1 (0 points)

    I understand what you say. Thank you so much.

  • dakhipp Level 1 (0 points)

    chris murphy, you saved my windows! Thanks a lot man!

  • dakhipp Level 1 (0 points)

    Can you tell me if it would be a bad idea to do this with another partition of my hard drive so that I can install linux on it and make that portion bootable also?

  • Blue_Contact Level 1 (0 points)

    I'm receiving the following error


    sudo: gdisk: command not found


    Andy advise, please?


    I'm running OSX 10.8.2

  • Blue_Contact Level 1 (0 points)

    I have to download the package!... sorry... my mistake!

  • Blue_Contact Level 1 (0 points)

    Christopher Murphy, I followed your instructions... I managed to boot into windows, but now, the internal storage partition is inaccessible from Windows.


    Windows disk management reports it as "GPT protected partition"


    I'm running ML 10.8.2

  • Michael_8791 Level 1 (0 points)

    Hallo Chris,


    I followed the instructions in this topic and was able to select the Bootcamp partition again in the bootmanager but I am experiencing problems during booting in windows. After running the Windows 8 advanced startup manager and choose the refresh option it brings up the following message.


    The drive where Windows is installed is locked. Unlock the drive and try again.


    Can you help me with this problem. Is it possible I made a mistake somewhere during the process ?


    System setup:


    MacBookPro mid 2011 OSX 10.8.2 (12C60)

    3 partitions Mac OS, Bootcamp (running windows8) and 10 GB Fat32 partition.

  • Michael_8791 Level 1 (0 points)

    some extra info, I don't know if you need it but this might be helpfull.


    sudo gpt -r -vv show disk0 gave the following result:


    sudo fdsk /dev/disk0 gave the following:




    trying to restore or repair the bootcamp partition by prompt gave the following message:


    X:\>chkdsk /f

    The type of the file system is NTSF.

    Cannot lock current drice.

    Windows cannot run disk checking on this volume because it is write protected



  • Michael_8791 Level 1 (0 points)

    Thanks Christopher,


    I run through all steps again and this time Windows 8 did boot properly so problem is solved.


    Many Thanks,



  • Kazxn Level 1 (0 points)

    @Christopher Murphy Hello im experiencing the same exact issue. But i got lost in the steps you provided, is there any way you could please help me in a more simple way of explanation? Thank You

Previous 1 13 14 15 16 17 Next