Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Desktop Wallpaper keeps going back to the standard wallpaper after reboot

I updated to 10.8 and for some reason my desktop wallpaper will default to the Galaxy wallpaper whenever I restart or shutdown. I will change the wallpaper to something else, restart or shutdown and the Galaxy wallpaper will be back. I re-installed mountain lion and it has not resolved the issue. Anybosy experiencing the same issues?

MacBook Pro (15-inch Mid 2010), OS X Mountain Lion

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Glad to have helped! 🙂

Posted on

Question marked as Helpful

Jul 27, 2012 12:32 AM in response to Sean8477 In response to Sean8477

Open Terminal (Applications/Utilities/Terminal.app) and paste this command


rm ~/Library/Preferences/com.apple.Desktop.plist


press 'return' on the keyboard.


Log out, log back in again. Change the wallpaper to what you want. Log out, log back in once more to test.


Any improvement?

Question marked as Helpful

Jul 29, 2012 7:49 PM in response to Sean8477 In response to Sean8477

Also this helped for me 🙂


If your wallpaper changes back to default (Galaxy) after reboot or after logout it is because

the wallpaper you set was on another drive.

and this drive loads after your settings are loaded.

MAC OS X Lion / Mountain Lion does not save your wallpaper on the native HDD, rather tries to load the wallpaper from the original HDD, i guess only the path to the wallpaper is saved in the OS X settings.

Anyways..

what happens is that when your OS X boots up it does not find the path to your wallpaper since the HDD you've saved your wallpapers in has not mounted yet. 😟

One basic solution for this is to save your wallpapers in the HDD where you've installed the MAC OS X..

but I didnt want to save all my wallpapers in Native Mountain Lion HDD, so i figured out my perfect fix..!! User uploaded file

This is how i fixed..

I found this file in my Lion install drive.. autodiskmount.plist

Library/Preferences/SystemConfiguration/autodiskmount.plist

If you can't find it on your OS X Install Drive then you can make one by typing

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="0.9">

<dict>

<key>AutomountDisksWithoutUserLogin</key><true/>

</dict>

</plist>

rename ur txt file to autodiskmount.plist

save this in your MAC OS X HDD

Library/Preferences/SystemConfiguration/autodiskmount.plist

Voila..!!

restart your system..

User uploaded file

Now save your wallpapers where ever you want on your computer and i didnt have to worry about the wallpaper changing back to default.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Jul 27, 2012 12:32 AM in response to Sean8477 In response to Sean8477

Open Terminal (Applications/Utilities/Terminal.app) and paste this command


rm ~/Library/Preferences/com.apple.Desktop.plist


press 'return' on the keyboard.


Log out, log back in again. Change the wallpaper to what you want. Log out, log back in once more to test.


Any improvement?

Jul 27, 2012 12:32 AM

Reply Helpful (32)
Question marked as Helpful

Jul 29, 2012 7:49 PM in response to Sean8477 In response to Sean8477

Also this helped for me 🙂


If your wallpaper changes back to default (Galaxy) after reboot or after logout it is because

the wallpaper you set was on another drive.

and this drive loads after your settings are loaded.

MAC OS X Lion / Mountain Lion does not save your wallpaper on the native HDD, rather tries to load the wallpaper from the original HDD, i guess only the path to the wallpaper is saved in the OS X settings.

Anyways..

what happens is that when your OS X boots up it does not find the path to your wallpaper since the HDD you've saved your wallpapers in has not mounted yet. 😟

One basic solution for this is to save your wallpapers in the HDD where you've installed the MAC OS X..

but I didnt want to save all my wallpapers in Native Mountain Lion HDD, so i figured out my perfect fix..!! User uploaded file

This is how i fixed..

I found this file in my Lion install drive.. autodiskmount.plist

Library/Preferences/SystemConfiguration/autodiskmount.plist

If you can't find it on your OS X Install Drive then you can make one by typing

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="0.9">

<dict>

<key>AutomountDisksWithoutUserLogin</key><true/>

</dict>

</plist>

rename ur txt file to autodiskmount.plist

save this in your MAC OS X HDD

Library/Preferences/SystemConfiguration/autodiskmount.plist

Voila..!!

restart your system..

User uploaded file

Now save your wallpapers where ever you want on your computer and i didnt have to worry about the wallpaper changing back to default.

Jul 29, 2012 7:49 PM

Reply Helpful (7)

Aug 21, 2012 7:20 AM in response to softwater In response to softwater

Nope. I use wallpapers randomly selected from my iPhoto albums. I have 4 workspaces. Spaces 2, 3 and 4 have the wallpaper correctly applied. The main workspace still reverts back to the default galaxy wallpaper. I would be glad to help out with any diagnostics and troubleshooting info if you want to request it.


BTW, I tried deleting ~/Library/Preferences/com.apple.desktop.plist - no avail

Aug 21, 2012 7:20 AM

Reply Helpful

Aug 21, 2012 6:50 PM in response to Sean8477 In response to Sean8477

SORRY, I FORGOT TO ADD A STEP TO FIND THE "com.apple.desktop.plist"


~I'm running a base retina Macbook with Mountain Lion.~

I just got off the phone with Apple Support.


~~~On the Finder bar, click 'Go', hold 'alt/option', click Library.~~~


Now navigate to:


Library:Preferences , delete 'com.apple.desktop.plist'


Choose your desktop background; reset computer.

Aug 21, 2012 6:50 PM

Reply Helpful (2)

Aug 23, 2012 2:03 AM in response to Sean8477 In response to Sean8477

killall -HUP Dock reloads the Dock and wallpaper.


This isn't a solution, but a workaround:


a) Create a file called "killall_dock.sh" in your home directory, with the following contents:


#!/bin/sh

killall -HUP Dock


b) Save it.


c) Turn on execute permissions (run the command in Terminal.app)


chmod +x killall_dock.sh


d) Add the file killall_dock.sh as part of your Login Items from the System Preferences > Users & Groups preference pane.

Aug 23, 2012 2:03 AM

Reply Helpful (1)

Oct 1, 2012 5:42 AM in response to softwater In response to softwater

Hi,


I posted a similar thread since I'm having the same proble.


I tried what you suggested and it seems to solve the problem ONLY when I log-out then log-in again WITHOUT rebooting. If I change the wallpaper after entering the terminal command you mentioned and reboot straight away (without loging-out first), the wallpaper reverts to the previuous one.


It seems like the log-in window has something to do with retaining the last wallpaper I choose (not sure how).


Thanks anyways!

Oct 1, 2012 5:42 AM

Reply Helpful
User profile for user: Sean8477

Question: Desktop Wallpaper keeps going back to the standard wallpaper after reboot