6 Replies Latest reply: Jan 2, 2013 2:59 PM by theminibishop
peter1952 Level 1 Level 1 (85 points)

After upgrading to Mountain Lion and installing XQuartz I have the following problem:


Symptoms - double clicking the Gimp application activates XQuartz but Gimp does not start. The icon bounces once or twice and then dies.


I was able to get Gimp to run by customising the XQuartz application menu by inserting a new item for Gimp with the command path as follows: /Applications/Gimp.app/Contents/MacOS/Gimp.  When this is selected from the XQuartz menu Gimp launces and behaves normally.  But even after this it won't launch as a result of double clicking the icon.


Before the upgrade I was previously using X11 and clicking on the Gimp icon was all that was necessary.  My question  is whether this is normal behaviour under XQuartz or is something wrong.  I would prefer to open Gimp by the double click method as before. I have no other X11 applications in my Applications folder, so I cante test them to determine whether the problem is with Gimp or XQuartz.  Xclock and Xlogo work when called from the XQuartz Application menu but not when invoked from Terminal (which they previously did).  Invoking Xclock from the Terminal results in the following:


Last login: Fri Jul 27 17:27:58 on ttys000

iMac:~ peter$ Xclock

Error: Can't open display:

iMac:~ peter$



I have also noticed that I have a new folder (Opt) at the root level of my hard drive.  I'm pretty sure - but not 100% certain - this followed the installation of XQuartz.


Versions: Gimp 2.8.0p1 and XQuartz 2.7.2.


By the way I am really impressed with Mountain Lion.  My machine is a mid 2007 iMac with 3GB of RAM.  I was reluctant to install ML as my machine is the oldest one listed in the hardware requirements but I thought at $20.99 I couldn't go wrong.  After running it for about a day I am glad I made the change.  It seemed sluggish at first but now seems faster than Lion.

  • pmjd7 Level 1 Level 1 (0 points)

    Had the same problem and found the answer here http://gimper.net/viewtopic.php?t=12230

    You need to re-install xquartz, restart your mac and then it should rebuild the links between xquartz and gimp.

  • peter1952 Level 1 Level 1 (85 points)

    Thanks for taking the time to respond.


    I tried your suggestion but with no luck at all.


    Further info:  I have tried starting Gimp from the terminal.  It fails and I get the following result:


    iMac:~ peter$ /Applications/Gimp.app/Contents/MacOS/Gimp

    find: /Users/Shared/Library/Application Support/Gimp/help: No such file or directory

    2012-07-28 10:05:06.197 defaults[407:707]

    The domain/default pair of (org.x.X11, dpi) does not exist

    Cannot open display:

    iMac:~ peter$

  • Cimmy Level 1 Level 1 (0 points)

    I have a similar problem, I installed XQuartz, logged out and back in, but the DISPLAY variable does not get set and I cannot run any X11 application from  a  terminal. Everything works if I start XQuartz and open an xterm, but I prefer to use the terminal and used to be able to do it. With ML, not anymore. Any help would be greatly appreciated.

  • peter1952 Level 1 Level 1 (85 points)

    I have tried a number of ways to get it working properly but to no avail.  In the process I found that the issue also affects Inkscape.


    The best work around I can come up with is to start


    1. Xquartz manually
    2. Customise its Applications menu to add whatever you want to easily access (include the full path to the application file eg "/Applications/Gimp.app/Contents/MacOS/Gimp"
    3. Right click the Xquartz icon in the dock and select 'Keep in Dock' from the Options item
    4. Quit X11.


    Next time you want to run Gimp double click Xquartz in your dock and when it is up and running right click the dock icon again and select Gimp (or whatever) from the applications menu.

  • Dave Lasker Level 1 Level 1 (100 points)

    I also had this problem after upgrading to ML. Check out the posts at the end of this thread:



    Entering the "launchctl load ... " command into Terminal, followed by a logout/login (or reboot) fixed my problem.

  • theminibishop Level 1 Level 1 (0 points)

    I found this helpful and this worked for me. Thanks.