13 Replies Latest reply: Oct 29, 2012 10:40 AM by sgdenies
gondor81 Level 1 Level 1

After updating to Mountain Lion from Lion, my mail app cannot connect to the SMTP server provided so, I cannot send emails although I receive mails.

I reenter all data for the e-mail account, I restarted my MacBook and the problem still stands.

I called the Internet provider to check if they have some system problem but I was told that everything is in order with my account.

Once I try to send an e-mail a box from mail appears suggesting change of SMTP server or recheck of the validity of info provided.

Everything is entered correctly and, the problem remains.

Can somebody please, help?!


MacBook Pro, OS X Mountain Lion
Solved by gondor81 on Jul 27, 2012 5:33 AM Solved

Believe it or not I found a solution and, as it ususally is at the last place I thought possible.

I manually put one of the default ports numbers (25, 465, 587) as a custom port. 

 

Mail>Preferences>select the account>go to Outgoing Mail Server (SMTP): select Edit SMTP server list....>Advanced>select Use custom port: add any of the default port numbers, listed in the previous (above) option of Use default ports (25, 465, 587). I used 25.

So, insted of selecting Use default ports (25, 465, 587) select Use custom port: 25.

 

Good luck!

Reply by Radiation Mac on Jul 27, 2012 4:08 AM Helpful

If you haven't already, open the Mail app>click on the word Mail up in the Menu bar>click on Preferences>click on the "Account" tab>click on the User Aoount you want to set to highlight it>clcik on the "Account Information" tab over to the right>go down to the line reading "Outgoing Mail Server (SMTP)" and click on the drop-down box little arrow at the right end of the line>click on the bottom line "Edit SMTP Server List">click on first the "Account Information" tab and enter correct settings, then click on the "Advanced" tab and enter those settings>click "OK".

 

Hope this helps

Reply by parna on Jul 27, 2012 4:58 AM Helpful

Have you got online access to the accounts that you can use to send emails from until you get this sorted?

All replies

  • francescofromvr Level 1 Level 1

    it happened to me, I solved it

    test system preferences> mail, contacts and calendars> choose the service and follow the prompts.

     

     

    Then I did some cleanup in the keychain access because some were duplicates

  • gondor81 Level 1 Level 1

    Francesco thanks but it doesn't seem to work anyway.

    I am using POP setting and, this part works, I am getting emails.

    The SMTP setting is without a password it is linked to the username only. It worked this way previously.

    Anyhow, I tried and went to Mail, Contacts and Calendars and, when I selected the mail account in question I just got info that the account is enabled and that's it. In my keychain I have never had and still don't have a password connected to the mail account itself.

    Any other ideas?

  • Radiation Mac Level 5 Level 5

    If you haven't already, open the Mail app>click on the word Mail up in the Menu bar>click on Preferences>click on the "Account" tab>click on the User Aoount you want to set to highlight it>clcik on the "Account Information" tab over to the right>go down to the line reading "Outgoing Mail Server (SMTP)" and click on the drop-down box little arrow at the right end of the line>click on the bottom line "Edit SMTP Server List">click on first the "Account Information" tab and enter correct settings, then click on the "Advanced" tab and enter those settings>click "OK".

     

    Hope this helps

  • gondor81 Level 1 Level 1

    I did this several times....I reentered same data twice hoping that it will reset something, but it didn't.

    It still doesn't work, I am at work and I have to send important mails.......it is so frustrating.

    In the part of the settings box after the "Outgoing Mail Server (SMTP):" I am getting the set SMTP server with the crucial (Offline) info after it. So, mail is online I am getting mails but the SMTP appears to be offline.

    This is hopeless I think. I restarted mail for several times, the Mac twice as well hoping that it will get back on track but the problem persists. thx for trying anyway.

  • parna Level 2 Level 2

    Have you got online access to the accounts that you can use to send emails from until you get this sorted?

  • gondor81 Level 1 Level 1

    I did this awhile ago, had no other choice. However, my mail cannot take the SMTP server online, no matter what I do. I got across a post suggesting repair of permissions through Disk utility but this also didn't help.

    It seems that I have some serious browsing ahead of me today.

  • gondor81 Level 1 Level 1

    Believe it or not I found a solution and, as it ususally is at the last place I thought possible.

    I manually put one of the default ports numbers (25, 465, 587) as a custom port. 

     

    Mail>Preferences>select the account>go to Outgoing Mail Server (SMTP): select Edit SMTP server list....>Advanced>select Use custom port: add any of the default port numbers, listed in the previous (above) option of Use default ports (25, 465, 587). I used 25.

    So, insted of selecting Use default ports (25, 465, 587) select Use custom port: 25.

     

    Good luck!

  • Ruth Lea Level 1 Level 1

    Thank you. Worked perfectly.

  • Nevka Level 1 Level 1

    Tried using custom port 25, but didn't work. Restarted the application and now seems to work properly.

     

    Thanks for the suggestion!

     

     

    D,

  • DMCarr Level 1 Level 1

    Worked. Thanks gondor81!

  • Nevka Level 1 Level 1

    It worked the first time but it's stuck again :-(

  • jweastman Level 1 Level 1

    try using mail.domain.com as your smtp server instead of smtp.domain.com

     

    worked for me.

  • sgdenies Level 1 Level 1

    wow... I've tried all the above suggestions, and find some work some of the time, but nothing works all of the time.  A few weeks back I gave up & loaded Postbox and have had no problems whatsoever with sending emails on my Mac... Reverting to an earlier version than Mail 6.2 isn't an option, right?   Mountain Lion has shown to have some really cool features, I love it... but now that the honeymoon is over, I find myself wanting for the good old days, of a rock solid OS and apps that turned me into a man of many macs.