Previous 1 9 10 11 12 13 Next 218 Replies Latest reply: Nov 16, 2013 7:07 AM by mpvecchi Go to original post
  • lightthief1 Level 1 Level 1

    I finally found something that worked to resolve this for me between my ML install and win7.

    Wanted to share in case it helps anyone else.



  • wingfat Level 1 Level 1

    I have a temporary fix for accessing OSX shares from Windows 7. If you keep getting a request for a password and the password does not work you ...


    In OSX go to settings > sharing > options > UNCHECK "Share files and folders using SMB (Windows) > Done


    Then go back and RECHECK the SMB option.  You will have to do this again if you reboot OSX.

  • sm00thArsenal Level 1 Level 1

    It hadn't occurred to me until today, but you are right.. this does fix it until reboot. Cmon Apple, we're 2 major updates and a supplemental update in, sort it out.

    wingfat wrote:


    I have a temporary fix for accessing OSX shares from Windows 7. If you keep getting a request for a password and the password does not work you ...


    In OSX go to settings > sharing > options > UNCHECK "Share files and folders using SMB (Windows) > Done


    Then go back and RECHECK the SMB option.  You will have to do this again if you reboot OSX.

  • jbiehler Level 1 Level 1

    I have been having the same issues connecting to the mac from Win 7, I have been doing the diable windows sharing are re-enabiling to get it working again. Not a permanent fix.


    On the connecting mac to windows shares I have been having a whole bunch of issues. I put a new PC together (12 core Xeon, Wiin 7 Ulti) and where I could connect to my old Win 7 machine with no problem the new machine is a pain to connect to, even after setting the different setting in the security policies that I have done before to get it working. Sometime I cant see the share. Try connecting again and I can see the share and connect, but I cant write, and then sometime I can see it, connect it and write until I disconnect and then it startes all over again. And sometimes refusal to take my password and then seconds later taking it. Tried creating accounts on the PC with the same login/password as on the mac and setting permissions for that.


    I have tried just about every way to get this thing connected, smb://name/, smb:name/share/, smb://username:name/, smb://username:name/share, smb://smb://username:password:name/


    So far smb://smb://username:password:name/ seems to be working for the moment. I have also tried the regedit mods mentoned a couple posts up. I dont know if they will work. We'll see in the future.


    And one note for an earlier poster with no password for his share, you must have a password. The mac will not connect with a null password.

  • jbiehler Level 1 Level 1

    No, the reg editing on windows made no difference. Restarted and am having a heck of a time even connecting to the win 7 computer from my mac.

  • jbiehler Level 1 Level 1

    Actually, the registry modification in windows DID fix the problem for me. I no longer get the / instead of a list of shares and I am not having password connection issues. I forgot to restart the PC after making the registry changes. DOH!

  • madskoch Level 1 Level 1

    I have had issues connecting to SMB shares on my office server. I have been able to connect by entering the share address as suggested by others in this forum, but i have not been able to browse shares. I have also not been able to browse shared Windows 7 machines on the network - this worked fine before Mountain Lion.


    However, after a reinstall of Mountain Lion 10.8.2 on a brand new SSD disc things have been back to normal - browsing the network, including smb shares, have worked fine. Today i noticed that when turning on 'Back To My Mac' in the System Preferences, shared computers on the network disappears from the Finder. Turning off 'Back To My Mac' and restarting fixes the problem and browsing and connecting is back to normal. Maybe there's an issue with  'Back To My Mac'. Any others with this situation?

  • EJ Ruth Level 1 Level 1

    I found this link on the web.  I made these changes on my Windows 7 workstation and I'm able to connect to my Windows 7 server now.


  • James Hardie Level 1 Level 1

    I noted that after upgrading from Snow Leopard to 10.8.2 Mountain Lion, I started having trouble mounting Samba shares served by a Unix server on our network. 


    Connecting via the Finder resulted in the "There was a problem connecting to the server X, Contact your system administrator for more information" message when I used this syntax:




    After reading through this thread, I tried connecting via the command line / Terminal:


    $ mkdir /Volumes/sharename

    $ mount_smbfs //username@serverhost/sharename /Volumes/sharename


    I'm prompted for the password, and then the share mounts fine.


    So, it would appear to be some difference in the way the Finder initiates/handles connections and the way the underlying OS X operating system does (assuming that mount_smbfs is a part of the same system as the Finder's network share management).




    Message was edited by: James Hardie - corrected typo

  • agodfrin Level 1 Level 1
    Mac OS X

    I tried your suggestion of using mount_smbfs but that failed with:

    mount_smbfs: server connection failed: Socket is not connected


    Hmmm. So I tried instead with mount -t smbfs - and lo and behold, it worked! But only for a few minutes. Somehow the share disconnected, and when I tried mounting it again (either mount_smbfs or mount -t smbfs) I got again the same failure as above.


    I also tried smbutil view -g //albert@ which also fails with the "Socket is not connected" error.  I don't think there is anything wrong windows-side: I can access all the SMB shares from my Windows virtual machine running on my Mac.  I tried multiple times, all without success.


    I also tried connecting to my local windiows VM. Using the Finder Go to Server approach, I do get the user and password prompt, but the authentication fails - although I know for a fact that both username and password are correct. Trying the command line, I also get the authentication error.


    So there are a good number of problems with the whole SMB integration charade: mostly connections are rejected, and if they get through then they fail with authentication problems. Looking from the many comments and complaints I have found googling the web, all I can conclude that the SMB integration is seriously broken and has been for many versions of MacOS. I can also conclude that Apple is just not interested in fixing them.


    Granted, SMB is a lousy protocol, but it is still widely used in the Windows world. I am sure lack of proper support is hurting Apple's use in Windows shops.



  • agodfrin Level 1 Level 1
    Mac OS X

    Since SMB does not work, I thought of using a simpler approach: ftp. So I setup an ftp server on my windows server (Filezilla). And guess what, it does not work either.


    It works fine from command line.

    It works fine from the Filezilla clienbt.

    It works fine from Firefox.


    It does not work from Safari.

    It does not work from Finder (Go Server).

    In both cases I enter "", enter username and password and get the following error:

    There was a problem connecting to server ""

    The share does not exist on the server. Please check the share name, and then try again.


    After some debugging, I found out that nothing was wrong with my ftp. All ftp servers I tried failed the same way. For example works fine from all interfaces and OS's except from Safari and Finder.


    My patience with Apple is really running thin.

  • agodfrin Level 1 Level 1
    Mac OS X

    Sigh. Now I just tried the smb connect from the Finder. And guess what ? It works. Not only can I connect to the share I wanted, but I actually see all of the shares.


    I have no idea what caused that to finally work. And I suspect there is some random element to the whole story.

  • NiqueXyZ Level 1 Level 1

    I'm having a similar issue, but not exactly what you all are seeing.


    So, when I first got this (new Retina 13" MBP running 10.8.2.), everything worked fine.

    After a couple of days of closing lid (sleep) and resume, it would not reconnect the share, even if I tried manually from finder.


    Same error message as everyone else "there was a problem..."


    If I try from CLI, I get "server connection failed: Cannot allocate memory"


    The only way for me to fix this error and re-connect to the share is to restart my windows 7 computer!

    Here's what ***** also -- in this state, no macs can connect to my windows box at all.


    However other windows boxes can connect just fine!  It's like the retina mac is doing something to mess up the SMB server but then it only messes it up for Mac clients?  Makes no sense to me.  Anyway on my MBAir with 10.7 this used to work just fine.  Sigh.

  • Silver5656 Level 1 Level 1

    how do i remove the share on my win 7 pc?  and what share do i remove?

  • Silver5656 Level 1 Level 1

    n/m, figured it out.  tried it, didnt work

Previous 1 9 10 11 12 13 Next