Previous 1 2 3 4 5 Next 218 Replies Latest reply: Nov 16, 2013 7:07 AM by mpvecchi Go to original post
  • ChrVinther Level 1 Level 1

    I sit togehter with a colleauge who just updated from Snow Leopard and I from Lion. We both get the same error message when connecting to a smb server.


    If I open a word document (thorugh word - recently used files) saved on the server I am able to view the server, but not thorugh finder.


    Still need help to get it fixed!

  • OrdsWoW Level 1 Level 1

    Same issue here,


    MBP17' 2009 upgrade , MBP17' 2012 new install and Imac 27" upgrade , same story. map / nothing else.

    I cant open in finder my whs 2011, as the picture shows parallels with w7 works fine.

    the psf network connection to my osx hd works ok. So i got a work around.


    But please we need a fix.


    Schermafbeelding 2012-07-31 om 10.49.09.png

  • g_pirtle Level 1 Level 1

    A guy in our office has a MacBook Pro that is not bound to AD and uses a local account and he is getting the same errors. All Macs bound to Active Directory do NOT have any issues connecting to smb://serverIP or through the Finder -> Network.

  • g_pirtle Level 1 Level 1

    Additional Info - I found that trying to connect to our 2 host failover clustered storage array (2 ea. Dell NX1950s w/MD3000 storage array) via Go -> Connect to Server and through Finder fails with the same error you guys are experiencing. All my other SMB shares work.

  • huff92653 Level 1 Level 1

    Same here, ML fresh install, bound to AD using Centrify, can reach shares via AFP but not SMB.

  • OrdsWoW Level 1 Level 1

    Update on my previous post 4 up.

    Same MBP17" 2012 now NO issue's, whs 2011 at my holliday adres. Can some1 tell me how to debug this to help myself @ home and you guys.


    Schermafbeelding 2012-07-31 om 20.01.20.png

  • huff92653 Level 1 Level 1



    SMB://HOSTNAME.DOMAIN anything does not work

  • g_pirtle Level 1 Level 1

    smb://hostname.domain brings up a list of available shares for me on most Server 2008 R2 file servers except for 2 servers (shares through Failover Cluster Management). On those two servers, all I get is a "/" through Finder and cannot connect through Go -> Connect to Server.

  • Bernie Case Level 1 Level 1

    I work for a NAS vendor and we've had some customers report this issue to us.  My analysis of it, so far seems to indicate that Mountain Lion is behaving differenty than Snow Leopard and Lion in the total amount of data it will accept from the SMB/CIFS server for the list of SMB shares sent to it from the SMB server.  (nerd speak: I'm pulling this from the MaxDataCount field in a network trace)


    • Snow Leopard accepts 16KB
    • Lion accepts 16KB
    • Mountain Lion accepts 2KB


    When the server tries responding to Mountain Lion with more than 2KB of data, it fails, because Mountain Lion has said "hey, I can only take 2KB of data for the list of shares."  Mountain Lion knows that the server couldn't respond with the shares, so it goes back to the server to get the share list a different way.  It uses an older method to get the share list and it seems like this is not fully supported by every SMB server out there.  In particular, I know that Windows Server 2003 R2 and Samba seem to support this alternate method, but Windows 2008 R2 does not.  So, for the servers that can't respond to 10.8 with the share list at all, 10.8 errors out and you see that error in your Finder when you try to connect.


    My feeling here is that this 2KB limit is a bug in 10.8.  I'm going to open up a bug with Apple via Radar.  Maybe it'll get fixed in 10.8.1.

  • nathan_h Level 1 Level 1

    That's great info.  Sort of.  I mean, the only solution then for someone like me, with all my network drives on a Win7 machine is....  get a different OS on the server, or roll back to Lion, for now. 


    Or is there a way to tell Win7 to send less data?

  • g_pirtle Level 1 Level 1

    So in theory, that is why my servers with only a few shares will show me the list, but my main storage array with 20+ file shares will not connect unless I specify the share.

  • Bernie Case Level 1 Level 1

    nathan_h: Your options are to:

    • reduce the total number of shares you have, or the names of the shares that you have, so that the full list will fit in a 2KB reply from the server to the 10.8 client
    • use a different SMB server like 2003r2 or Samba
    • suspend use of Mountain Lion and use Snow Leopard or Lion until Apple patches Mountain Lion's SMB client.

    g_pirtle: as far as I can tell, you're correct, but I'm going off of packet traces to try to infer just what Mountain Lion's doing here.  That's the one thing that sticks out to me and some of my other colleagues.

  • nathan_h Level 1 Level 1

    Hmm.  I only have three shares, and their names in total are less that 50 characters.  You're saying if I cut it down, that will help?  I'm guessing since each share has tons of folders inside, just changing the top level names won't help me?

  • Bernie Case Level 1 Level 1

    nathan_h: that sounds a bit different than what I've seen in my environment and in my tests.  Your issue sounds somehow different.  More investigation (like, a network trace) would be needed for me to be sure it's the same issue.  There might be cause for you to try to open a case with Apple to get help, or to use the workaround of connecting directly to a share, i.e. smb://server/sharename.  If the workaround doesn't work, then you're definitely seeing a different problem.

  • nathan_h Level 1 Level 1

    okay, i guess i'm seeing something different.  hmmm.   my vmware win7 instance on the same box gets to the shares fine, still, and Lion had no trouble from the Mac OS.  i'm stumped.

Previous 1 2 3 4 5 Next