Previous 1 15 16 17 18 19 Next 644 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. Go to original post Branched to a new discussion.
  • obroni Level 1 (0 points)

    After trying some solutions - sudo, spotlight - I changed yesterday evening to Carbon Copy Cloner. Now I have fast backups again.

    But it is not my "philosophy" of using apple-devices to use foreign apps. (I have a macbook, an iPad, an Iphone - and everything worked very fine and easy.)

  • Tech Harmony Level 1 (0 points)

    Thanks @gvaughan, your tip helped me (see previous page for unloading Spotlight at boot).


    I was able to finish off 20GB of Time Machine backup in less than an hour over network (from Lion to Snow Leopard machine) instead of days.


    I spoke too soon on the "sudo tmdiagnose" Terminal fix I mentioned on the previous page. It DID reduce my estimated backup time from 400+ days to mere hours, but after I had to stop TM and restart it again (other reasons), it was back up to requiring hours and days. Not as bad as before but still way too long for 20GB.


    I used @gvaughan's tip to unload Spotlight at boot and restarted the computer...the backup finished in less than an hour... done and done. But of course, we want Spotlight!


    So after the backup completed, I reloaded Spotlight (I just said "load" instead of "unload" per the linked instructions...again, see previous page for @gvaughan's tip and link) and restarted. I then told Time Machine to run again, it indexed briefly, and seems to be happy. Spotlight was working again too.


    So now I have a complete and functional Time Machine and Spotlight is back in action.


    This was one of the crappier sequence of fixes I've had to do on a Mac -- and I've had to do plenty over the years and machines -- but I'm thrilled to have it working.


    So to recap, I don't know if the "sudo tmdiagnose" Terminal step helped (see previous page for instructions) but the subsequent unloading of Spotlight, reboot, and running Time Machine, allowed me to get it done.


    Thank so much everybody.

  • TStam Level 1 (75 points)

    When ML came out i had issues and reformateed TC. Since, I've never really had issues with the speed of backup with my 2 TB time capsule. Have two machines backing to it and one is fairly large. For first backup,iIt takes 20 hours or so for the 400 gb machine (ethernet) and 8 or so for the 70 gb machine (wireless). What's disturbing for me is the number of times the subsequent backups get delayed even though nothing is changed on my system. I then have to remove and reselect the TC and all is well for a while. Subsequent backups work quickly. I do have spotlight off for all external drives. Multiple machines and hourly backups is what TC is designed for, but too many headaches and it doesn't "just work". This thing should be hands-off easy but is not.


    What prompted me to look at this again is that yesterday my larger sparse bundle would not load and I could not back up any more. Disk utility said it could not repair it and I had to format even though the smaller sparse bundle was fine. So, a quick format and I'm back in business. We did have a power failure and I suspect that's what did it.

  • lauhub Level 1 (0 points)


    Yes this is only a workaround. And it only worked a few hours for me: after a day of work, a new backup and TM is stuck

    The only way I found to make backup fast enough is to de-activate Spotlight before launching TM using the "launchctl unload" command.

  • lauhub Level 1 (0 points)

    Tech Harmony wrote:


    @dolfke's solution worked for me under Lion.

    dolfke wrote:

    How to run tmdiagnose


    1) Launch (/Applications/Utilities/

    2) Enter the command text below followed by the Return key on the Terminal command line:

    sudo tmdiagnose

    3) Enter your admin password when prompted and wait for all of the tmdiagnose processes to finish.

    This did not work for me: I am stuck at 167Ko after half an hour.

  • Schooner57 Level 1 (0 points)

    Confirming:   success with gvaughan's citation from osxdaily (I did a from-scratch bak over ethernet with TM in bridge mode).  No stalls observed, sole backupd error noted in console was "Indexer unavailable" at/near completion..


    So - I'll manually actuate TM backups after disabling spotlight until Apple patches this thing, relying on CrashPlan for routine data/file backups.



  • Tech Harmony Level 1 (0 points)

    @lauhub "sudo tmdiagnose" didn't work for me either in the long-run... what worked was, as you mentioned in your other post: unload Spotlight at boot, reboot, then run TM...let it complete... then reload Spotlight at boot, and reboot.


    I used this link:


    This Terminal command to unload Spotlight at boot:

    sudo launchctl unload -w /System/Library/LaunchDaemons/

    (all on one line)


    [restart; run TM until it completes]


    This Terminal command to reload Sportlight at boot after TM completest:

    sudo launchctl load -w /System/Library/LaunchDaemons/

    (all on one line)


    [restart; try TM again]



    @TStam You're right, after getting Time Machine or Time Capsule going, there's additional shenanigans that can happen


    Quickly I'll suggest the program TimeMachineEditor: it still works under Mountain Lion and lets you schedule your Time Machine backup to happen once or twice a day...Any schedule you'd like. Now TM may still RUN for awhile once it starts, but at least it won't seem like it's going all the time (you must schedule it for a time when your computer (and backup resource) is awake...or use Energy Saver system preference to schedule a computer wake-up)


    I've struggled with 4 different clients' Time Capsules (for the first backup, you should use a highspeed Cat5e or Cat6 cable to back up directly to Time Capsule from your computer, where possible). Occasionally the "Identity of the Backup" will fail and the whole thing will need to be redone. Sometimes I've had Time Machines run constantly, for days, to local USB drives. And sometimes it just works


    Most of my experiences were under Snow Leopard and I had hoped things would be resolved for Lion and Mountain Lion. So thank you for the feedback that there are still shenanigans. Apple would probably recommend making sure your Time Capsule firmware is up to date... and probably erase/format the whole thing and redo it. Sometimes this just isn't practical but sometimes it really does help. YMMV. (I was warned by a genius bar once that the constant rebacking up and reindexing was normal for the first few days... maybe I could accept that better if the sparsebundle didn't go belly up every 3-6 months)


    All-in-all I do like Time Machines (and Mountain Lion's ability to TM to multiple drives) as a theoretically fool-proof backup method for the masses.


    However, I always install a secondary backup on client computers. For a long while I preferred a program called Chronosync (not free) which wakes the computer to backup, verifies the data it copies, and sends you emails if it fails.... but I only used it to back up the User folder and setting it up optimally and scheduling it is not a one-click process. Still, a very well-done program!


    Someone else mentioned Carbon Copy Cloner and this is a fantastic program (used to be free but I don't think any longer). It can also be scheduled, wake your computer, alert you via email, and you can set it to make a bootable clone of your whole computer or clone to a sparsebundle diskimage. Having this kind of backup means you can directly restore the exact state of your computer (at least since last clone) to a functioning drive.


    Finally, some people supplement with an "offsite" backup option like CrashPlan but I haven't tried it yet myself. I don't see the cloudy backups as reliable or secure enough to be a primary backup but I like the idea, especially for fire, lightning, and theft.

  • gvaughan Level 1 (0 points)

    Hi - Good news - My Time Machine backup completed successfully: 990 GB in ten hours. As I mentioned earlier, the command I used was:


    sudo launchctl unload -w /System/Library/LaunchDaemons/

    I found this at:

    Good Luck!



  • TStam Level 1 (75 points)

    All of this is very helpful. Thank you. I do maintain CC Cloner backups in two locations, one updated daily and one weekly, JIC. I just can't trust TM with all these issues. To me it's an enhancment to my backup strategy versus a reliable backup - unfortunate.

  • Laurent Drion Level 1 (25 points)

    I backup an iMac to a disk attached to another Mac in my network, a Mac Mini.

    Since I updated to 10.8.2 I have the same problems reported here: the estimation for my 300 gb backup was 8-9 days, 30x longer than before 10.8.2.


    I tested most of the tricks suggested above but none worked for me.


    Then I read another forum where they say that you can solve the problem by upgrading the OS of the Mac on which you store the time machine backup to OS X Server (€15,99 in the Mac App Store). So I updated the OS of the Mac Mini with the OS X Server App.


    I confirm that since I turned on Time Machine in the Server App I can backup my 300 gb in 2 hours...


    So there is clearly a bug in 10.8.2 's Time Machine but until Apple fixes it you can avoid it by upgrading to 10.8.2 Server.

  • putnik Level 3 (780 points)

    So there is clearly a bug in 10.8.2 's Time Machine but until Apple fixes it you can avoid it by upgrading to 10.8.2 Server.

    Note that going back from the Server installation to the ordinary OS and would require an erase/install.

  • Schooner57 Level 1 (0 points)

    Update to "gvaughan solution worked for me" -


    Time Machine performing brilliantly.  However when I re-enable Spotlight after bak, I now enjoy the following hover message:  "Indexing (Computername) / About 3 months remaining".

  • lauhub Level 1 (0 points)


    So you reached into the Spotlight bug that is currently annoying all of us. I had the same problem with Spotlight.


    Can you follow the steps 1, 2, 3 and 5 below (extracted from there) and let us know if it made it better with indexing time:

    Using Terminal:

    1. I disabled Spotlight indexing:

    sudo launchctl unload -w /System/Library/LaunchDaemons/


    2. I deleted Spotlight index in all my drives (including the backup drives):

    sudo rm -rf /.Spotlight-V100/Store-V1 /.Spotlight-V100/Store-V2  /.Spotlight-V100/VolumeConfiguration.plist


    (rm -rf /.Spotlight-V100/* did not work for me)


    3. I deleted /var/folders content (see this topic to know why):

    sudo rm -rf /var/folders/*


    5. I restarted Spotlight:

    sudo launchctl load -w /System/Library/LaunchDaemons/

    sudo mdutil -i on -E /


    Spotlight should start re-indexing a few seconds after the last command.

  • Schooner57 Level 1 (0 points)

    @lauhub thanks.  Followed your recipe precisely.  Indeed get "Indexing enabled" response from Terminal after final command & indexing resumes moments later.  Spotlight-hover eventually returns an initial ETA of 61 minutes, quite the improvement over prior "3 months".  Will confirm/refute timely completion when done.


    [Do default exclusions for Spotlight include network drives?  Surely this thing isn't crawling all over my idiosyncratic Mac/Win network interrogating Drobos and PCs and Hamachi'd remote PCs?]

  • Tech Harmony Level 1 (0 points)



    Be very careful if you follow the "sudo rm -rf" steps in @lauhub's post above! "sudo rm -rf" is the most powerful deletion command on the Mac so you must input the text perfectly (and sometimes copy/paste doesn't work).


    Usually to remove Spotlight indexes without Terminal, you can go into System Preferences and drag the hard drives (including your Time Machine Backup) to the Privacy list (not sure if that's what it's called on Mt.Lion). This may not be as complete as deleting through Terminal but should remove Spotlight indexes.





    Perhaps also try the "sudo tmdiagnose" Terminal step in addition to unloading/reloading Spotlight.... for me "sudo tmdiagnose" seemed to actually do some cleanup and TM management. Perhaps it unwittingly helped my Spotlight unload/reload go smoothly... I do like the above idea of clearing Spotlight indexes, rebooting, etc.


    It may take hours to reindex a full computer. This typically explains the slow-down after an OS upgrade because Spotlight seems to reindex everything at that point... so it's sort of "normal" ... I wouldn't trust the estimates but give it a day if you've got a huge drive.

Previous 1 15 16 17 18 19 Next