Previous 1 19 20 21 22 23 Next 644 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. Go to original post Branched to a new discussion.
  • FelikZ Level 1 Level 1 (0 points)

    Solution by TizianoT (see reply) completly works on 10.7.5!

  • oler Level 1 Level 1 (0 points)

    I was backing up my iMac mid 2012 to a mac mini mid 2011 both running 10.8.2 and the mini running server. It took about 1 hour per gig. I went into system prefs and switched from DHCP to DHCP with manual address and now its 1 minute per gig, on gigabit ethernet. Go figure.

  • gitarzysta Level 1 Level 1 (0 points)

    I think I started to have problems with 10.8.2 suplemental update. I wiped the Time Capsule disk out and started from the scratch. But the initial backup took ages (and never finished), so....


    I can confirm that switching to manual TCP/IP configuration (or DHCP with manual IP address) solved the issue!




    (10.8.2 with suplemental update, 2008 iMac, Time Capsule)

  • LegalGeek Level 1 Level 1 (0 points)

    Tech Harmony's very thorough explanation of how to backup without Spotlight did not work for me. I followed all the steps to the letter and even had tried a few things that he did not mention. Here is what I have done so far (not necessarily in order):


    1. Verified/Repaired Permissions on boot drive.

    2. Verified/Repaired boot drive (booting into Mountain Lion Recovery Mode).

    3. Erased my drive completely and restored only data and applications from backup (no settings).

    4. Removed anti-virus.

    5. Removed Crash Plan (which I use as a supplementary off-site backup).

    6. Deleted all files in /.fseventsd.

    7. Deleted the entire Time Machine backup from the network drive (multiple times).

    8. Tried tmdiagnose (multiple times).

    9. Unloaded Spotlight.

    10. Rebuilt Spotlight index (multiple times)


    None of these things has worked for me. Here is my config:


    Source Machine - MacBook Pro Retina 15" using Thunderbolt Ethernet (WiFi turned off). 10.8.2 with supplemental update.


    Desination TM - 2011 Mac MIni Server with Drobo S (2nd Gen) attached via FW800. Running 10.8.2 Server with supplemental update and running Time Machine server.


    Every time I run it, TM runs fine for a while and then gets hung up. This is the case even after a fresh rebuild of Spotlight index and erasing the existing TM backup. Best case scenario, it would back up about 200GB of about 650GB and then freeze. Worst case, it would back up only 20GB and then stop. Subsequent backups would also freeze after a period of time. When I say freeze, I mean that neither the number of files nor the size of files changes, after hours go by and even when left overnight.


    Right now, I am trying @gitarzysta's suggestion of setting a manual IP address. I am setting manual IP address with DHCP on BOTH the Source Machine and on the Destination TM box. It seems to be running better, but is still in the process. If it completes the current backup, my next step will be to re-enable Spotlight, erase the TM backup again, and try from scratch to see if my machine (restored to normal configuration) will still work.

  • cfsdoriga Level 1 Level 1 (0 points)

    Hey LegalGeek,


    Lets us know if its work.


    I got in contact with crash plan because my back up in an external drive using CP was also pattently slow as Time Machine. They're trying to find out what's going on.


    I'll keep you post it.

  • Tech Harmony Level 1 Level 1 (0 points)

    Wow LegalGeek, EPIC!


    Short of Time Capsule, it sounds like you had many combinations of variable: antivirus, crashplan, 10.8.2 server, ethernet, Firewire 800, and a Drobo hahah WOW.


    So let me get some clarity on a few things.


    1) You are attempting to run backups while Spotlight is completely unloaded from your system, right? And it still choked during the Time Machine backup!? Wow. So maybe I was wrong about this being a mainly/mostly/only Spotlight issue   One thing though: did you unload Spotlight on both the sending and receiving computers? They are both running the busted 10.8.2 OS after all and they will both be throwing their Spotlights at any sent/received data the whole time it is running....


    2) I think deleting the Spotlight indexes will only really help when you have reloaded it during boot. Otherwise, all that rebuild time will really tax your systems if you're also trying to back up. But I think you got that.


    3)  I confess I like this manual DHCP idea. In the past I've left the IP address alone and changed the Advanced --> Ethernet tab from "Configure: Automatically" to "Manually: 1000baseT" which sometimes helped my transfer speeds in general. So this manual IP business is an interesting wrinkle.


    Here's the interesting thing that comes to mind: when I've built my own Macs in the past, the critical networking extension "IONetworkingFamily.kext" also impacts the functionality of Time Machine... only it really wouldn't work at all if you didn't have the right extension. Perhaps Apple screwed it up in 10.8.2. An adventurous person might take the IONetworkingFamily.kext from a 10.8.1 machine (or older) and inject it into a 10.8.2 system....This is, of course, a relativley easy but non-trivial thing to do ... it won't brick a system but one could be up a creek with no ethernet if they don't know how to work with or restore kexts.


    4) Speaking of 10.8.1, did you say you reformatted your main computer and restored only data and applications from backup (you must have had another backup)? If you did this, why not just have updated your OS to 10.8.1? I think things were still working under 10.8.1.... Just a thought Too late now really.


    5) If the Time Machine completes, you're going to erase TM again and try under "normal configuration."? What do you mean? Like try TMing with the DHCP fix alone but Spotlight loaded? Seems to me that once you get a functional Time Machine, you would just want to reload Spotlight, let it index, then try seeing if future TM backups run reasonably... then turn on DHCP automatic again...and see if TM continues to run reasonably. For many (some?) people, once they got the initial Time Machine completed, it worked alright after that...

  • LegalGeek Level 1 Level 1 (0 points)

    Okay, it failed again anyway. Froze up once again with no further activity in dialog, system preferences, network, drive, and CPU. I don't know what else to try at this point.


    1. Yes, I tried it with it unloaded from my system using the "sudo launchctl unload -w /System/Library/LaunchDaemons/" command. I did not unload it on my Mac Mini. Just my MacBook Pro. I will try that next, I guess. Technically, only the source computer should be indexing the backup, if it is running to specs.


    2. Yes. I believe that indexing has been completed each time I try a backup. I do not even start the backup until the Spotlight window says that it is complete.


    3. Apparently, the manual IP didn't work.


    4. I can't install 10.8.1 because Apple doesn't give you that option when you install the OS using the recovery partition. It always downloads and installs the latest build.


    5. I only try to change one variable at a time so that I can isolate the problem. Once I believe that I have isolated the problem, I was going to erase the backup and try again from scratch. If it works all the way through, then I know I've found the problem. I understand that if I get a complete backup again, I can re-enable Spotlight and continue on, but the only real test is if I can do a complete backup from start to finish without interruption.


    So, now I'll try with no Spotlight on both the client and the server.

  • Tech Harmony Level 1 Level 1 (0 points)

    I like your style LegalGeek, very thorough.


    Yes, I like the idea of disabling/unloading Spotlight on both sending and receiving machine, restarting both, and then running the TM backup as "normal" ...


    [I am assuming that things are not "running to specs" else we would not be 20 pages into a discussion board about this lol. Maybe Spotlight is acting really greedy ... but I agree, it seems like a longshot... still "sudo tmdiagnose" on both machines while you're at it]


    I would also do the "select no TM backup disk"/"reselect TM backup disk" trick... including unmounting the network share and remounting it... just to be thorough.


    Out of curiousity, when you just copy a 10-50GB file over File Sharing, does it copy pretty fast to the Server's Firewire Drobo? It should be fine/fast but hey, it will help narrow variables if for some reason just a straight-up Finder copy is slow. Then we know something else is afoot.




    If I can extract a 10.8.1 "IONetworkingFamily.kext" from a client computer, let me know if you are interested in trying it out... I'm not sure I want to get into the details here, mostly because I don't want anyone to screw up their computer and blame me. It's not a major operation but, like anything, can be borked if fat-fingered. Most that would happen is your internet would go down though...and that can be fixed by restoring the extension... Anyway, just depends on what kind of IT mood you're in

  • BertlHeinz Level 1 Level 1 (0 points)

    This seems to be a bug that needs fixing by apple. No one in the community seems to have a clue how to overcome the trouble of endless backups with mountain lion. Hope that this will be solved as usual with one of the following bugfixes.

  • David Schwab Level 1 Level 1 (110 points)

    LegalGeek wrote:


    4. I can't install 10.8.1 because Apple doesn't give you that option when you install the OS using the recovery partition. It always downloads and installs the latest build.


    10.8.2 doesn't seem to be the problem on my end, because it was working fine after that update. Then it just stopped working one day.


    In my case it's also not anything to do with networking, because I'm backing up to a USB 2 drive. Carbon Copy Cloner backs upmuch faster to the same drive.

  • Tech Harmony Level 1 Level 1 (0 points)

    10.8.1 and 10.7.4 were working fine for everyone. 10.8.2 and 10.7.5 seem to universally hit a snag...probably not coincidence. Although for people who already had a completed Time Machine under 10.8.1, they may not have had a problem under 10.8.2 because no new Time Machine/Spotlight data would be involved. Maybe after a few days or a week, as changes were made on the machine or Spotlight rebuilt itself, the problem manifested.


    I can't tell for sure but 10.8.2 may have rolled out on October 5th....


    You're right to point out that the problem isn't direclty related to networking as many people have problems with local backups (and success with Spotlight disabling workarounds). In fact, you mentioned that it took your Carbon Copy Cloner about 21 hours to copy about 550GB. This is very very slow. My Snow Leopard would take under 6 hours to clone the same amount.


    However, Time Machine itself is historically tied to a buried System extension (driver) called "IONetworkingFamily.kext" which is, essentially, the networking system. When some users thought they had success in modifying their networking settings, it led me to consider that the Time Machine problem could also be a problem with this extension.


    It's counterintuitive, I know But for some reason Time Machine has been tied into the networking extension/driver under prior Apple OSes and it's likely to be connected to the current one. If the Spotlight fixes aren't working for all Mountain Lion users, we're forced to consider these other conditions....

  • RockTheGlobe Level 1 Level 1 (0 points)

    I also seem to be having a problem with the Supplemental Update.  As soon as I installed it, Time Machine began running glacially slow to the point where even when I left my mid-2010 MBP running overnight, it still couldn't finish a 7GB backup -- and when I tried to stop the backup, TM crashed and I had to reboot.  I was in the middle of another backup that had seemingly hung when I ran across this thread, so I switched my network settings to DHCP with manual IP, and that seemed to get the Time Machine backup going again at a pretty decent clip.  But there needs to be another patch for this, I haul my machine to and from work so I can't keep putting in IP addresses manually.  Whatever happened to "it just works"?

  • David Schwab Level 1 Level 1 (110 points)

    It makes sense it had something to do with 10.8.2, since it broke in 10.8.2. But it was fine for a while. Coincedentally, the day TM broke, I also couldn't open several applications becaue the permissions were messed up. Right after I fixed them (booted to the recovery partition and used DU), it stopped working.

  • Julius Cheng Level 1 Level 1 (0 points)

    This is odd to me, as I always had pre-assigned IP addresses in DHCP for my Air and my network storage... and it's only lately that TM had sped up (though not 1G/min).  The only thing that worked for me was to shut off the automatic TM backup and do each manually.

  • gitarzysta Level 1 Level 1 (0 points)

    Please remember there was a supplemental update to 10.8.2 that did not change the version number. It was like a week ago or so. And I noticed slowdowns of incremental backups (to a point where they would time out) around the same time I installed this supplemental patch:


    In my case assigning static IP helped immediately, but yes there may be other scenarios that require different approach. I already submitted a bug report to Apple and suggest all do the same.

Previous 1 19 20 21 22 23 Next