1 25 26 27 28 29 Previous Next 650 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. Go to original post Branched to a new discussion.
  • 390. Re: time machine very slow with mountain lion
    Kirs Level 1 Level 1 (0 points)

    Same issue here.  10.8.2, late 2011 MacBook Air using and external USB drive.  Backup was always reasonably fast but now it's taking 30 mins to back up only kilobytes.  I don't understand what went wrong.  Checked the USB drive in diskutil, no problems.

  • 391. Re: time machine very slow with mountain lion
    elusivenapkin Level 1 Level 1 (0 points)

    I have been having the same issue when using a 2 TB Raid 5 setup connected directly to my computer via FW800. I just migrated to a new imac, and this was the first backup. Overnight it only accomplished 3.5 GB of 145 GB. In the beginning it was estimating 6 hours to complete the backup. It currently shows 16 days remainined to complete.

     

    I know there must be something wrong here. I really don't want to go down the road of doing a fresh install. Especially since I don't have any backups of my data as of yet.

  • 392. Re: time machine very slow with mountain lion
    minebob Level 1 Level 1 (0 points)

    Just to pile on, my 2012 Air is backing up VERY VERY slowly with a class 10 microSDXC card and Time Machine, but I can copy files to the card in Finder at about 10mb/s as it should be.

  • 393. Re: time machine very slow with mountain lion
    DriftlessOrganics Level 1 Level 1 (0 points)

    OK - 27 pages of posts and so many suggested answers, but has anyone been successful in fixing this? I've read through this entire thread and more confused than ever.

     

    Here's my deal:

     

    ML 10.8.2 on 2011 MBP

    Using a 1TB WD "My Passport" external hard drive

    Haven't been able to back up to TM in over a month - I'm at 18.8 MB of 12.75 GB

     

    Somebody please help!

  • 394. Re: time machine very slow with mountain lion
    LegalGeek Level 1 Level 1 (0 points)

    Hi, DO. I tried every solution in this thread and others posted elsewhere. The only solution for me was given to me by AppleCare. I worked with them over a period of several weeks.

     

    I'll warn you... it is painful. But it was the only way to clear everything out and eliminate all other variables.

     

    I have now installed all software that I need on a daily basis. There are others that I may have had installed, but use only occasionally and so did not install them yet. But I have completed many backups very quickly with no more hangups.

     

    Here is a repost of what I did that worked for me. I continue to have successful backups every night since...

     

    Disclaimer: I am not responsible for lost data. This is simply a good faith effort to try to help others fix their Time Machine problems. This is also pretty much the last resort. If you have tried every other suggestion here and it didn't work, this is the suggestion that I got straight from AppleCare. I worked with them over a period of weeks sending them log and system files.

     

    Here is a list of steps that anyone should be able to use to try to fix the TM problem in Mountain Lion 10.8.2. If anything is not clear or you have suggestions for improvement, let me know and I will update the instructions.

     

    1. Make sure to Deactivate any licesnses of software that you may have. Some software only lets you activate so many times and you have to deactivate them first. I had to deactivate Adobe Creative Suite CS6 and iTunes.
    2. Backup your data using some other method. You can do this by using some other backup software or by simply copying your Home folder (or Users folder if you have more than one user) to another drive. I can't stress this enough... make sure that you have a good backup of your Home or Users folder before you move forward. If you don't, you will lose data. Forget what I said about using TM and manual restore. It's not necessary to do it that way. It's just the way I found most convenient for me. Just use whatever way you feel comfortable with to backup your data files.
    3. Start your machine and hold down Option right after the "bong". Select to boot into the Recovery Partition of your drive.
    4. In Recovery mode, select Disk Utility. Select the Partition for your Mac OS (no need to do this to any other partitions). Erase the partition. NOTE: THIS WILL DELETE ALL DATA ON YOUR DRIVE. MAKE SURE YOU HAVE A GOOD BACKUP OF YOUR DATA BEFORE YOU DO THIS.
    5. Exit out of Disk Utility. Select to install Mac OS X. Make sure there are no devices connected to your machine other than mouse and keyboard. No external drives, no printers, no external speakers, etc. Go through the normal installation procedure.
    6. When you create a new user account, use the same name(s) as the user(s) you had on your machine before.
    7. Do NOT install any apps or drivers; or copy any data yet. Go to App Store and install all OS X updates. This will likely require at least one reboot.
    8. Install iPhoto, iMovie, and Garage Band if you have them. Install all updates from the App Store.
    9. Connect your Time Machine drive (whether on the network or local). On your Time Machine drive, you will see a file called something like "Jonathan's Mac Book Pro.sparsebundle". It will be the name of your machine with ".sparsebundle" at the end. You will need to delete this file in order to do a clean backup from scratch. The bad news is that this will delete all of your previous Time Machine Backups. EMPHASIS: THIS WILL DELETE ALL OF YOUR PREVIOUS TIME MACHINE BACKUPS. But, if you want to eliminate variables, this is a requirement.
    10. Set up Time Machine and perform a backup. If it won't back up your machine, then there is either a problem with your setup or hardware somewhere or this is an Apple OS X problem. The purpose of doing it this way is to eliminate the possibility that any third party software could be interfering with the TM backup. This worked for me. I was able to backup my machine for the first time since installing 10.8.2. My advice is to call AppleCare at that point or post back here and we can try to help further.
    11. Assuming the backup works now, as it did with my machine, copy all of your data from your backup back into your Home folders. I just took each folder (Music, Movies, Documents, etc.), opened each one, and copied the data from the backup to the home folder on my machine.
    12. Now try steps #9 and #10 again. It is important to delete the .sparesebundle each time in order to make sure that your machine can do a complete system backup from scratch. If you don't delete the .sparsebundle, it will only backup the changes (called an incremental backup). An incremental backup is not a good test of your backup strategy because you need to be sure it can backup your machine end-to-end, start-to-finish first.
    13. Again assuming that the backup worked, as it did with my machine, you can start installing your apps again. I have installed a few apps each day as I've needed/wanted them. Then, I go through steps #9 and #10 again at night. It's only a minor inconvenience because the backup works while I'm asleep. Keep track of which applications you install each day to help you figure out the culprit.

     

    If you follow these steps, it will help you narrow down the problem. Or, it may even eliminate the problem.

     

    One theory is that some third-party application or driver is causing TM to fail. In that case, you will one day run into the problem again. Backups will fail and you can review your list to see which apps you installed since your last backup. Delete each app one by one and try to figure out which app is stopping the backups. Then, you can contact that software vendor and work with them.

     

    Another theory is that there was some leftover cruft somewhere on the machine that was causing TM to fail. In this case, you will be able to install all of your apps again, and it will successfully backup your drive every time.

     

    It does not appear to be a hardware problem... at least not for me. If it were hardware-related, I would not have been able to get past step #10. Still, I would not discount the possibility that it is a software problem. Perhaps something in the 10.8.2 update causes a file somewhere to become corrupted or something. However, this appears to be fixed by following the steps above.

     

    I have been able to successfully follow steps 9 and 10 four days in a row now. I have done end-to-end backups 4 times. Last night's backup was 502.25GB and was completed in 6 hours and 20 minutes over gigabit Ethernet. This is the first time since the release of 10.8.2 that I have been able to use TM.

     

    My setup:

     

    MacBook Pro Retina with Thunderbolt to gigabit Ethernet adapter.

    Backing up over the network to a Mac Mini Server with a Drobo S connected over Firewire 800.

    Both machines are running 10.8.2.

  • 395. Re: time machine very slow with mountain lion
    DriftlessOrganics Level 1 Level 1 (0 points)

    Thanks LegalGeek! While I do not doubt that this would work, I am not sure I have the gumption to go through with the process you have outlined. I think for now I will go with backing up on Carbonite (already have an account with them with a few of our office computer's signed up) and hope that Apple will come up with a solution some time in the near future. Is there any wisdom to this?

  • 396. Re: time machine very slow with mountain lion
    LegalGeek Level 1 Level 1 (0 points)

    Believe me, I felt the same way, but Apple was pretty adamant that it was not their problem to fix. They blame it on 3rd Party software or drivers. They said that something was slowing/stopping TM from backing up correctly. After I did a clean install of OSX without any software or drivers, it worked right away.

     

    I hate to say it, but Apple may be right that there was some other software on my system that was causing the problem.

  • 397. Re: time machine very slow with mountain lion
    minebob Level 1 Level 1 (0 points)

    With all due respect to Apple, if Time Machine is being affected by software from 3rd parties so often that a thread is this big about the problem then there is something wrong on their side. I literally killed every process that I could without crashing my system from the command line and TM was still slow, even with a brand new SD class 10 card and formatted partition. Basically, they need to investigate this rather than sitting on their laurels and saying it is user error. This is very poor customer service to say it's our fault and I'm getting quite irritated.

     

    Edit: In addition, I can copy all 20GB of files directly to my SD card in less than an hour (at 10MB/s for a class 10 SDXC card that would normally take 34 minutes, so I expect an hour is about right based on having, it seems, 600,000 files), so where's that mysterious program that makes it fail with TM? It's Apple's fault and they're too lazy to fix it.

  • 398. Re: time machine very slow with mountain lion
    Julius Cheng Level 1 Level 1 (0 points)

    I'd also like to point out that my issues started after the upgrade from Snow Leopard to Mountain Lion.  I've added no other third-party software since then, and it took me a month to get things straight - mostly by wiping my old backup and starting over with manual backups first (i.e. turning off Time Machine's automatic backup).

     

    Unfortunately, I still have issues with some WiFi setups under Mountain Lion, so I'm wondering if that's part of the problem (e.g. dropped packets).

  • 399. Re: time machine very slow with mountain lion
    Tech Harmony Level 1 Level 1 (0 points)

    LegalGeek's steps have been the best so far.

     

    Although I do feel like some people have had success with backup drive reformats and fiddling with Spotlight.

     

    Apple obviously changed something with 10.7.5 and 10.8.2 that created/revealed this disaster, however you want to slice it They fixed it with the 10.7.5 supplemental update (note no excuses from them there that it was a third-party problem) but they haven't been able (or cared) to fix it with 10.8.2.

     

    I did a silly thing and, knowing everything from this thread, updated my GF's brand new MBP from 10.8 to 10.8.2, installed a bunch of apps, and ran Time Machine to back up her 200GB to a local USB-connected drive before I finally realized what I had done. Noooooooooo. The back up said it was going to take 5 hours, which sounded long, but when it started choking after a pause/resume (think it said 1000 days at one point) I would have been grateful for the 5 hours!

     

    I didn't have time to extensively try a technique of swapping out the IONetworkingFamily.kext (which TM historically relies on) from an old Mt. Lion install but I did try it and it seemed to get things back down to 5 hours. But that's not realistic for others, wasn't scientific enough to explain now, and I restored the original kext driver.

     

    But I DID do a few things that may have helped and that would be doable for others, but you must be very careful:

     

    1) First back up your computer some other way... Carbon Copy Cloner has a full 30-day trial so you can use that but just pay attention to your settings so you don't inadvertently wipe out your target/destination drive (unless you want to)... I like to use CCC to back up to a new sparsebundle disk image on a backup drive.

     

    If you have room on your existing backup drive for a full clone and a full Time Machine, you can use the same backup drive; otherwise choose another location for your clone.

     

    2) Doublecheck your backup

     

    3) Delete your current partial/busted Time Machine from your backup drive... Might be called backups.backupd if on a local drive or "drivename.sparsebundle" if on a network drive.... empty the trash

     

    4) I went into my System Preferences and turned TM off for the moment... if you know how, you can tell it not to back up to any drive for now...although I didn't easily see that in Mt. Lion.

     

    5) I went into System Preferences for Spotlight and added the TM drive to the Privacy/exclusions list... now if your drive is on the network, I bet you could mount the drive on the network and add the mounted drive to the Privacy list... Honestly, for the sake of thoroughness, add the TM drive to the Privacy lists of any computer involved in your backup process (source and destination).

     

    6) Here's the "dangerous" step because it involves a powerful Terminal command to nuke Spotlight on the backup drive. Long as you type it correctly, you'll be fine   So fire up Terminal on the backup drive's computer (I use Spotlight to launch it but it is just in your Applications --> Utilities folder) ...

     

    WAIT, did you see what I said: Launch Terminal on whichever computer that has the backup drive attached to it...forget mucking with this over the network (although doable).

     

    OKay, firstly

    type this innocuous command to get to the right drive:

    cd /Volumes/<NameOfYourBackupDrive>

     

    (I just type cd /Volumes/ and then the first few letters of the backup drive, then I press the "tab" key and it will fill in the whole drive name for you...then press return.. if it doesn't, you've mispelled it or you have multiple drives beginning with the same letters...type more letters...check your caps lock... this stuff is case sensitive)

    press return to have Terminal go to the backup volume....

     

    Okay, so the resulting prompt should give you a sense of where you are...

    you can type the following to see what's in the directory...totally safe:

    ls -al

     

    (that is "el ess dash a el")

    press return

     

    You should see ".Spotlight-V100" in the list

     

    CRITICAL STEP, CAREFUL NOW:

    So to delete that you type, very carefully:

    sudo rm -R .Spotlight-V100/

     

    you see that dot in front of Spotlight?! yeah, there's a dot...otherwise it won't find that file at all (it's hidden)

     

    Press return...It will ask for your computer password.... for me it took a long time to delete! Which made me think, wow, there must be a lot of crap in that Spotlight directory already!

     

    7) Alright! Almost done... Now just get back on the original computer you are trying to back up and you're going to restart into Recovery mode so you can run a basic Repair Permissions.... To get into Recovery mode you restart the computer and then hold down the "option" button after you hear the *bong* ... I think I read that you can get there by holding "command and R" at the same time after the *bong* but I haven't tried that.

     

    Anyway, get into Recovery... it will take a few minutes to boot up... then use the menu/Utilities whatever to fire up Disk Utility... highlight your main computer drive (or the indented line right beneath it) and hit "Repair Permissions" down below... this is totally innocent/great ... Don't Verify...waste of time... and Repair Disk can be a bit more aggressive so it's not necessary... just Repair Disk Permissions.

     

    Phew.... after that...quit out and restart the computer.

     

    8) Alright... set up a new Time Machine to the drive we cleaned up earlier and see what happens! For me 200GB still said it was going to take 5 hours but that was going to be better than days.... AND it was 650,000 items so that can matter more than the total size... lots of little bits and bytes

  • 400. Re: time machine very slow with mountain lion
    DanHambone Level 1 Level 1 (0 points)

    Hi Folks,

     

    I had the same problem after upgrading from Snow Leopard a couple of days ago.  Prior to doing the Mountain Lion upgrade, I did a backup, and all was 'normal' with regard to transfer speed.  Post-upgrade, it was unbelievably slow to the point that I discovered this thread in a search for the solution.

     

    From reading how some folks solved the problem (i.e. reformatting and re-installing), it seemed to me that the disk might be highly fragmented.  My laptop is almost 3 years old so it was probably not in the greatest shape with regard to disk fragmentation.  I suspect that the Mountain Lion upgrade didn't help.

     

    I downloaded the free trial version of iDefrag, and it showed a lot of fragmentation.  So I went out on a limb,bought it, and ran it.  After running a 'Full Defrag' (option 5), I ran my time capsule backup, and it started out very slowly for the first 50MB or so.  I began thinking that I had just wasted 30 some dollars, but then it started to pick up and is now humming along at about 5MB/s (wired Ethernet).

     

    Hope this helps!

  • 401. Re: time machine very slow with mountain lion
    Pat_C Level 1 Level 1 (0 points)

    Hi Tech Harmony

     

    I am sorry but your statement with regard to fixing the issue with 10.7.5 supplement is not correct.  My troubles started after upgrading to 10.7.5 and the supplement did not fix the problem.  What did was turning off spotlight.  Unfortunately I was stupid enough to presume that Apple would have fixed the problem with 10.8.2 so upgraded - not only was the problem still there, the spotlight fix didn't work anymore!

     

    Apple's claim of a 3rd party problem might be true but it is a problem that they have introduced - I have not added any drivers or software prior to the 10.7.5 upgrade so there changes 'broke' a working system.  It is shameful that given the length of this thread and several others Apple seem to be just ignoring the issue.  I regret being persuaded to move to a Mac from a PC earlier in the year as there support is so poor.

     

    Pat

  • 402. Re: time machine very slow with mountain lion
    David Schwab Level 1 Level 1 (110 points)

    DanHambone wrote:

     

    From reading how some folks solved the problem (i.e. reformatting and re-installing), it seemed to me that the disk might be highly fragmented.  My laptop is almost 3 years old so it was probably not in the greatest shape with regard to disk fragmentation.  I suspect that the Mountain Lion upgrade didn't help.

     

    I downloaded the free trial version of iDefrag, and it showed a lot of fragmentation.  So I went out on a limb,bought it, and ran it.  After running a 'Full Defrag' (option 5), I ran my time capsule backup, and it started out very slowly for the first 50MB or so.  I began thinking that I had just wasted 30 some dollars, but then it started to pick up and is now humming along at about 5MB/s (wired Ethernet).

     

    Hope this helps!

     

    It's not because of fragmentation, because I had been using iDefrag prior to this problem starting. So my hard drive was not fragmented. Also, all TM was doing at that point was incremental backups, not a full backup. Apple knows it's their fault because they released an update to fix TM problems for 10.7.5. Maybe a fix is part of 10.8.3 (which was sent to beta testers this week).

     

    Also reports that it's from third party software or drivers is nonsense, since even after the system update, TM was working fine on my machine. Nothing new was installed, and then it stopped working.

     

    I also did a full clean reinstall, and that did not fix anything.

     

    Meanwhile Carbon Copy Cloner has been doing backups very quickly.

  • 403. Re: time machine very slow with mountain lion
    LegalGeek Level 1 Level 1 (0 points)

    I agree that the problem is not because of fragmentation. I have an SSD drive only, which doesn't suffer from fragmentation problems.

     

    Being a software developer myself for decades, I believe that it is plausible that third-party software could be the problem. For me, the problem began when I upgraded to 10.8.2. I can recall many times when I had issue even with Windows that were caused by third-party software.

     

    @David Schwab, could you clarify whether you tried a full clean reinstall and then tried to do a backup without installing any software first? If you can't backup even on a clean install with no third-party apps or drivers, you need to call Apple and open a case.

     

    I agree that it is an easy out for Apple to blame other companies. I have seen it countless times when one company blames others for the system problems. However, I cannot be upset at Apple because in this case, at least for me, it turns out to be a valid possibility. When I did a clean install with no third-party apps or drivers, TM worked.

     

    That said, it does no one any good to bicker or moan about who is to blame. A lot of what has been posted here (even by me) is speculation and guesswork. Apple may very well have introduced a bug in 10.8.x that is bringing the problem to light, but in my view it is just as likely that a third-party software just doesn't play well with 10.8.x. If anyone believes that OS X is the issue, then that person needs to open a case with AppleCare and begin working with them on the problem. In my experience, if enough people report a problem, it will increase the attention it gets, and a solution will follow. Simply posting here, in a place where Apple may or may not see it--in a place where the RIGHT person at Apple may or may not see it--is not enough.

     

    I literally worked with AppleCare for weeks on the issue before we arrived at the solution I posted earlier. We tried everything including uninstalling numerous apps. Nothing worked for me until I did a complete reinstall with no apps. Fortunately, my backups have continued to work, but I have not installed all of the same apps and drivers that I had on my machine before.

     

    What I can tell everyone here with absolute certainty is that troubleshooting a problem like this requires a methodical approach. You have to eliminate variables. The only way to eliminate all other variables other than Apple is to follow my steps. If it still doesn't work with a clean install and no third-party apps or drivers, then it is either a problem with OS X or a hardware problem. Either way, it would then need to be addressed with AppleCare at that point.

     

    Hope this helps.

  • 404. Re: time machine very slow with mountain lion
    David Schwab Level 1 Level 1 (110 points)

    @ LegalGeek. Yes, I tried that. It wasn't working, so I restored from a backup I had made with Carbon Copy Cloner. I have to actually use my Mac, so not having software and drivers installed doesn't help me. I had already waisted almost an entire week on the problem. That was a last ditch effort. I also REALLY doubt the issue is caused by 3rd party software. If it is, Apple needs to get things a little more compatible. Safari is the same **** way, it wont display some sites that other browsers using WebKit do. But that's another story.

     

    I have since switched to using CCC instead of TM, since I had gone almost 4 days without an incremental backup. I did report the problem to Apple, twice, but at this point I'm not going back to TM any time soon, since it would be too much of a hassle.

     

    The fact that CCC effortlessly and quickly backs up the same hard drive and to the same backup drive points at an issue on Apple's end. Clearly it doesn't have an issue with whatever I might have installed.

1 25 26 27 28 29 Previous Next