Previous 1 33 34 35 36 37 Next 644 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. Go to original post Branched to a new discussion.
  • stefanoaz Level 1 Level 1 (0 points)

    Using 'sudo tmdiagnose' solved my Time Machine slowness issue in OS 10.8.2 using a USB3 external drive. After rebooting, encrypted backup of 520 GB went from two weeks to six hours. PROBLEM SOLVED!

  • David Schwab Level 1 Level 1 (110 points)

    That doesn't solve it for everyone. I tried that while I was on the phone with an engineer from Apple, but he said that wasn't expected to fix anything. It was just to gather info.


    Apple knows this is a problem and they are loooking into it.

  • Nikhil-gupta Level 1 Level 1 (0 points)

    I am facing the same issue. Earlier backups were fine but now speed is something likr=e 1 kB per minute. I am using USB2 hard disk for backup.

  • GuruTracy Level 1 Level 1 (0 points)

    I too had the same issue and I had too much data to risk off to the Genius Bar I went.


    What we did was set up a test user (made a new user account) and ran the TM B/U on it, it went just fine...everything backed up.


    Then I went back to my user and did it again...worked great.


    Apple has no idea what could be causing this, but until they figure it out you could try this, especially if, like me you gotta back up!

  • atd777 Level 1 Level 1 (0 points)

    hi, I was having this issue after installing my SSD and HDD in a macbook pro.


    I excluded the SDD in TM the HDD backed up at normal speed. Problem must be with SSD then. I assumed it was taking a long time because all the files looked different even though I duplicated my old HDD, must be a change in permissions/owner I thought. Maybe the clone software (superduper) is changing/adding something...


    I reset the permissions using these commands:


    reboot and hold command and S on startup, then type


    mount -uw /

    chown root /

    chmod 1775 /



    computer starts.


    opened TM included SSD, started TM and now all OK.  Backup speed OK. 13.2GB of 64GB so far as I write this.


    Not sure if this is the solution or just a coincidence, but it worked for me.


    Good luck & Kr

  • afroman7600 Level 1 Level 1 (0 points)

    Earlier backups were fine for me, but is now predicting 3 days and counting, for 138.47 GB after starting over with a clean time machine drive.

  • robbieturner Level 1 Level 1 (0 points)

    SOLVED MY ISSUE: There appears to be quite a lot of issues here and specualtion on potential causes but I found a resolution to my TimeMachine problem on my Retina MPP. I was having a problem with my TimeCapsule/TimeMachine backups (slow to respond, "preparing", disk utility would stop responding when trying to view the drive, etc...). While trying to perform another backup with other software I noticed my computer took quite some time to copy a log file from the program Little Snitch. I recalled installing LS quite a long time ago but thought it had been uninstalled. Once I removed the program I went back to TimeMachine and it was plugging away. I went into Disk Utility and the drive was already there. It appears Little Snitch was the culprit for me!

  • benjamin.liang Level 1 Level 1 (0 points)

    I have the same problem. I run ML on my macbookpro with 512G SSD. TM is connect to firewire 800 disk array.


    so long story short, when you start TM backup, try to disable your wireless network. and you activity monitor can show you that the disk IO will increase to 35-60MB/s...


    It is a bug but here is a work around.


    Good luck,



  • ragges Level 1 Level 1 (0 points)

    In my case, it was backupd being throttled way to much.


    You can check it yourself with (as root):

      fs_usage  $(pgrep backupd)


    If there are a lot of THROTTLED, you may have a problem.


    I got it up to speed by disabling file system throttling (as root):

      sysctl -w debug.lowpri_legacy_throttle_window_msecs=0

      sysctl -w debug.lowpri_throttle_window_msecs=0

      sysctl -w debug.lowpri_legacy_throttle_max_iosize=524288000

      sysctl -w debug.lowpri_throttle_max_iosize=131072000


    Other tasks on your machine could possibly suffer, but I haven't noticed anything.


    To reset the values, do:

      sysctl -w debug.lowpri_legacy_throttle_window_msecs=200

      sysctl -w debug.lowpri_throttle_window_msecs=500

      sysctl -w debug.lowpri_legacy_throttle_max_iosize=524288

      sysctl -w debug.lowpri_throttle_max_iosize=131072

    Or you could just reboot to get them back.

  • pipof Level 1 Level 1 (0 points)

    In my case, stopping spotlight didn't help (neither formatting, nor dumping a first disk ti a second with dd), but after quitting DropBox, a full babkup could be done, without changing anything else! For the first time since january 18.


    Things began to fail, for me, when I decided to add a second disk for TM.


    USB2 disk, freshly formated, ML on a mid-2010 MacBook Pro.


    Hope this help someone...



  • izzy2000 Level 1 Level 1 (0 points)

    I had no problem with a 5 year old Macbook Pro on a 500GB Time Capsule.  However, when I migrated the contents to a 2.3ghz mini, TC refused to play ball so I wiped the contents and started from scratch - estimated time - 40 days...


    Tried Terminal & 'sudo tmdiagnose' - still 40 days.


    Then rebooted Mac & 250GB transferred in less that 2 days.  Brilliant!

  • St1ngray Level 1 Level 1 (0 points)

    I have bought the time capsule to backup my MBA. When I connect the TC to the MBA directly via ethernet cable, the backup is quick, as expected.


    However, when I then connect over wifi, through my 3rd party router, the backup takes forever.


    Now the good part: I call the Apple Care service to help me out here. They told me that Apple does not support the config in which I connect my MBA and the TC wirelessly to my 3rd party router.


    The only reason I buy a TC is to hide it in the house somewhere, so that in the unfortunate event of a burglary, the backup is still there. So I am not looking to put it next to my modem or to hide cables to the attic.


    The Apple Care (NL) rep. told me that the only configuration supported, is the one in which I connect the TC by ethernet to the modem. Wonder if everyone does that?


    So then I did that, and it still took the TC about 5 minutes to backup 20mb.


    I wonder what you guys think, as I find it a bit weird that Apple Care blames it on the fact that I use a third party router. And on top of that, I find it weird that when the connection is still slow after connecting by wire, that they tell me to see how it goes for a few days.


    I spent 4 nights now trying to get this thing working and I must say I am very disappointed in Apple for the first time. Surely a 20mb backup should not take 5 minutes, and surely it is meant to work wirelessly.

  • bhurte Level 1 Level 1 (0 points)

    In your case, I'd recommend turning off 5GHz networking in your TC and seeing if that doesn't speed up the wireless backup - it worked for me (though I wasn't going through a 3rd party router).  You may have to turn off 5GHz in your 3rd party router also, but I wouldn't start there.  I'd also test it on a larger backup than 20MB - who knows how much overhead stuff is happening that masks the actual backup time for a backup that small.

  • Brian Christmas Level 1 Level 1 (100 points)

    I've got the same problem, but with a Firewire 800 linked 3TB Seagate drive that I just bought.


    Backing up 1.28 TB.


    It's mounted in a Newertechnology Voyager Q case, and I've tried the following to get Time Machine to speed up after the initial 1.62 GB, which went extremely fast.


    Re-named the drive (from 'Time Machine' which was my previous backup name)

    Repaired permissions


    Erased the drive

    Stopped and restarted the Backup


    but it always goes into super slow mode after the 1.62 GB initial burst. On stopping and restarting TM, it went to 386 days, and was still increasing.






    Late 2010 i7 27" iMac with 16GB ram, 2TB HD

  • winquirer Level 1 Level 1 (0 points)

    I am having the same problem of very slow backups with Time Machine after the upgrade to ML.


    Based on several posts on this issue, it seems that there is a bug with TM and other applications. It maybe Spotlight or other. The thing is that the workarounds have worked for me only for 1 or 2 backups and then TM performance goes back to super slow speed.


    Configuration summary:

    - iMac Mid-2010

    - OS X 10.8.2

    - WD MyBookLive 3TB NAS for backup

    - NAS is connected via Ethernet cable to the router, but the iMac goes WiFi


    So this is what I do to be prepared for a backup:

    - Turn Off Time Machine

    - If your router has 2 channels, ensure that the iMac is connected via 2.4GHz

    - Reboot the NAS

    - Do a Full Reset of TM based on Postini recommendation: A4. Full Reset of Time Machine

    - Run the command: sudo tmdiagnose (in the Terminal app, and you will need the admin password)

    - Reboot the iMac

    - Turn On Time Machine

    - Select the volume for backups from the options showed up in a window. Select the same volume you were using before for TM


    Normally the next backup will run with a decent speed ... but sadly one of two more backups later, speed drops again. So I repeat the procedure


    It is not a permanent solution, but at least I can rest in peace that the backups are being done to the NAS


    Hope this can help someone else, and hope that Apple can give a permanent fix

Previous 1 33 34 35 36 37 Next