Previous 1 39 40 41 42 43 44 Next 644 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. Go to original post Branched to a new discussion.
  • Csound1 Level 8 (46,885 points)

    jshrager wrote:


    I don't think that he meant unreliable in the sense of dropping bits, but wireless uses more power and more retries to overcome loss do to noise, which is much higher in a wireless network, resulting in significantly lower throughput (even than the bandwidth should theoretically allow).

    The additional retries compared to wired connections are because of dropped data (bits). The network will resend over and over again until the packet is correct, Thus lower performance (wires do the same thing, but have less errors and are faster)

  • jshrager Level 1 (0 points)

    I think we're saying the same thing, except I dropped enough bits to make "due" into "do". :-)

  • Csound1 Level 8 (46,885 points)


  • Paul Johnson13 Level 1 (60 points)

    Csound1, you and I may not have the same definition of "reliable" w.r.t a wireless connection. In the context of this thread I assume it to mean that a string of bits sent over the 'ether' does not get altered and at the destination can be counted on to be identical to what was transmitted. (If this were not the case, then what good are backups or disk copies anyway?)


    The only thing I can think of to explain your apparent sarcasm is that your are refering to reliablity in the sense that relative placement of the sending and receiving devices plays a part in signal strength and how often pckets need to be resent, etc. That's not what I'm referring to when I mention 'reliability' in the context of this thread.

  • Csound1 Level 8 (46,885 points)

    No, reliability is referring to the rate at which error correction will need to be applied to the data stream in order to keep it accurate. That will be much higher using an RF connection than over a wired connection. The data (at the end of the transfer) will be the same (or fail entirely) the time taken to get it there (and the OP is talking about time if you look) will be much longer over a WiFi connection.


    This thread is entitled:


    Screen Shot 2013-04-08 at 3.49.25 PM.png





    Speed is of the essence.

  • Paul Johnson13 Level 1 (60 points)

    This thread is FAR too long, and I'm going to have to discontinue monitoring it since I get too many email messages. I'm sure Apple is aware of a problem with the speed of Time Machine backups and has been pursuing a solution. Right now, I have Time Machine running. The first backup took a LOT of time but once completer, subsequent backups (which are much smaller) finish in a resonable amount of time.


    Looking forward to an Apple update that fixes the Time Machine issues reported on this thread.

  • Julius Cheng Level 1 (0 points)

    Oh, and as the RAM is fixed in many portable machines (e.g. Air, MBP), adding RAM is not a solution for them.

  • Tech Harmony Level 1 (0 points)

    Wow, this problem is still happening for people!?




    I recreated the problem once while setting up my friend's computer for the first time... but then in several subsequent fresh installs of 10.8.x (updating to 10.8.3) on other machines I haven't had the problem.


    I had the problem under Lion 10.7.x on 5 computers and managed to fix it before they released a successful fix. But that boiled down to spotlight ....but this Mountain Lion Time Machine problem is a hairier beast.




    Summary of Fixes (incomplete)

    Mountain Lion Time Machine:


    -tmdiagnose fix: that fix seemed to work because it doesn't just diagnose, it actually does something. But what it does was debatable so people would downplay that solution (much like they used to downplay repairing permissions with Disk Utility...something that magically fixes many things...) So who knows what tmdiagnose does but it seems harmless and seemed to help me.


    -network settings: some people would turn off DHCP and put in a manual IP address...some people needed to be on automatic...Feel like there was more to this.... wireless vs. wired? I know that under Snow Leopard (definitely Leopard), Time Machine was interwoven with the networking driver so that if your networking driver wasn't quite right, Time Machine wouldn't work at all. So I do wonder if toggling these settings doesn't somehow "fix" the networking driver for Time Machine.


    -Spotlight fixes: This involved finding the hidden spotlight files on each drive, deleting them....hiding the drives from Spotlight using System Preferences--> Privacy ... then disabling Spotlight altogether via Terminal commands. I had to do variations of these, sometimes more aggressive, sometimes less...The idea is to really clean and, if necessary, suspend make sure it's not somehow causing an indexing loop with Time Machine.


    -Activity Monitor investigation: if you pull this up and set it to show all processes...then sort by highest at top, you might see a process on your computer going bonkers. I've had one called "syslog.d" come up crazy which required magicks beyond the scope of this post. But worth noting what's going bonkers while you're trying to back up....


    -Repairing Permissions... you can Repair Permissions from Disk Utility (I don't even bother Verifying first....if there's a Permission that needs repairing, get it done!) ...sometimes you will see errors no matter how many times you run Repair Permissions. Yeah yeah, complain to Apple Long story short, you kinda have to get a sense of which ones aren't real errors. But do it a couple times if you see errors (Repair Permissions while highlighted on the second line of your hard drive in the hard drive list... not Repair Disk)


    The next level of this trick is to boot from your recovery USB stick and Repair Permissions while booted from this stick.


    -Reformatting the computer.... This tends to work best   But one person reformatted and tried to restore from his Time Machine backup at first AND HE STILL HAD THE PROBLEM. The backup restored the Time Machine problem for him! So then he realized if he just reformatted the computer and reinstalled all his Application and User info himself, he solved the Time Machine problem. This is unfortunate for people who don't really want to set up everything again.


    Course, one could try restoring your user info from a backup without restoring your applicattions ....He was of the belief that one of his restored Applications was the real culprit but he couldn't figure out which (some people thought that Dropbox needed to be updated but that wasn't universal)




    I fell off this Discussion Board at this point so am not sure if anything new came up...





    How to get SOME kind of backup:


    And how to get a decent backup in the first place, if Time Machine isn't working!? Carbon Copy Cloner or SuperDuper are great. Not sure if they cost anything now. This way you can make a perfect clone of your drive (or 2 clones!) before you start mucking about with can restore stuff from the clone using Apple's Migration Assistant if you want to go that route.... if it's too frustrating in the end, you can clone back from the clone to your computer.... But yeah, I suggest 2 clones to hedge against, um, "operator error." 


    Carbon Copy Cloner and SuperDuper have no problems copying data to/from external hard drives!





    As for Time Capsules:


    I like Time Capsules but i've had 5 different ones have trouble, spanning as many environments and models. But assuming the Time Capsule is working great otherwise, your first backup you should do wired. Choosing Gigabit (1000Mbps ) vs. Wireless (54Mpbs) that first time means you will get a straight backup in spite of how you've got your wireless environment set up. It is sooooo much faster.


    Yeah, wireless should work, but I've had problems with Wireless N if the people don't have direct line-of-sight...Heck, I've had some homes where Wireless G couldn't get through the walls! I had to daisy chain Linksys WRT54GL DD-WRT routers to bounce the signal around. You can mess with the radios and channels on the Time Capsule but sometimes even that isn't enough. Most people will have an easy time of it but I've encountered problems often enough that the only way to minimize variables here is to use a Cat 6 or Cat5e ethernet cable between you and the Time Capsule and turn off your computer's wireless to force it to use the ethernet. (You probably have Cat5 cables ...they're OK but you won't get the best speeds... better than nothing)


    This doesn't solve the  problem AT ALL but will let you see what your system will do under ideal Time Capsule circumstances.



    Data Corruption:


    I personally use a program called Chronosync to schedule daily backups of parts of my computers/drives rather than the whole thing. I like that there is a "verify data" step -- takes twice as long but I do it at night and it goes to that question of "losing bits" .... I've had computers for almost 20 years and that means moving data through a lot of machines over that time. I started getting into the habit of using Chronosync because it should detect errors if it hits corrupted data, and then I can see if I can find another copy of the file before I entrust my system. Now, how many times have I encountered corrupted data from a system copy? Not often... handful of times so far maybe? (and Carbon Copy Cloner caught one once or twice!) And not often enough to really matter, in the scheme of things. But I like the purity of a perfect (well, double-checked) copy. But for most people, that's overkill. I don't worry about wireless/wired loss because anything significant I transmit is verified by Chronosync...

  • rjovale Level 1 (0 points)

    my TM troubles started with the upgrade to 10.7.5 on my 2006 MBPro and then with 10.8.x on my new 2012 MBAir. i suspect that in my case it really is a spotlight issue:


    1- if i reset spotlight in my MBAir using the privacy trick, it takes a long time (~1 day) to finish the indexing, which is weird given that the SSD the MBAir has is pretty fast.


    2- Then, when i back up with TM for the first time (using a USB3 drive) the speed is pretty good till a point at which the indexing kicks in and the back up gets stuck (mds is 100% and more). Eventually the backup ends though.


    3- Also, it seems as i cannot properly search my SSD, files that should appear in the search dont.

  • RobertSWUK Level 1 (0 points)

    By some chance my time capsual is now backing up and copying data with no problem at all....

  • alchait333 Level 1 (0 points)

    My TM and any files transfers to an external drive were getting rediculously slow. TM would get stuck in "preparing backup" for two hours and then I'd have to let it run all night just to get a backup.


    After a lot of time working with the people at AppleCare, I started to suspect Dropbox as being the problem.  I found out that Dropbox doesn't automatically update, so I downloaded the latest version, 2.0.6 and restarted the Mac.


    After it indexed everything, which didn't take long, I put my cursor over the dropbox icon at the top and saw that it was stuck syncing on one file that a customer had given me.  I trashed that and similar files from that customer, and Drobox finished syncing.


    Now TM is super fast, file transfers are super fast and it's like having a new Mac.

  • msmgs0 Level 1 (0 points)

    Just Upgraded to Mountain Lion and slow TM using USB connect to Seagate 2T drive!


    Found that I had to uninstall AVIRA Mac Security to resolve the problem.


    After good TM I will install the latest Avira and see if it was fixed!

  • tban Level 1 (0 points)

    I had the same problem ... ever since I upgraded to 10.8.3 by backups never completed (I mean I terminated them looking at the estimate). Yesterday I did the following while the backup was going its third attempt to do a 40GB at a few KB per minute,


    - quit dropbox

    - quit google drive

    - unload spotlight (this took some time, actually two attempts)


    The backup suddenly picked up speed and was done in under an hr (maybe less - I wasn't watching).


    Hope that helps.


    This TM issue has happened many times now ... poor automated regression coverage before patch releases!

  • kilgo Level 1 (0 points)

    This worked.


    Before setting Spotlight exclusion targeting my Time Machine disk, it was going to take 13 hours to back up 31kb!


    31kb, not 310 GB...KILOBYTES!, 13 HOURS!...Jeeeeze!


    Although Spotlight responded "(disk) is a Time Machine Backup disk, and will continue to search items it contains" or somthing similar...when I closed it and did a back up took a fraction of the time, only a few seconds.

  • obroni62 Level 1 (0 points)

    Yes, so did I!

    I tryed a lot - and nothing worked.

    I switched over to CCC to make my backup.

    Because I had another problem I DELETED MY ANTIVIRUS-APP Bitdefender, formatted my externel HD again and tryed again TM!

    Holy Steveness, it worked

    Everything is fine now.