Skip navigation

time machine very slow with mountain lion

167667 Views 650 Replies Latest reply: Feb 11, 2014 4:45 PM by Booker T. RSS Branched to a new discussion.
  • Plughie Calculating status...
    Currently Being Moderated
    Aug 5, 2013 11:49 AM (in response to 1tombhome)

    I was staring at an 8 day backup for about 150GB when I started doing some of the suggestions in this thread:

    Turn off Spotlight indexing: sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

    Run Time Machine diagnostics: sudo tmdiagnose

    Quit Dropbox

    Quit Box

    Stop on-access scanning in Sophos Antivirus

    Pause Crashplan

     

    Estimate is now showing 20 hours, and it's dropping by an hour every 30 seconds or so. With any luck, it will be done by the end of the work day.

     

    MacBook Pro Mid 2010

    4GB RAM

    500GB SATA drive

    External 500GB FW800 disk for TM

  • zfelder22092 Calculating status...
    Currently Being Moderated
    Aug 16, 2013 2:21 PM (in response to Plughie)

    Tried just about everything and am still at 4.6GB out of 250 with 3 days left to go on my initial backup. Does this seem right to anyone? I just updated to 10.8.4 today and am getting .1GB/sec. This is ridiculous.

  • Plughie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2013 2:25 PM (in response to zfelder22092)

    Turn off any service that scans the disk for any reason, and as much as possible, don't use the machine while it backs up.

  • athomas88 Calculating status...
    Currently Being Moderated
    Aug 16, 2013 3:43 PM (in response to 1tombhome)

    I am at 1.37GB of 319.95GB - about 5 days remaining. With so many having an issue, why is Apple not fixing this? My original TM (a WD 3TB My Book) has always backed up fine. Have been away from the office a lot so haven't used TM since 7/13/13. Now I only get "preparing for backup". Using a different 1TB WD My Book. Working but severely slow.

  • zfelder22092 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2013 4:30 AM (in response to athomas88)

    Did a backup with the program that came with my hard drive in a very reasonable amount of time. 200gb in 5 hours. Now I am attempting to do another backup with TM.. I have 20.58GB out of 234GB with "About 3 days" left and it's been running for 7 hours! Someone needs to fix this ASAP.

  • jladams97 Calculating status...
    Currently Being Moderated
    Sep 5, 2013 6:43 PM (in response to zfelder22092)

    Somehwere in this thread I saw a couple of people post that when they had an issue with the Time Machine backup being painfully slow, they started over and that fixed the issue for them. Well +1 to that for me: I went from expecting it to take something like 4 days to expecting it to take 7 hours! I believe I read where for someone else starting over didn't work but based on my (admittedly very limited) experience, I do very much recommend you at least give it a try. Now, if Time Machine slows down for you after you've been using it for a long time, then you're in a tough spot and I get that. But if you're like me (and many others who have posted here) and it's slow when you first set it up then you literally have nothing to lose (well, okay, so outside a small investment of time) by trying starting over.

     

    What I did to start over is in the Time Machine settings, I completely removed the NAS shared drive as a target so Time Machine was back to its initial "choose a backup disk" state and then on the NAS I completely removed the existing share (I deleted it) and created a new one. Then I went into Time Machine, selected the new share, and let the backup start (there's a countdown for something like 2 minutes that Time Machine does when you first set it up).

     

    Things that are notable in my case:

    • During the initial slow backup I was also doing a SuperDuper! backup to the same NAS; on the second speedy backup that SuperDuper! backup is not running. The difference in speed between the 2 backups is so great that I wouldn't expect it to be entirely due to the effect of the SuperDuper! backup (or lack thereof) but it's possible.
    • When I initially set up Time Machine to back up to the NAS, I set it up then turned Time Machine off before it could ever back up because I wanted to get some stuff off the Mac and onto the NAS before Time Machine went to work (that way I avoided having the same stuff taking up space both directly on the NAS and in the Time Machine backup on the NAS); when I started over, I made sure to set up Time Machine and then let it start backing up immediately. Letting Time Machine start backing up immediately in the second instance wasn't just happenstance: that was very intentional because I had a feeling that it might make a difference. Now, I don't entirely know why it would make a difference--maybe in the first instance even though there was no existing backup Time Machine was still engaging it's logic to check to see if something needed to be backed up or not; that would be silly and obviously a HUGE bug, but maybe that's it.

     

    Anyway, as they say, your mileage may vary but definitely give this a try before jumping through more difficult hoops and certainly before just giving up. I don't know what the keys are and so I therefore recommend a complete starting over that includes completing removing any knowledge of the backup target from Time Machine so it is back in its initial "choose a backup disk" state and it includes completely starting over with your backup target (either removing and recreating the share if you're working with a NAS or removing and recreating the partition if you're working with a drive directly). I think it's important before you say "starting over didn't work for me" that you really are starting fresh both on the Time Machine side and the target side. It still may not work for you, but if you're just kind of starting over and not really doing it fully and it's not working then it's not fair to say that starting over didn't work for you.

  • BaronBomBurst Calculating status...
    Currently Being Moderated
    Oct 8, 2013 3:28 PM (in response to 1tombhome)

    Shame on Apple.   The original posting date of this thread is Jul 2012,  now it's Oct 2013 and it's still not fixed.  A fundementally basic task of backup, not working.   We shouldn't be jumping through hoops for this, my opinion.

     

    Telling people my Macbook Pro, is so great, seems hypocritical when I can't even back it up using the OS provided mechanism.    Disappointed.

  • Andrew Beswick Design Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2013 3:59 PM (in response to 1tombhome)

    First back up is always a nightmare and slow.... after that its incemental.

  • gafortiby Calculating status...
    Currently Being Moderated
    Oct 14, 2013 8:02 PM (in response to 1tombhome)

    Hello everyone,

     

    I had the SAME problem and FIXed it.

     

    On the following hardware:

    • brand new 2013 Macbook Air with 802.11AC, OSX 10.8.5 and 10.8.5 supplemental update all installed.
    • brand new Time machine backup (first time initial backup) to 2013 Time Capsule with 802.11ac with all updates installed.
    • Everything occuring over 802.11ac 5Ghz with transmit rate 700. I am sitting 5 feet away from my TimeCapsule.

     

    I was averaging 3KB/sec, estimated completion 10 days for 50 GB of data. Comparitively, my wife's 2011 MacBook Air as showing 5 hours to completion for 100GB of data. My 2006 MacBook would routinly complete its backup in about 6 hours for 40GB of data on its slower 802.11n so I knew something was wrong with a 10 day prediction.

     

    In the Console, I found repeated error messages, alternating the following with ~~~~~~ actually representing a very long string.

    decmpfs.c:1339:decmpfs_read_compressed: decmpfs_fetch_uncompressed_data err -35

    /SourceCache/AppleFSCompression_kexts/AppleFSCompression-49/Compressors/Dataless /compressorType5Kext.c:532: Error: post_request error for ~~~~~~.DocumentRevisions-V100~~~~~~

     

    So in my limited knowledge I guessed that TimeMachine was trying to back up my .DocumentRevisions-V100 directory but failing.

     

    I added .DocumentRevisions-V100 into my "Exclude these items from backups" option of Time Machine and clicked "save". I had to "show invisible" to add the folder. TimeMachine backup re-started automatically (from 0) but my backup time changed from 10 days to 2 hours!!!

     

    I believe .DocumentRevisions-V100 is supposed to be excluded from Time Machine anyway, but for some reason it WAS being backed up on my computer. From what I read, .DocumentRevisions-V100 is just for versioning, I figured I don't need to back up this directory.

     

    So I solved my problem, I wonder if others can bennefit from this tidbit. Good luck everyone!

  • athomas88 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2013 7:22 AM (in response to 1tombhome)

    Ok...found my issue. My problem actually had nothing to do with Time Machine. The Genius Bar told me my HD was fine that I had a software issue that was causing my "spinning pinwheel" and my slow TM backups. After completely erasing my HD and starting over, the TM and pinwheel issues persisted. I ended up going to Best Buy's Geek Squad and was properly diagnosed with a failing HD. Replaced HD, restored from TM and back in business for nearly 2 months now.

     

    A little disappointed that my 4 hour round trip to the Apple store failed to properly diagnose an Apple computer issue, but happy to be back on my MBP.

  • Timmsy Calculating status...
    Currently Being Moderated
    Oct 19, 2013 5:22 PM (in response to 1tombhome)

    Was having the same problem, this is a screen shot....Time Machine backup!!!!.jpg

    thats about 6,415 years..............

    I found that Bitdefender was the problem, I went in and excluded the backups and it went down to 5 days and now to 2!!! Still a while but at least acheivable, it is TB's we are talking about after all.......

  • Sherri39401 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 21, 2013 3:14 AM (in response to 1tombhome)

    I had the same problem with slow backups. Called Apple 5 times and went through all the hoops checking plists, airport, and then erasing using my airport utility and the first backup of about 25-30 gigs went fine, but the second backup would take between 1-2 hours. By the time it was finished it was ready to do another backup.

     

    After looking at community fixes I found that my Comcast Norton Anti Virus was the problem. Upon speaking for the 6th time to Apple I was told that should have been the first thing they asked, since antivirus programs check each file going to the time capsule. Even unchecking the scan external drives did not help.

     

    I removed the Norton AV from my system and replaced it with the IAV from apple store (free) and my backups are back to normal. I timed a 100 meg using Ethernet/LAN and it took 9 minutes 32 seconds from clicking backup now, searching for backups, preparing backup, backingup, and cleanup. My Wifi connection on 10 megs took only 1 minute 29 seconds.

     

    Now my backups run so fast I don't even see them working. Also the constant updates to Norton were casuing my backups to be 100 megs or more each time due to daily Norton updates. Now I get backups in the order of 10-20 megs - depending up what I have put on the machine. If I put music on it increases the size of the files installed.

     

    I recommend anyone having this slow time capsule problem to turn off your full antivirus program no matter what you are using and watch the difference in speed. I am so happy! No more 2 hour backups and 45 minutes to 1 hour preparing backup! good luck

  • tadpoles Calculating status...
    Currently Being Moderated
    Oct 23, 2013 8:52 AM (in response to 1tombhome)

    Same problem - Time Machine backups become never-ending! After uninstalling Norton AntiVirus, everything returned to normal and Time Machine backs up quickly again. Many thanks for suggestions. I'll keep the Console loaded from now on and regularly check the speed of backups

  • Cpt_Morgan Calculating status...
    Currently Being Moderated
    Dec 6, 2013 11:30 PM (in response to dolfke)

    Thanks dolfke

    Problem solved

  • Cpt_Morgan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2013 11:36 PM (in response to 1tombhome)

    This solved my problem

     

     

     

    How to run tmdiagnose

     

     

    1) Launch Terminal.app (/Applications/Utilities/Terminal.app)

    2) Enter the command text below followed by the Return key on the Terminal command line:

     

     

    sudo tmdiagnose

     

     

    3) Enter your admin password when prompted and wait for all of the tmdiagnose processes to finish.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (24)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.