4 Replies Latest reply: Feb 25, 2013 1:04 PM by Eric Root
venny Level 1 Level 1 (20 points)

Just installed Mountain Lion, and neither of my external drives will unmount. When I attempt to drag them off my desktop, I'm prompted to "force eject" them, which has no effect. The only solution I've found is to log out.

 

Has anyone else experienced this? Is there a fix? Thanks in advance.

  • Steven Forwood Level 1 Level 1 (15 points)

    I have this problem and it is driving me crazy. None of my external drives will eject on Mountain Lion. If I connect the same drives to a Mac running Lion or Snow Leopard, they dismount immediately. I've been trying to fix this for a couple of months and have had no luck. Does anyone have any ideas how to fix this. For some reason, the system locks into something on my externals as soon as they are plugged in. This problem appears using USB 3.0 and Firewire (through thunderbolt port). Thanks in advance.

  • Steven Forwood Level 1 Level 1 (15 points)

    I guess no one has a solution to this problem. I have figured out that it only affects USB 3.0 drives. USB 2.0 drives eject properly. I wish Apple would look into this. None of these problems occurs in Lion. Mountain Lion seems to be full of bugs.

  • Steven Forwood Level 1 Level 1 (15 points)

    Finally solved the problems of external drives not ejecting. Get an application called LaunchControl. This app solved this problem I have had for months. The app showed me that a Steam launchagent was looking for a game on those drives for some kind of clean up process. I removed references to those drives in the Steam launchagent and all my drives now eject properly. This was not a problem with the system after all. LaunchControl is a very good application, I highly recommend it if you want a closer look at your launchagents and deamons.

  • Eric Root Level 7 Level 7 (27,425 points)

    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work.

     

    Isolating an issue by using another user account

     

    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the grey Apple icon and a progress bar appear. The boot up is significantly slower than normal.

                   

    Safe Mode

     

    Safe Mode - About

     

    General information.

     

    Isolating issues in Mac OS X

     

    Permissions Troubleshooting

     

    Step by Step to Fix Your Mac