Previous 1 2 3 4 Next 45 Replies Latest reply: Sep 21, 2014 8:48 AM by Nickburgers Go to original post
  • apple jon Level 1 Level 1 (0 points)

    I have the same persestint issue that comes and goes without a restart.  I also have a problem that only my main account on the computer-macbook pro 2011- will air play the display all other accounts have a scrambled screen displaying random info not associated with that account. looking foward to a update that will correct this.

  • Raakanin Level 1 Level 1 (0 points)

    If you are using VLC when experiencing these problems - try this:


    Activate AirPlay first, then you can launch VLC.

  • stephanschier Level 1 Level 1 (0 points)

    I have the same issue which sometimes resolves itself with a reboot, and sometimes not.  Currently I can AirPlay the audio output but display mirroring fails.

  • theden1974 Level 1 Level 1 (0 points)

    This works for me, thanks.

  • Raakanin Level 1 Level 1 (0 points)

    Another thing to try if the sound is not being AirPlayed to the right device (ATV), is to run this Terminal command:


    sudo killall coreaudiod


    If this Terminal command works, you can download this Applescript-application that runs the script for you (put it in the Dock):

  • theden1974 Level 1 Level 1 (0 points)

    even better, thnks... Hopefully Apple will come up with a solution, this bug has been hanging around for a long time...

  • stevemcd92 Level 1 Level 1 (0 points)

    worked beautifully!

    its ridiculous this is taking so long to fix

  • spencerjon Level 1 Level 1 (0 points)

    Exact same problem here. MBA 2012 and apple tv 2012.  won't let me select sound output for apple tv, just shuts off airplay mirroring when i select that option.  No sound possible through mirroring. this is annoying and is definitely a bug since it was working fine when i first got the air and apple tv.

  • DexterII Level 1 Level 1 (10 points)

    Yes I am having the same problem here. Mountain Lion 10.8.2 on 13" retina MBP. Discovered it the other day. Restarting fixes sometime. But whats ticking me off now is when I do get it to work the audio sometimes studders and pauses while my iphone and ipad have no problem.... Not sure the reasoning behind this hopefully a bug Apple will work out.

  • onehorsegirl Level 1 Level 1 (0 points)

    Same here...I have everything on and ready to go and restarted MBP Late 2011 and the sound was coming out of the TV FINALLY!  We shall see how long it lasts tho....

  • stephanschier Level 1 Level 1 (0 points)

    I have had this problem for quite a few months now.  I have a Retina, MBP 13in (late 2012), running OS X 10.8.3.


    Running sudo killall coreaudiod in the Terminal as Raakanin mentioned solves this problem every time.


    Or and also, launching the Activity Monitor, filtering for "audio", selecting the "coreaudiod" process and clicking "Quit Process" fixes it every time.


    Coreaudiod relaunches and I am able to select Sound / Output / Apple TV [AirPlay] again.  No need to restart the MacBook.

  • netsoup Level 1 Level 1 (0 points)

    Awesome! Thank you.

    sudo killall coreaudiod worked for me too.

    It feels so janky to have to to reboot your $1000 Mac Air every fourth or fifth time you use airplay to get audio.  Reminds me of an old rustbucket when it's really a fine machine and product but for this bug.

  • WeepingAngel Level 1 Level 1 (0 points)

    +1 confirmation that this "coreaudiod" appears to be the culprit.


    also replying can only help the google page ranks about this right?...

  • gphonei Level 1 Level 1 (0 points)

    Killing coreaudiod is not working for me.  I can not select anything but internal speakers, with 3 different airplay audio destinations visible.  Each time I click on one of them, it goes back to the building speakers.  With airplay display mirroring going out to the AppleTV, when I click on the audio route to the AppleTV too, airplay mirroring turns off when it switches back to the builtin speakers.


    There appears to be some broken, remembered state, that is keeping it from switching.  I just can get coreaudiod restarts to fix it for me.

  • Raakanin Level 1 Level 1 (0 points)

    When you're experiencing this problem, are VLC running? (either as the frontmost app or in the backgrouond).


    If so, open the 'Audio' menu in the menu bar of VLC => Audio Device => choose the audio device you want, in your case it would be AirPlay.


    If you don't use VLC at all - Of course I'm sorry for wasting about 5 seconds of your life