1 2 3 4 5 Previous Next 135 Replies Latest reply: Feb 26, 2014 2:54 PM by Romana Go to original post
  • 30. Re: Javascript bugs in Safari 6 on Mountain Lion
    David Barrett1 Level 1 Level 1 (15 points)

    Your suggestion didn't fix my JSON string problem, meadeiator, but it did add a bit more zing to Safari, which had felt a bit slow since my Mountain Lion update.

     

    Kudos for that!

  • 31. Re: Javascript bugs in Safari 6 on Mountain Lion
    David Barrett1 Level 1 Level 1 (15 points)

    Just turned off all extensions and problem solved. Had previously turned off Ad Block, but that didn't help, so must have been something else, or maybe a combination. Will now go back to the old-fashioned "half-on, half-off" to see if I can isolate the problem. Will report back ...

  • 32. Re: Javascript bugs in Safari 6 on Mountain Lion
    David Barrett1 Level 1 Level 1 (15 points)

    Evernote Web Clipper 5.6 extension. Reinstalled it, and it still breaks Javascript.

     

    May not help everyone, but hope it helps some!

     

    Doesn't seem to be a conflict with any other extensions, because once I'd isolated it I ran it by itself and it still gave me a JSON string error. All fixed now. Now just have to wait for an update ...

  • 33. Re: Javascript bugs in Safari 6 on Mountain Lion
    TheAnimaster Level 1 Level 1 (0 points)

    I would imagine that it would, for the same reasons SunSpider slows to a crawl. With AdBlock I encountered horrible memory leaks, and this would quickly eat up my memory under 8GBs. Now that I've installed 16GBs of memory I've enabled AdBlock again -- but only because it does block ads better than the alternative (Glimmer Blocker). Glimmer has bugs itself, but none that cause serious system performance degradation.

  • 34. Re: Javascript bugs in Safari 6 on Mountain Lion
    Dave from MB Level 1 Level 1 (0 points)

    I'm having the same issues here (white "blocks" covering certain areas, typing/backspacing looking funny, etc). I notice it most often in Gmail. It's really getting irritating!!! Please fix... someone! After having read everything to this point... it appears that there is not yet an easy fix for this right?

     

    - getting slightly frustrated... Dave

  • 35. Re: Javascript bugs in Safari 6 on Mountain Lion
    HuwPNE Level 1 Level 1 (5 points)

    Same issue for me, on a iMac (3.06 GHz Intel Core 2 Duo with 12Gb of Ram) have disabled AdBlock, and the SunSiper ran much quicker. Will test again.

     

    However have a Air with no Safari extensions and the same thing happens

  • 36. Re: Javascript bugs in Safari 6 on Mountain Lion
    Pecos Bill Level 1 Level 1 (75 points)

    Your problem is either hardware or something not broswer specific. Check Activity Monitor (in the utilities folder) to see what else is running

  • 37. Re: Javascript bugs in Safari 6 on Mountain Lion
    Barna Biro Level 1 Level 1 (0 points)

    I am also experiencing some weird rendering issues in Safari. Never happened before on Lion... I've made a complete clean install of Mountain Lion approx 1 week ago. Deleting text from input fields can many times reproduce the issue... then simple scolling or selecting the messed up text renders it correctly once again.

     

    It's definitely a software issue and not hardware.

  • 38. Re: Javascript bugs in Safari 6 on Mountain Lion
    Matt Hardy Level 1 Level 1 (135 points)

    I can report Safari 6 has some widget problems related to javascript.

     

    My example is a <select> <option> list, with onchange.

    The option content, is. the name in the list, completely disappears.

     

    But, Chrome has the same problem...

     

    Webkit 2 perhaps?

  • 39. Re: Javascript bugs in Safari 6 on Mountain Lion
    Matt Hardy Level 1 Level 1 (135 points)

    I have found my specific error - although I am unsure why this is not supported:

     

    I have an array in my form 'editform'.

     

    ["USD", "0.1650", ".", ","]

     

    and then I do this onchange:

     

    document.editform.currency.value=currency_arr[0];

     

    Where 'currency' is the name of a select.

     

    Then the option label disappears.

     

    however, I've found that the operation is not a required feature, and should not be in the code.

    But I am confused as to how it messes with the dom render in this way, and has worked in the past without the effect.

     

    So, well, it's not Safari, but Webkit I think.

     

    Unfortunately I spoke too soon. It's a possible bug in Webkit, I have to add a 3rd dom element to counter the 'disappearing' select option.

     

    Hm, in fact, I found that my db solution removes the need for fixing the data, a 3char field saves the html-concatenated js array as just the currency code, so a storage solution solved this js behaviour / code design issue.

     

    OK, but still webkit weirdness

  • 40. Re: Javascript bugs in Safari 6 on Mountain Lion
    tacmark Level 1 Level 1 (0 points)

    Hi,

    I having one particular problem with Safari 6, 10.8 and WebKit.

     

    At my work place we have a number of security camera's(IP network type) record to a Window's server. On occation we directly access an individual camera to see whats happening in an area at work from Mac desktop computers. This is not an issue with 10.6.8, Safari, Chrome, FireFox or Opera it is a real problem with Mac OS 10.8, Safari 6, Chrome and Opera although FireFox displays the live IP camera feeds without issue.

     

    We also use FileMaker Pro 12 is to display some of our camera feeds (custom WebViewer frames) for a receptionist, which works great under 10.6.8 and it's underlying WebKit engine. Up six live camera feeds into the FileMaker database, without issue as well as ODBC data from a MySQL server.

     

    Mac OS 10.8, Safari 6 and the WebKit that comes with Mountain Lion fails on tasks listed above. Safari, Chrome or Opera will only load a few frames of live content, with the stream stopping mid flight. The same applies to FileMaker Pro 12 and the Web Viewer frames within the database, a few frames of streamed footage which then stop. The functional part of the FileMaker database is not affected just the camera streams to the Web Viewer frames.

     

    It seems to me that there is compatibility issue between 10.8, Safari and the WebKit. I've installed the latest Java 7 builds and Java 6, current WebKit build as of the 10/08/12. Safari and Google Chrome not working seems to support this as well as FileMaker Pro 12 and its Web Viewer frames.

     

    Any input would be appriciated.

     

    Mark

  • 41. Re: Javascript bugs in Safari 6 on Mountain Lion
    Pecos Bill Level 1 Level 1 (75 points)

    As was mentioned elsewhere in this topic, Java and Javascript only share a similar name. Otherwise, they are utterly separate. And of late, Java is used as a vector for malware infection so unless you need it, I would leave it off.

     

    Meanwhile, this is sounding like a bug that only Apple can fix. For that reason, anyone experiencing this problem should report what they're seeing via one of the two bug reporting systems available. For non-developers, it's Apple's OS X Feedback (first feedback type option) and include as much info as possible on what to do to recreate it.

  • 42. Re: Javascript bugs in Safari 6 on Mountain Lion
    Mazzitech Level 1 Level 1 (0 points)

    I'm having the same issues.  I'm developing a Joomla site and I progressively lose the ability to use the JS features.  I tried going out to the forum.joomla.org site to look something up and I get a 406 Not Acceptable error yet Firefox on my iMac works!  I did not have these problems until I did the upgrade.  Apple, you have a real problem here!

  • 43. Re: Javascript bugs in Safari 6 on Mountain Lion
    AppleEatersAnonymous Level 1 Level 1 (0 points)

    I'm having a similar javascript issue. If you open up the error console you will see that any site that uses Jquery breaks. Actually it's more like any site that uses Jquery that is hosted at

    Failed to load resource http://ajax.googleapis.com/ajax/libs/jquery/1.5.1/jquery.min.js

     

     

     

    I can however load up a VM that has windows on it and use the browser in the VM just fine which is how I have been working around this.

     

    I believe this has gotten worse in the last few weeks. There is also another error you can find Unsafe JavaScript attempt to access frame with URL - Domains, protocols and ports must match.

     

    I am really lead to believe this may be a keychain / certificate issue since it is effecting all my browsers. It's definitely not adBlock and it's definitely not a browser extension as neither of them are on my system and the one browser extension I have for Chrome is disabled and I have Safari's extensions turned off.

     

    Whatever this is, it is on a system level. I just dumped my keychain but it had no effect. The reason I think it has to do with the keychain is because if you try to navigate the URL for the hosted jquery that I mention above, you can't get there. Safari Can't Connect to Server. So it's either something with my keychain or something with my hosts file and my hosts file looks ok to me. It's not a software firewall issue, my firewall is not turned on. It's not a hardware firewall issue because I can get to it from my Mac if I am on a VM...

     

    I'm a web / app developer and it's not effecting what I do for work... I think it may also be tied to Safari because when I have the error console opened up, I can't navigate to a page without the debugger running and stopping the page from loading. This should not be happening either. So I think there may be something going on with Keychain / Security Preferences that is triggering issues with the browsers.

     

    Just my uneducated guess...

  • 44. Re: Javascript bugs in Safari 6 on Mountain Lion
    AppleEatersAnonymous Level 1 Level 1 (0 points)

    Also, I just upgraded to 10.8.1 and it's still there.

     

    Can you all check out stackoverflow.com and see if you get a red banner at the top with this error:

    Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load.

     

     

     

     

    I think if we all get that message, our errors are related.

1 2 3 4 5 Previous Next