Previous 1 2 Next 16 Replies Latest reply: May 14, 2014 1:11 PM by seanxsolo
tazreed Level 1 (0 points)

OK...I'm just about over iTunes. I have been purchasing more and more songs on my iPad from the iTunes store and then when I start up iTunes on my home PC, it starts to download the songs, as it is supposed to, locally to my hard drive. However, every single song does not complete downloading before a message comes up that the itunes network connection was reset. The song in Downloads indicates "err = -3253.

 

Based on various discussions, I have added all of the apple sites to my security software (webroot), uninstalled and reinstalled itunes (pointless since it never really uninstalls), deselected "Allow simultaneous downloads", looked to see if I have conflicting services running (I don't), and pulled out several hairs clicking the OK button everytime the error comes up and clicking Resume All....

 

Ultimately, I will get songs to download completely, but there really is no excuse for this.

 

I  run Windows 7 Professional and have Verizon FIOS as my service provider.

 

Anyone else experiencing this (I've had this happening for well over a month now)? Anyone have a solution?

 

Thanks!

  • Nydidia Level 1 (0 points)

    I've been having the same problem, and also have the same setup (Windows 7 and Verizon Fios).

     

    I'm not sure this is related either, but previews of songs are interuppted. I typically only make it through 10-20 seconds of the preview, before it stops. Do you have this problem, too?

     

    This is a fairly annoying error. Hopefully we'll get an answer soon.

  • tazreed Level 1 (0 points)

    I've had the preview song issue happen as well...but usually only when I click to another application. As long as I stay in iTunes and don't click anything, previews seem to work.

  • James Robert Level 1 (5 points)

    Yes.  I'm on MAC Lion.  First I thought it was a problem with my NAS as I was having some issues there.  But got the latest NAS firmware update, which resolved that, but iTunes download error persisted.  I've looked at my NAS and router logs after the issue has occurred but I'm not seeing any errors there.  I did discover that I could prevent the annoying failed retry everytime I restarted iTunes by removing the tmp folders and files under the iTunes Download directory.  But the issue persists and I have stuff on Apple Store that I've purchased but can't download.  I've seen other posts with resolutions that seem pretty hit or miss like one above.  I continue to be surprised and disappointed at how flakey iTunes is.  Just when I think I have it stable, something like this happens.

  • James Robert Level 1 (5 points)

    Right after I posted this found a couple of other replies elsewhere.  Including one below.

     

    http://appletoolbox.com/2010/09/itunes-10-the-network-connection-was-reset-fix/

     

    iTunes appears to be sensitive to DNS lookups (for folks not in the weeds, DNS is what translates the url you type in to a computer ip address - e.g. on the internet).  This fixed it for me.

  • Justin Schack1 Level 1 (35 points)

    I was having the same issue. Moved my iTunes music folder to NAS, which worked fine. But downloads would get interrupted with error 3253. I switched from accessing the internet via wi-fi to ethernet and the problem disappeared. Try connecting an ethernet cable between your router and the computer you're using to access the iTunes store. it worked for me.

  • tazreed Level 1 (0 points)

    Trying James' solution, though if you want a link to how to change DNS in Windows 7 instead of Mac, here's one:

    http://www.sevenforums.com/tutorials/15037-dns-addressing-how-change-windows-7-a .html

     

    Will be trying it out today, so fingers crossed!

  • tazreed Level 1 (0 points)

    Yep - the DNS settings did the trick. All better now! Thanks!!!

  • SillyMikey Level 1 (10 points)

    I am using Windows 8.1 and when i try to update apps that are no longer on my phone, it always says connection reset. I have full of apps now that i cannot update cause they arent on my phone....

  • ellenks Level 1 (0 points)

    This worked like a charm for me! Thanks so much!

  • Fwoggie2 Level 1 (0 points)

    Agree with ellenks, this worked for me too.

  • RadRobert Level 1 (0 points)

    How does this work on iTunes 11 though? That's what I'm running.

  • JimConno61 Level 1 (0 points)

    I connected my airport extreme with my computer via ethernet. No change.

  • raj18 Level 1 (15 points)

    This started happening to me about three days ago and meant iTunes Match was not working and nor was it possible to download updates to apps.  The internet was otherwise fine on my computer.

     

    I did a few things which did not work:

     

    1. Sign out of the Apple Store and log back in

    2. Turn off iTunes Match and restart it

    3. Remove uneeded items from the start up menu

    4. Restart cable modem

    5. Restart Apple Time Capsule

    6. Restart iTunes

    7. Restart Computer

    8. Update DNS settings from Google's to my ISP

     

    I then did the following which did work:

     

    1. Update DNS setting to Open DNS (as in James Robert's post above) and hit Apply

     

    I only updated the settings in the network system preferences panel against my Ethernet connection.  I did not amend anything in the Time Capsule or Modem.

     

    Frankly fed up that so much tinkering is needed at such a detailed level.

  • NorCalOffspring Level 1 (0 points)

    I have a netgear dual band router. After encountering this error message, I switched to the other band off my same wifi router and that seemed to work.

Previous 1 2 Next