Previous 1 2 3 Next 34 Replies Latest reply: Jun 22, 2015 1:21 AM by JBP1 Go to original post
  • Mijko Level 1 Level 1

    Ah ha! Success with Calendars 'On My Mac'

     

    After following dburrens steps, I got them to appear again.

     

    I think it's important to make sure you only disable the iCloud account from inside Calendars preferences, and not actually completely sign out from iCloud from within system preferences (which is what I tried before following applefandan's first suggestion).

     

    Now I only have 'On My Mac' folders missing from the new Reminders application, which is where I'd would make most use of them. Has anyone got them to reappear there?

  • Mike Matthews Level 1 Level 1

    Do this:

     

    Control-click on an empty space in the Calendars list in the sidebar. From the pop-up menu that appears, choose New Calendar. You can also make a new calendar group this way. And it appears you don't have to disable your iCloud (or other) accounts.

     

    mm

  • verdi1987 Level 1 Level 1

    Trying to get back the option for local "On My Mac" Notes while also using iCloud Notes was driving me crazy. I originally moved all my Notes to iCloud after upgrading to 10.8. Afterwards, I wanted to keep sensitive Notes locally, but there was no way to either move a Note out of iCloud or create a new one locally, as the local Notes folder had disappeared.

     

    Somewhat serendipitously, the OS X Notes app had a problem syncing one particular Note and created four duplicates locally — "On My Mac."

     

    So now I have both local and iCloud Notes.

     

    It boggles me that the ability to recreate a local Notes folder either was overlooked or intentionally not included/fixed. Then again, I am even more surprised there is no way to sort Notes alphabetically (whereas you could when Notes resided in Mail).

  • Mike Matthews Level 1 Level 1

    And I should add this: make sure that no other calendars are selected is the Calendar list. If a calendar is selected, then the New Calendar will be created within that account, rather than On My Mac.

     

    mm

  • revstrange Level 1 Level 1

    republish them where? i am using iweb and i can no longer publish my calendar.

  • webweasel Level 1 Level 1

    Excellent Mijko, now were're getting somewhere!  Thanks for the tip,

  • deivy Level 4 Level 4

    Thanks Mijko,

    You are absolutely right, doing it from within iCal fixes the problem.

    However, I believe that this is an abuse and we should have our local calendars if we wanted too.

    not everything has to go thru iCloud.

    I'll file a bug report with Apple and suggest everyone else do the same.

  • Cucurucho Level 1 Level 1

    In case it helps, this is what I did to recover the "on My Mac" section on Calendar (after mistakingly allowing iCloud to gobble up my local calendars).

    Did an export of all the relevant calendars. NOT a backup, an Export. You end up with an .ics little file for each calendar.

    Unchecked Calendar & Reminders from the iCloud System Preference, walking past the warning that the calendars where going to vanish from my Mac, rain would pour and my cat would be kidnapped by angry koreans (which after trying to fix the stupidity of this app for hours seemed like an enticing perspective). Puff... the calendars dissapeared from Calendar.

    At this point it was impossible to create a calendar on the "on My Mac" section, which had apparently also been taken for a ride.

    Went to Calendar Preferences and deactivated all my CalDAVs.

    Back in Calendar did File->New Calendar and created an "untitled" calendar. Boom, it landed on "on My Mac".

    Reimported the calendars I saved, using the .ics files above.

    All's well now. I just hope the darn team that developes Calendar simmers for ages en el infierno.

  • mauer_uk07 Level 1 Level 1

    I finally made it! Thank you Mijko!

    Yeah, the key thing is we only need to uncheck the "enable iCloud" checkbox, create a new "On my mac" calendar adn then re-enable the iCloud Account.

    Greeetings from Mexico!

  • mikejimtech Level 1 Level 1

    Excellent.  Took a while to figure this one out, but that totally solved my problem.  Thanks!

  • KirkKerekes Level 1 Level 1

    Another way to recreate the "On My Mac" calendar section is to use Automator to create a Calendar action. That will automatically recreate the On My Mac group.

     

    Then, if you don't want to keep the Automator calendar, create another calendar in the On My Mac section before deleting the Automator calendar.

  • K I M B A K A T Level 1 Level 1

    Great..but where is the option for "On My Mac" in Mountain Lion?

  • KirkKerekes Level 1 Level 1

    Create an Automator Calendar Action, and Calender creates the "On My Mac" section to put a "Automator" calendar in.

     

    The Action contents is irrelevant.

     

    Create the action in Automator, not Calendar.

     

    Just try it, you'll see.

  • J-e-L-L-o Level 1 Level 1

    I was having trouble with iCal also trying to figure out how to enbable On My Mac calenders. (Late to the party on upgrading to Mountain Lion).

     

    Simple and easy fix: Disable ALL accounts first. Then you can create a new calender which includes a new "On My Mac" calender. I had more than one and couldn't figure out why it wasn't working. Disabling them gives you a blank calander to add to.

  • Ellen B. Level 1 Level 1

    The only options I'm given when trying to creata a new calendar is gmail or icloud.  I cannot get On my Mac no matter what, and BTW all my calender entries are now in quintuplicate! Please help.

     

    Message was edited by: Ellen B.