Previous 1 2 3 Next 32 Replies Latest reply: Oct 28, 2013 12:31 PM by M.Stella Go to original post
  • kholford Level 1 (0 points)

    I have the same problem.  Quickest fix is to execute the Terminal command "killall Dock".

  • peggert Level 1 (0 points)

    I had the same problem after updating from 10.7.4 to 10.8.2 and found a possible solution. There seem to be some incompatible settings in old configuration files for the dock.

     

    I could solve this by deleting the configuration file for the dock. To do this open Terminal and type

    rm ~/Library/Preferences/com.apple.dock.plist

     

    Don't forget to make a backup copy of this file before! Or just rename it instead of delete it with a command like

    mv ~/Library/Preferences/com.apple.dock.plist ~/Library/Preferences/backup.com.apple.dock.plist

     

    After that you get a dock with only the Apple standard apps in it and a new com.apple.dock.plist is created. It is a good idea to make a screenshot of your existing dock before to remember which apps you have in there.

     

    Perhaps you have to repeat this for all of your user accounts.

     

    After that fast user switching works for me without transparent dock and any other problems.

     

    I hope this will help you. Good luck.

  • fab@colmar Level 1 (0 points)

    this is solved deffinitivly

  • fab@colmar Level 1 (0 points)

    This is solved definitivly for me.

    thx

     

     

    I have the same problem.  Quickest fix is to execute the Terminal command "killall Dock".

  • AndreGB Level 1 (5 points)

    This has apprently solved for me too. Thanks a lot!

  • M.Stella Level 1 (0 points)

    I tried what you suggested, but unfortunately the problem is only solved temporarely. The problem comes back again.

    Has anybody found a permanent fix?

  • fab@colmar Level 1 (0 points)

    So it's not a permanent fix but try this.

    open AplleScript :

    copy and paste :

     

    do shell script "killall Dock"

     

    and register as a application, without options.

     

    And paste this new application in the "open" option in the users "system pref", with the "hide" option check.

    Voilà, it's not a permanent fix. but an automatique fix... it's quite the same

    ;-)

  • Tomn94 Level 1 (0 points)

    @ peggert :

    Destructive solution but it's the solution.

    Thanks !

  • peggert Level 1 (0 points)

    I found out that my suggestion only solved the problem temporary for me, too. But after the supplementary update from Apple for 10.8.2 this weekend, it looks like it is solved for me durable.

     

    What is your experience?

  • zantafio Level 1 (0 points)

    This solved it for me :

     

    move dock to the left (or right) then back at bottom, transparency is  gone.

     

    I have loggged off and back in, it seems to stick!

  • Smods Level 1 (0 points)

    I have been trying to get Dock Transparent since Lion, I think it's much more apealing.!!

  • hogga Level 1 (0 points)

    Hi,

     

    same problem - mountain lion 10.8.2

    sometimes i switched between my 2 user accounts, the dock is transparent.

    switch back to the user bevor and another switch back and all is good.

     

    i mean the user profile isn't correctly load.

    wen the dock is transparent, e.g. it is not possible to change the desktop background.

     

    so i think it's not a problem with the dock himself, ist a problem with the user account data.

  • Tomn94 Level 1 (0 points)

    Hi,

     

    This guide might help a little:
    http://www.macg.co/news/voir/258549/si-votre-dock-plante-regulierement-sous-moun tain-lion

    Yeah, it's in French.

     

    To sum up, this issue happens when the icons of the Dock are rendered. Preferences or caches cause this problem.

    So you can use Onyx (be careful), Clean tab › User, and check cleaning Dock icons.

    If it's still not working, maybe this issue is due to font and not only icons.

    Open Font Book app (in Applications folder). Look for Lucida Grande and remove all duplicates (FileDelete). You can even validate the remaining font (FileValidate font).

     

    Well that's what MacG.co explains. Hope this will work!

  • hogga Level 1 (0 points)

    Hi peggert,

     

    this solved it for me.

    I think it's just the only way to remove the old com.apple.dock.plist file and let lion create a new one.

     

    Thanks.

     

    @TOMN94

     

    Sorry, onyx doesn't work, so i tried the tip of peggert and it worked.

  • hogga Level 1 (0 points)

    The Problem is still coming back.

    I Think to remove the com.apple.dock.plist file work, but it doesn't.