10 Replies Latest reply: Nov 16, 2012 4:22 PM by juangrande62
TheBrownEye Level 1 Level 1

I have a MBP 2010 13 inch model and have tried to upgrade the ram from 4gb to 8gb with 3 different brands of ram (pny, corsair, crucial). Non of these work. I have checked all the specifactions, and all are an exact match to what is compatible with my MBP. Even the Geek Squad guys were dumbfounded when all three failed. with the new ram sticks installed, the MBP will not boot up at all. Does anyone have this same problem? any solutions you may recommend? The funny thing is when I upgraded with this exact same 8gb ram into my mac mini it worked flawlessly.


MacBook Pro, Mac OS X (10.7.4)
  • ds store Level 7 Level 7

    You likely have a bad RAM slot, take the machine in for a logicboard replacement at Apple, show the reciepts you tried different RAM etc and they will test it too.

     

    Hopefully your still under AppleCare. If not, then your stuck on whatever RAM you can place in the machine.

  • Bimmer 7 Series Level 6 Level 6

    does your macbook work with your original RAM installed?

     

    if so, then you're installing the wrong speed RAM.

     

    your Macbook requires 1066MHz DDR3.  there are times when 1333MHz might work but I advise against it.

     

    if however, your own original RAM doesn't work with your Macbook when you put it back in, then I have to agree with ds store that your RAM slot is faulty...

     

    good luck - hope you get it sorted out.

  • TheBrownEye Level 1 Level 1

    original ram works perfect, aftermarket rams are 1066MHz DDR3. I have tried combonations of one orignal and one aftermarket and computer boots up fine and even registers that it is running on 6gb of ram. i even switched the slots and still boots up fine. when i put both aftermarket rams in it wont boot up at all. I reset the PRAM but to no avail it does not work. Any other suggestions?

  • halfapie Level 2 Level 2

    It's strange, the issue sounds just like the problems from the 2008 macbook pro's.

     

    http://blog.macsales.com/9102-secret-firmware-lets-late-08-macbooks-use-8gb

     

    Have you applied all EFI updates? Couldn't hurt...

    http://support.apple.com/kb/HT1237

  • Shootist007 Level 6 Level 6

    Did you buy the Crucial RAM directly from Crucial.com after using there memory finder for your model Mac.

     

    Or was this some Value RAM with a crucial sticker on it you bought from local or other online retailer?

  • Shootist007 Level 6 Level 6

    What CPU is in your 2010 MBP? Core 2 Duo or "i" series?

     

    EDIT:

     

    Doesn't matter as both use 1066Mhz RAM.

     

    Message was edited by: Shootist007

  • Bimmer 7 Series Level 6 Level 6

    try this....

     

    have a look at your original RAM - I think yours is CL7......Shouldn't really make a difference......

     

    now, have a look at the RAM you're trying to install, if they're above CL7, like CL8 or CL9, then you should be fine...

     

    however, if the one's you're installing is CL6 or lower, then chances are it won't work.....

     

    ran into this issue with some late 08 Macbooks but it shouldn't matter with yours....

     

    good luck...

  • Widerbarrel Level 1 Level 1

    Hi there,

     

    I have a 2010 Macbook Pro 15, Macs are picky about ram.... tried a couple brands like kinston and the machine won't boot..... tried G.Skill ram and it works, also very cheap..... under 50$ for both 4Gb sticks..... I got them from Newegg I think. Just search for the specs of memory your computer requires and get it. Good luck.

  • Moses Kasuva Level 1 Level 1

    Get yourself a new RAM from OWC. They are specialist for mac products. I  have never been dissapointed with OWC.

  • juangrande62 Level 1 Level 1

    I'm having the same problem with my MB (unibody late 2010- white). I bought Crucial from amazon. Both cards work seperately or with original 1g (in all configurations). Together it only registers 4g. Did you solve your problem? Max I can get is 5g.