Previous 1 2 3 4 5 Next 70 Replies Latest reply: Oct 10, 2012 1:21 PM by movery Go to original post
  • @rnopier Level 1 Level 1 (0 points)

    Are you sure you try to open the "old" one, on my window i see the same name for each library. Put your mouse on each and his content display.

  • Sanjaya Kumar Level 1 Level 1 (10 points)

    OK, here's what worked:

     

    I redownloaded the Aperture 3.3.2 update and re-installed it, and now Aperture is able to open my library!

     

    I should have thought of this before. I had the same problem a couple of months ago and the same solution.

  • léonie Level 9 Level 9 (79,540 points)

    Philipp,

    So, I know the problem must be in the main library, but I can't figure out why it will launch successfully only after opening a different library.

     

    I repaired permissions and rebuilt and repaired the database, but none of these seemed to fix the problem I'm having.

     

     

    The one thing I can think off, that Aperture read only from the first library that you open on start-up, but not from the second library, are the keyword button sets and keywords, afaik.

     

    Have you defined button sets? Then it might be worth a try to remove the "keywordSets.plist" file from your Aperture Library package to the Desktop, after quitting Aperture and log-off/log-on again.  You will have to redefine your button sets however, after doing this.

     

    Léonie

  • Phillip Breske Level 1 Level 1 (75 points)

    Hmm. I can only say that what I have tried has worked for me.

     

    Have you already tried all the database fixes (repair permissions/repair database/rebuild database)?

     

    Never mind. I see you've found a fix. Great!


  • langutah Level 1 Level 1 (0 points)

    Same problem. Aperture no longer opens after 3.3.2 update. Library issues. For me, downloading and reinstalling the 3.3.2 update did not work either.  I restored from the vault and now am good to go.

  • langutah Level 1 Level 1 (0 points)

    Another update. My vault version was a couple of weeks ago, missing some imported stuff. So I restored a version, using time machine from a few hours from my bogus update.  That worked better.

  • giordajl Level 1 Level 1 (0 points)

    I'm unfortunately dealing with this same problem.

     

    I can use Phillips work around to open my Aperture Library, but I'm worried that something isn't quite right. So I don't want to just ignore it and move forward.

     

    However, I've tried all of the following thus far with no success:

     

    1. Deleted all Previews

    2. Updated all Previews

    3. All basic troubleshooting (repair, rebuild etc.)

     

    I've got a SuperDuper backup of my drive from a week ago, but don't want to give up that week worth of work.

     

    Any suggestions from the experts out there? Thanks.

     

    I just upgraded to 3.3.2, Aperture upgraded my library, I did a few hours worth of work. Closed Aperture for the night. Came back the next morning, and Aperture would hang on opening.

  • Phillip Breske Level 1 Level 1 (75 points)

    I don't know if I was clear on this before, but here's what I've been doing for the past few days:

     

    1. Launch Aperture while holding down the Option key. This opens the library picker window.

     

    2. Select the previously created "alternate" library. Click Choose to launch the application. (You may see a MobileMe advisory window before the app launches—I just use the Switch to Library button in this window and this negates the next step.)

     

    3. Once the application is open, I use the File > Switch to Library... menu command to choose the main library and switch to it.

     

    This has worked every time so far, but it's still a workaround. I received an email from David at Apple asking some questions about my library and whether I was still having the same issue. I was unwilling to send a copy of my entire library (they were going to send me a hard drive to effect the shipment), but I did provide a copy of my system report. At least we know someone at Apple is working on a fix.

     

    What my workaround tells me is that Aperture will not launch completely if it even attempts to open my main library before I tell it to pick the alternate library. If I use the Option key at launch and tell Aperture to use the alternate before it looks for the main, it opens fine, but once Aperture has made an attempt to open that corrupted main library, it won't work again before I quit and re-launch, even if I point it to the alternate after the first failed attempt.

     

    What irks me is that it does eventually launch and run just fine—I have yet to discover any corrupted photos or videos in the library. Grrrr.

  • AlexBrown Level 1 Level 1 (0 points)
  • giordajl Level 1 Level 1 (0 points)

    Alex,

     

    Thanks for the suggestion. I will give it a try. Now that you mention it, I do recall clicking on Sort by Date and seeing nothing happen in Aperture.

     

    But was this also causing the same problem for you in that Aperture would hang when opening?

     

    Thanks!

  • giordajl Level 1 Level 1 (0 points)

    Phillip,

     

    Can you please ask David at Apple to reach out to me?

     

    I'd be happy to send him my library if it will help us all with a permanent and stable solution.

     

    I'm at jgiordani AT gmail.com

     

    Thanks!

  • Phillip Breske Level 1 Level 1 (75 points)

    I will send him your email.

  • AlexBrown Level 1 Level 1 (0 points)

    Yes, this causes launch problems too.  I have submitted a bug to apple including a library with just one photo in that demonstrates the problem (bug 12034892).

     

    -Alex

  • Netrag Level 1 Level 1 (25 points)

    this happened to me tonight, i was able to fix it by opening the library with iphoto 11.  after closing iphoto 11 it opened properly in aperture

  • giordajl Level 1 Level 1 (0 points)

    Thanks! That did the trick for me too!

     

    I had tried that with my iPhoto library before, but not with my Aperture library.

     

    This did the trick! Nice.