Previous 1 2 3 4 5 Next 70 Replies Latest reply: Oct 10, 2012 1:21 PM by movery Go to original post
  • movery Level 1 Level 1

    I have exactly the same issue with my Aperture library.  Am running the latest version of Aperture on the latest version of Mountain Lion on a brand new MacBook Pro Retina.  Have tried all the first aid options and restoring from TM backup but no joy.


    Going to try tonight the workaround of opening a new library first then opening the "main" library and see if that works.  Really sounds like an Aperture bug that I hope Apple fix very soon!!!  Dreading losing my life's photos....

  • movery Level 1 Level 1

    OK, the solution of opening a new library then opening the library that has photos imported from iPhoto also works for me. 


    Thanks for the workaround!!!  Now we just need a proper fix from Apple....

  • @rnopier Level 1 Level 1

    Unfortunately when the library is too big it's impossible to open it by iPhoto !

    What idea to want open the same library with these two very different softs !

    And a power cut during a process of backup corrupt this library ! Now I try co repair and it's hours and hours !

    Take care, small libraries are better than a big one.

    Apple do something plz

  • SierraDragon Level 4 Level 4

    @rnopier wrote:


    Take care, small libraries are better than a big one.

    I do not use iPhoto so I cannot comment on that.


    However, multiple Libraries are a very bad idea because they defeat a major purpose of having an images database, the ability to search and keyword among all images.


    Aperture can handle hundreds of thousands of image files in a single Library as long as folks back up before import into Aperture and reference originals on external drives. Using the managed-originals approach with originals in the Library is seldom appropriate.



  • konnektor Level 1 Level 1

    i have the same issue, and the new library workaround worked. for now at least...

  • @rnopier Level 1 Level 1

    I aggree with you dear SierraDragon but now I have a problem with my 360 000 photos library and Aperture try to repair it for two days becausen here in Egypt we have power cut and ...

    Small libraries, one in each subject feel better because on my laptop I have a copy of the most important projects and it's safer not the best I aggree but safe. Sure all the files are on external HD.

  • @rnopier Level 1 Level 1

    I don't know why but after all the desasters described above and more than 26 hours of "Rebuild library" without power cut !

    The window of the "corrupt" library appear !

    And the multicolor wheel more than half hour.

    I decide to restart, Aperture and iMac.

    When I want restart Aperture with "option key" this librairy appear in the menu without any count of pictures or projects !

    I start with the empty one and request to switch one the big one, nothing happen !

    I force to quit and restart and ... it's the big one who open immediatly !!! I don't know why but it's !

    My library is now 204 projects and 335 506 photos, that feel less than before but I'm not worried of that because all the pictures are on external hd.

    Hope that continue ...

  • DGroce Level 1 Level 1

    You saved my Aperture library--it wouldn't open until I saw your workaround.  Thanks.

  • Reflective Turtle Level 1 Level 1



    Was having the exact same problems and ran through the same work arounds as posted here. Jumped over to

    Alex's post: Aperture 3.3.2 unresponsive if library contains old iPhoto albums - solution (it's on page 2 of this thread) and the process outlined worked for me.


    If you select, from the Library tab of the inspector pane (the gear menu at the top of the pane), "Keep Projects and Albums Arraged by:->Date" and nothing happens, the library has the bug.


    For me, picking "Keep sorted by date" triggered the bug and locked the library into the hang loop described here. Once I killed the offending albums, I could sort and resort the library any way I wanted and it worked. Could quit Aperture and it would reopen the library just fine.

  • damongold Level 1 Level 1

    I did the same. Changed sort date and the crash happened. The work around is working. Waiting for a fix Apple.

  • Tony Podbevsek Level 1 Level 1

    Well I have been able to use thw work around which I found before this discussion thread.  One thing I ntoiced in the last week it that I has a few "RECOVERED" folders.  Nothing in them and nothing to do with them.   I really like the older interface as well.  Did anyone download the midtone pathc to get back some of the slider adjustment bars?   I had put that in before the upgrade but wanted in interest of full disclosure ask.  Has everyone a library size above lets say 20,000 photos?   My library right now is sitting at 26K.

  • Tony Podbevsek Level 1 Level 1

    One other issue I can't use itunes to read the library either to export the photos.  So Much for using a retina display for a portfolio.   Now moving photos over on a SD card is the way to go.

  • LDB71 Level 1 Level 1

    I was experiencing this exact same issue after a reinstall of Lion 10.7.4.  Thought I'd try the reinstall Aperture 3.3.2 route to see if that solved my problem, and took a quick look at the reviews on it...  Thanks Ian Abbott for this tip which solved the issue!


    Mobile Me is now defunct.  You need to go to your System Preferences, select MobileMe and sign out of your account.  Aperture now opens straight away.


    Problem solved.  You'd think in a new release of software Apple would be aware of this issue...


    Hope this helps everyone.

  • Glenn Cogar Level 1 Level 1

    Hi all,


    I just wanted to add that I was having the same problem, could not launch Aperture, would hang on launch.  Tried just about all of the suggestions.


    The one that seemed to work for me was going to the System Preferences and logging out of MobileMe.


    I am a new user of Aperture and did not have an existing library.  Im making the shift from iPhoto.


    The system dumps caused when I had to force quit Aperture each time it hung seemed to indicate a loop, like it was waiting for something that never happened.  The first part of the dump seemed to indicate that it was attempting some sort of logon.


    When I read about the need to sign out of MobileMe I thought that maybe this was what it was trying to do.


    I started using iCloud some time ago and never thought I had to explicitly log out from MobileMe but when I did and re launched Aperture it started immediately! No more spinning beach ball


    The Mac I am running Aperture on is still running Lion (10.7.4) and so I guess MobileMe is still a hang over.  My Macbook Pro runs Mountain Lion and so MobileMe is no longer a feature and it runs Aperture without a problem.


    Maybe this will help others too that have tried other suggestions.

  • Phillip Breske Level 1 Level 1

    The new version of Aperture (v3.4) is out and this issue appears to have been fixed. My copy now launches without hanging. I hope everyone else is able to upgrade and enjoy the application again.