Previous 1 11 12 13 14 15 Next 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock Go to original post Branched to a new discussion.
  • dendyland Level 1 (0 points)

    I have the problem when I was sent an email that contained an email address and I wanted to click on that email address to create a new email. If I click on the email address from within the preview window, then the From address is correct. If however I open the original email, and then click on the address it gets it wrong and uses the first email address in my list. It's like once you open an email it loses the context of where it was opened from.

  • Scotteth Level 1 (15 points)

    Have you tried adding all the "From" addresses you need to use to the "Email Address" field your default account?




    1. Open Mail's preferences

    2. Go to "Accounts"

    3. Select your default account and select "Account Information"

    4. In the "Email Address" field add all the "From" addresses you need, separated by a comma (ie,,  Put preferred address first (ie The one to use when creating a brand new email that is not a "reply")


    I don't have a system I can try this on, but I'd be interested to know if this works.

  • sfare Level 1 (0 points)

    Interesting idea. I just tried it, and it doesn't work. Also of note, the recent (yesterday) update to OSX 10.8.2 does not fix this bug either.

  • DWFaust Level 1 (25 points)

    Since Apple has still not seen fit to fix this bug, I have discovered a workaround ... to create a keyboard shortcut to set the FROM address in the Mail app...


    Click on "Application Shortcuts" on the left and look for the + icon at the bottom center. Click on this + and select "Mail" from the Application menu. Type in your email address (don't forgetting the formatting shown above) into the Menu Title and enter your Keyboard Shortcut combo. The keyboard combo should be easy to remember and ideally related to your email account. You can click Add when you are done.

  • Kawanaut Level 1 (50 points)



    I assume that means you have to do that keyboard shortcut on every single mail you reply? Or at least you have to verify the "from" address on every reply you write, to make sure "from" is correct?


    I don't understand why Apple hasn't fixed this yet. It makes no freakin' sense to destroy it in the first place.

  • thomjet752 Level 1 (0 points)

    Same here since downloading recent update. I can receive gmail, but cannot SEND through the gmail server in my MAIL account!


  • phineas8 Level 1 (0 points)

    I give up on Apple (which usually seems to espouse my-way-or-the-highway). I'm switching to Outlook,

  • sfare Level 1 (0 points)

    I took a stab at improving the applescript/Automator based workaround to this. My improvement is added as a comment to nder-bug but also included below in verbatim for convenience and reference.


    Since I really needed to fix this (the bug is driving me insane…), I took a stab at your wishlist and also fixed some other annoyances (sometimes your original script included the body of the original message twice for some weird reason).

    There is still one really annoying behavior; “selection” only picks the first message in a thread even though another message is selected. I can’t figure out how to fix this, but the manual fix is to double click the message so that it comes up in a separate window, then the script works ok.

    So, after a lot of hacking, I came up with the script below (to be used from Automator). I then use system preferences to bind this script to Cmd-R (add it to “Application Shortcuts” for “” in “Keyboard” -> “Keyboard Shortcuts”.

    Note that to get “Reply All” behavior, you replace
       set theReply to reply selectedMessage
       set theReply to reply selectedMessage with reply to all
    I created a copy of the script for this and mapped it to Shift-Cmd-R

    Here is the script:

    on run
         tell application "Mail"
              set theSelection to selection
              if ((count of theSelection) > 0) then
                   set selectedMessage to item 1 of theSelection
                   set addresses to address of every recipient of selectedMessage
                   set sentTo to ""
                   repeat with selectedAccount in accounts
                        set accountemails to email addresses of selectedAccount
                        repeat with accountemail in accountemails
                             if addresses contains accountemail then
                                  set sentTo to full name of selectedAccount & " <" & accountemail & ">"
                                  exit repeat
                             end if
                        end repeat
                   end repeat
                   set theReply to reply selectedMessage
                   tell theReply to set sender to sentTo
                   tell theReply to set visible to true
                   display dialog ("Select a message before running this script.")
              end if
         end tell
    end run
  • DWFaust Level 1 (25 points)

    Kawanaut wrote:




    I assume that means you have to do that keyboard shortcut on every single mail you reply? Or at least you have to verify the "from" address on every reply you write, to make sure "from" is correct?


    I don't understand why Apple hasn't fixed this yet. It makes no freakin' sense to destroy it in the first place.


    Yes... and it's annoying that Apple hasn't yet fixed it... considering switching to Outlook (yuck) for my email client...

  • ShsAz Level 1 (0 points)

    I have a friend who does not have this probem with his IMAP account.  His "Email Address" field in settings has many comma-delimited addresses.


    I have the same problem described in this thread, but I use a POP3 account.


    Are any of you having this problem with IMAP, or just with POP3?  (Just curious if that's part of the problem... and perhaps why Apple can't reproduce it.)

  • Scotteth Level 1 (15 points)

    That explains a lot. I've recently installed Mountain Lion, tested it and had no problem and couldn't understand why.


    All my accounts are IMAP.


    Thanks ShsAz

  • Canadian in Malta Level 1 (0 points)

    Kudos for doing all that Stefan but I've never used Automator before and I'm not sure which are the parts that need replacing and how to duplicate the sections that would be required for each separate e-mail address.


    I have e-mails dating back to 2003 in Mail. I can't imagine what a nightmare it would be to switch to Thunderbird for example but after sending command-shift-d from the wrong account again this morning, I think it's either your script, Thunderbird or saving every reply as a draft, then double-checking the "from" address and THEN sending them all.


    Now I'm going to go figure out how to explain this morning's faux pas to its recipient.


    What really annoys me is that I bet most of us have been Apple users since way back when we had to have an intermediary step just to communicate with the Windows world at all. Now that Apple has more money than God you would think it could at least keep the basics working.

  • sfare Level 1 (0 points)

    Good point. Automator and application bindings are not self evident. It's pretty simple though and here is the exact procedure:


    Launch Automator (available in Applications)

    File -> New

    Select "Service" -> Click "Choose"

    Blank window appears

    In the left hand Column double-click on "Library" -> "Utilities" -> "Run Applescript"

    Replace all text with my script

    Click "Hammer" (which compiles and checks the script)

    In the panel above:

       Service receives "no input"

       in ""

    File -> Save

       Save service as: "Mail - Reply to specific"

    Exit Automator



    Apple menu -> System Preferences

    Keyboard -> Keyboard Shortcuts -> Application Shortcuts

    Click "+"

    In the panel that appears:

       Application: ""

       Menu Title: "Mail - Reply to specific"

       Keyboard Shortcut: Hit "Cmd-R"



    You're done!

  • sfare Level 1 (0 points)

    Just to clarify: this new version of the script shouldn't be modified in any way. It picks up all your account settings and email addresses automatically.

  • Andy Lawniczak Level 1 (0 points)

    The problems seem to be in POP3.  HOWEVER, several others say they don't have the problem, but they are not re-creating it properly.  If emails come in and sit in the original inboxes, there is no problem, they reply from the proper account.  IF they are MOVED in any way (usually due to a rule that is set up), and replied to from a different folder, then they seem to use the default email address, or the first email address in your list of inboxes. 


    Adding multiple email addresses to each account like described by some did nothing for me either.

Previous 1 11 12 13 14 15 Next