Skip navigation

Mail bug in Mountain Lion

95258 Views 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock RSS Branched to a new discussion.
  • iacas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 5:47 AM (in response to sfare)

    I just used the raw AppleScript in combination with FastScripts, which let me set the normal keyboard shortcuts (cmd-R, shift-cmd-R) and it's been working well.

     

    I almost never use the toolbar buttons to reply, and NEVER use the menu items, so it's okay.

     

    Still hoping Apple fixes this SOON, but with my current solution, I'm not sure I'll notice if they do.

  • Canadian in Malta Calculating status...
    Currently Being Moderated
    Oct 12, 2012 6:20 AM (in response to sfare)

    When I tried the sfare fix the first time I used the techpatio.com (http://techpatio.com/2012/guides-how-to/mountain-lion-mail-default-from-field-se nder-bug) automator script and I got an error and then it wouldn't work in mail. I went back into Automator and used the script from this discussion and it works perfectly.

     

    Can I buy you a beer Stefan?

  • ShsAz Calculating status...
    Currently Being Moderated
    Oct 12, 2012 8:25 AM (in response to sfare)

    The AppleScript is brilliant.  Thank you to all the contributors that pulled it off.

     

    The only issue I have is with the reply-all modifcation of the script... it includes my address in the "Cc" field, whereas "Command-Shift-R" does not. 

     

    Any ideas? 

     

    (I ended up creating a DragThing toolbar and then having DragThing assign key combos to the script.  For some reason I can never get System Settings to assign command-keys to stuff in Mail.app.)

  • phineas8 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 8:42 AM (in response to ShsAz)

    All along this has been my main symptom of the problem. Automatic CCing of the sender has been very little mentioned in this thread, but it is discussed in detail in others. Even though I use lots of accounts the way I manage them doesn't get me into the trouble that others get into. My main complaint has been that my own email address has been CCed on every message that I send out from Apple Mail since 10.8. For background, because my IT department archives all messages on the exchange server after 30 days, I move all of my mail out of the main exchange inbox to an inbox "On My Computer." Because of the way accounts are handled in this newer version of Apple Mail, the messages lose their identity. CCing "the sender," when I'm forcing the same email address as the exchange inbox, is Apple's stupid way of coping with the change of inbox. It's almost as if Apple Mail is trying to protect the receiver from spoofed mail. The whole thing is preposterous. And I believe it to be all because Apple wants to make OS X Mail work similarly to iOS Mail -- in other words, more separated account by account. That would make Apple Mail far simpler, but it would also give it a functional lobotomy.

  • Brian Dear Calculating status...
    Currently Being Moderated
    Oct 12, 2012 12:56 PM (in response to sfare)

    I just recently installed Mountain Lion and have been running into this bug CONSTANTLY.  I toggle between a handful of different email addresses for various different projects all within the same Mail.app -- have done it this way for years.  And with Mountain Lion, suddenly whenever I reply to a message, it sets the From to the default account, NOT the "Send new messages from: Account of selected mailbox".  That's how I have the setting in Composing Preferences.

     

    Apple: this is a real annoying bug that not only affects my productivity, it screws up things on the recipients end; they may not recognize the other email address if I have been corresponding with them for months or years with, say, abc@def.com and suddenly they see a reply from abc@ghi.com.

     

    Please fix.  You have enough money in the bank to task an engineer with this.  Get on it, please. Thank you.

  • CMathis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 1:23 PM (in response to Brian Dear)

    And with Mountain Lion, suddenly whenever I reply to a message, it sets the From to the default account, NOT the "Send new messages from: Account of selected mailbox".  That's how I have the setting in Composing Preferences.

     

    You've describe the problem very well. People are talking about a lot of different things in this thread, but you nailed it.

  • Lord Percy Calculating status...
    Currently Being Moderated
    Oct 13, 2012 1:33 AM (in response to markmal)

    Was having exactly the same problem. After playing around a bit, I have certainly fixed the problem I was having, so hopefully this will work for you too.

     

    I have two mail accounts, number1@sky.com and number2@sky.com. Both are gmail type accounts. In the left hand navigation pane in Mail, you can see the inboxes for number1 and number2.  I would go into the inbox for number2, and send a new message. The from field would say it was going to be sent from number2@sky.com.  I sent messages to my work address so i could pick them up straight away and check.  When they arrived, they would be sent from the name of the person associated with number2@sky.com, but the reply address would be number1@sky.com.  Very annoying.

     

    Anyway, the fix that worked for me:

     

    Go into the inbox of the mail account you want to send mail from.

    Compose a new message

    Next to the "From" field, I have two dropdown boxes. The first is the person (profile) you want to send from, the second in the outgoing SMTP profile that will be used to send it (this is the important bit).

    Click on the dropdown arrow on the second, and choose "Edit SMTP Server List".

    Now, on mine there were two profiles, both with the "Description" field named Sky. I noticed in the "In Use By Account" field showed both Number1 and Number2 were using the same SMTP profile. Clicking on "Advanced" for the profile they were both using showed that was the SMTP profile for number1@sky.com.  This is why both were sending using these details.  So, it's necessary to assign the correct SMTP profile to the correct Account profile.

    I changed the names of SMTP profile by clicking on each in turn and calling one Number1 Sky and the other Number2 Sky. This helps tell one apart from the other later.

    Ensure in the advanced tab under both, they have the correct username and password.  So, the SMTP profile for Number1 Sky should have the SMTP uername and password for number1@sky.com, and the SMTP profile for Number2 Sky should have the SMTP username and password for number2@sky.com.

    It may ask you to save the changes when you click OK

    Then, in the Mail > Preferences > Accounts window, click on the first profile.  For me, this was Number1.  Under account information, there is a field called "Outgoing Mail Server". Set this to the one you have named to relate to profile Number1. For me, this was the one I called Number1Sky.

    Then click on the next mail account, and do the same, only this time set the "Outgoing Mail Server" to the SMTP profile you named for Number2.

    Repeat for all other profiles.

    Save the changes when clicking OK.

     

    When you compose a new message, you will see more obviously in the two dropdown boxes next to the From field that the mail is coming from Number1 using Number1's SMTP profile, or From Number2 using Number2's SMTP profile.

     

    Now when I send mail, they come from the correct account, and the reply address is correct.

     

      Hope this helps.

    OS X Mountain Lion (10.8.2)
  • Ernie Stamper Level 8 Level 8 (37,415 points)
    Currently Being Moderated
    Oct 13, 2012 2:52 AM (in response to Lord Percy)

    An excellent write up of how to correct a long known problem that was not introduced by Mountain Lion, but found in all earlier versions of OSX.  However, it is not the issue that brought forth this thread.

     

    Ernie

  • CMathis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2012 7:09 AM (in response to Lord Percy)

    Lord,

     

    What you describe is not the issue.

     

    Please see Brian Dears post above for the bug we're discussing.

  • Canadian in Malta Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2012 7:35 AM (in response to CMathis)

    Sounds like a prayer when it begins with Lord, ...
    Anyway, the sfares solution works! Nice to have a blessing to count.

  • jesmith Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 15, 2012 10:18 AM (in response to sfare)

    sfare's solution seemed like a nice work-around, but I found that:

     

    1. It doesn't work consistently. Perhaps there is a tug-of-war for what will handle the ⌘-R?

     

    2. I find that I often select some text, then hit ⌘-R to reply just quoting what I selected. That doesn't happen, obviously, with this script.

     

    So I've stopped using it, and I'm back to manually setting my from address. The good news is that Apple is taking so @#$%^&* long to fix this bug that I'm starting to get trained to check it.

  • infobleep Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 15, 2012 12:25 PM (in response to markmal)

    I didn't like Mail before this bug. Now I like it even less. I was only thinking this evening how great Mountain Lion is for it's lack of bugs affecting me...... I thought too soon.

     

    I am considering moving to Thunderbird. The problem with Outook is the lack of advanced mail rules. Thunderbird is doesn't have advanced rules but it does have a rule which includes to; from; cc and bcc in the same rule, so I maybe able to use Thunderbird for my needs. There is also a regular expression add on for mail rules but I don't understand regular expressions well enough to use it. They look easy until you attempt to create one, as I tired to do in the past for another project.

     

    I considered Mulberry but it hasn't been updted in 5 years and I don't want to migrate to something that isn't so well supported.

  • kathithewingspouse Calculating status...
    Currently Being Moderated
    Oct 17, 2012 12:12 PM (in response to markmal)

    I was hoping I would find a solution if I went to the most recent post. I'm having the same problem. Hope this bug gets fixed soon!

  • Andy Lawniczak Calculating status...
    Currently Being Moderated
    Oct 17, 2012 12:15 PM (in response to kathithewingspouse)

    I'm seriously starting to think that this is somehow "working as intended" by the way they are not addressing the issue.  I can't understand why.  Sometime's Apple's ways of doing things don't make sense, but in the end you thank them for it...  I just don't see the "benefit" of this.  Anyone have any ways they might have wanted it to work this way?

  • jesmith Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 17, 2012 12:57 PM (in response to Andy Lawniczak)

    The bug I filed was closed as a duplicate. The duplicate is still "OPEN". If Apple thought this was "working as intended" then they would have changed that bug to "CLOSED." Therefore, it is a good bet that Apple does consider this a bug, but they just haven't fixed it yet.

     

    Apple never comments on bugs, so their silence is non-informative. The fact that it is taking so long to fix either means they have not assigned resources to it (perhaps all the developers are working as part-time cartographers right now), or that the bug is actually hard to fix for some reason.

1 ... 12 13 14 15 16 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (22)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.