Previous 1 4 5 6 7 8 Next 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock Go to original post Branched to a new discussion.
  • jevlewt Level 1 Level 1 (0 points)

    Tidbits has published an article on the problem.

     

    http://tidbits.com/article/13189

     

    Lots of Mountail Lion Mail consternation in the article and in its comments. This definitely needs a fix!

  • ADub128 Level 1 Level 1 (0 points)

    Thanks for linking to that article, @jevlewt. I've run into the same problems with email replies. I have multiple email accounts that I use, and it's difficult to isolate the various buggy scenarios.

     

    I have some workarounds, but ultimately I need to be very careful about the From field and corresponding associated signatures. #PITA.

  • Raptor4 Level 1 Level 1 (0 points)

    I recently upgraded from Snow Leopard to Mountain Lion on a 2.4 core duo iMac with 4GB of RAM. Accordingly in the transition, and/or shortly after the first two messages were sent using the mail app, to a contact imported from my gmail account, I experienced an issue where the mail account was sending multiple incomplete emails to this contact, before I had finished writing same.

     

    Subsequently in reviewing my message using Mountain Lion mail, I noted that the mail app had continued to send multiple versions of my message to this contact [up to 30 times], even though I had only sent 'one' email to this person. This issue was confirmed in my list of sent messages on gmail when I logged in directly, to my dismay! 

     

    This is despite the fact that I have deleted, and revised the connection to gmail from one gmail account to another, with the approach that that I now use one gmail account as an inbox, and the other account as outbox. While other users may question this approach, unfortunately my spam folder in gmail receives up to 20+ attempted 'hacks' every day, where I have begun to identify key stroke, or malware attachments from info contained in the subject line. When this occurs, I just try to filter, and delete these approaches, without opening the message in any way.

     

    Subsequently I have disabled the Mountain Lion mail, because this situation is not professional, and causes problems for my correspondence with people in my daily interactions. Can anyone explain what is happening?

  • Robert Silverstein Level 1 Level 1 (0 points)

    Same issue here, and I put in the "me too" bug report. In the mean time, here's my workaround:

    I created the applescript below, saved it as a compiled script, and assigned the keyboard shortcut command-option-R to it using the app "Spark" so I can call it from the keyboard while within Mail. Note that you have to select the message in the column view, not the viewer window, for this to work (if you have more than 1 message in the conversation, you have to click the disclosure triangle to drop down the list of each message in the conversation, and then select the specific one that you want to reply to. This doesn't select an actual account in the "From:" drop down menu of the message you are replying to; but it does address it to the original send to account. This was the best I could come up with.

     

    property sentTo : ""

    property theResult : ""

    tell application "Mail"

      activate

              set theSelection to selection

              if ((count of theSelection) = 1) then

                        tell item 1 of theSelection

                                  set sentTo to (address of recipient 1 of item 1)

                                  set messageID to id of item 1

                                  set theResult to (reply item 1 with opening window)

                                  set sender of theResult to sentTo

                        end tell

              else

                        display dialog ("Select a message before running this script.")

              end if

    end tell

     


  • Jerome Krinock Level 1 Level 1 (15 points)

    Step back out of the trees and tell us about the forest, Robert.

     

    I think you mean that, with this script installed in Spark, you use ⌘⎇R instead of ⌘R when you want to reply to a message.  Correct?

  • Robert Silverstein Level 1 Level 1 (0 points)

    Yes. Download and install Spark from here (http://www.shadowlab.org/softwares/spark.php). Paste my code into Applescript and save it as a compiled script wherever you want on your hard drive. Launch Spark.

    It's not that intuitive, but here's how you install the script for Mail:

    Click on the All Applications's HotKeys button at the top of the window (the author's English isn't perfect...). A drawer will slide out. Click on the plus at the bottom of the window. Navigate to your Applications folder and select Mail. The button at the top of the window will change to "Mail's HotKeys." Double Click on "Applescript" in the left pane under HotKey Groups. Click in the Shortcut text box and type ⌘⎇R. Give it whatever name you want in the box under that. Click on the File button (to the right of the Source button below the Name text field. Navigate to the compiled applescript that you saved above. Click on the create button. You can quit Spark now.

    Re-launch Mail. Select an email that you want to reply to (in the list, not by clicking on the message viewer window. Type ⌘⎇R.

     

    Or, you could also just install the script menu, and run it from there...

     

    No need to insult someone who is trying to be helpful. I could have just kept my solution to myself. If anyone has any other questions and I can help further, I'll try to do so.

  • sfare Level 1 Level 1 (0 points)

    As an FYI this bug has not been fixed in the just-released 10.8.1 OS upgrade.

  • Jason C Level 1 Level 1 (15 points)

    I am also experiencing the same problem. But mine didn't start until the system crashed earlier today while using Mail. I upgraded to Mountian Lion about 10 days ago. No problem with Mail until after today's crash. Now all replying adddress default to the first email account in the Inbox. Also, Mail had somehow forgotten several SMTP account passwords, but not all of them.

  • dtpearson Level 1 Level 1 (0 points)

    I'm not sure if this is a fix for everyone, but it was for my problem, just drag the inbox wanted as the default "send" account to the top of the list of inboxes down the left hand side of the mail program.

     

    This means that any "New Message" will default to be sent from that account.

  • jevlewt Level 1 Level 1 (0 points)

    I don't know that setting a default "send from" account for new messages is part of the problem for some or any people here; if it is, that may help.

     

    Rather, I believe that Mail sending messages from such a default account, not from the account that received the message, is the problem for many. Still no fix for that, or even a clue from Apple as to whether that's a bug, or (for some inexplicable reason) an intentional ML change, or what's up.

  • waynefromvirginia beach Level 1 Level 1 (0 points)

    Edit: Misread original post.

  • etresoft Level 7 Level 7 (25,885 points)

    There is no inherent connection between an e-mail address and an SMTP server. Many people, including myself, have forwarding e-mail addresses that do not really exist. Any properly configured e-mail servers will reject an e-mail sent from an account that doesn't exist. If this "feature" ever worked before Mountain Lion, then it was a serious bug on Apple's part.

     

    In your list of Inboxes, select the one you want to be the default and drag it to the top of the list. That will be your new default sending e-mail address. If you want to choose a different sending account, you will have to manually change it when composing a new message. If you wnat to associate that message with a virtual e-mail address, use the headers control to show the "Reply-To" header. Enter your virtual e-mail address there. When your recipient replies, it will go to that address.

  • jevlewt Level 1 Level 1 (0 points)

    I think your reply is meant for someone else. I have no problems with, or questions about, SMTP servers in Mountain Lion. And I don't need to drag any Inboxes around; I have no problems with, or questions about, default mail addresses in Mountain Lion. (I understand that others may have problems there, and your message may help.)

     

    My Mountain Lion problem: I'm happy to have an address "whatever@generic_account.com" that is the default sending address when composing new messages (unless I change the sending account, of course). But I'm not happy when I receive a message at "very_important_stuff@work_account.com", and my reply is sent from "whatever@generic_account.com" instead of from "very_important_stuff@work_account.com". That's bizarre. When an outgoing message is a reply, the original recipient address should become the outgoing reply's default sending address.

     

    Yes, I can change the sending address in the reply, but that was never necessary in any previous version of Mail, nor in any version of any email program that I've ever seen (YMMV). I hope Apple fixes the bug (?) and restores the behavior that was present in all previous versions of Mail (or best of all, provides an option for using either the old normal behavior or the new crazy behavior).

  • latas Level 1 Level 1 (0 points)

    Totally agree. That's the problem. And it should be fixed asap. I'm really exhausted to answer emails everyday changing the From field, because I've got more than 20 email accounts from my differents business.

  • etresoft Level 7 Level 7 (25,885 points)

    jevlewt wrote:

     

    Yes, I can change the sending address in the reply, but that was never necessary in any previous version of Mail, nor in any version of any email program that I've ever seen (YMMV). I hope Apple fixes the bug (?) and restores the behavior that was present in all previous versions of Mail (or best of all, provides an option for using either the old normal behavior or the new crazy behavior).

    Obviously my reply was directly correctly. This has nothing to do with e-mail programs. This is about e-mail servers. If your e-mail server is incorrectly configured, that is the problem for your admins. That puts your e-mail messages at risk of going on a SPAM blacklist. Then you will wonder why your messages aren't arriving and, undoubtedly, blame Apple for it. You can't do that now, because Apple doesn't allow it. Your e-mail server may still allow it, but that isn't Apple's problem.

Previous 1 4 5 6 7 8 Next