Previous 1 5 6 7 8 9 Next 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock Go to original post Branched to a new discussion.
  • jevlewt Level 1 Level 1 (0 points)

    I appreciate the reply, but again, I don't follow. Nothing has changed with the email servers I use, and for 15+ years of using email servers and email clients that operate under what I called "the old normal behavior", ending up on SPAM blacklists has never come up. I have no concerns about email servers at all (but if someone here does, your comments may be a help).

     

    The only thing that's changed is Mountain Lion's behavior. It's changed from every past version of Mail, and every email client I've ever seen. My apologies if I'm not stating the problem clearly; I'll let TidBits say it instead, as they devoted a whole article to exactly what has me scratching my head: http://tidbits.com/article/13189 . Interested parties should read the article for details, but let me note that the writer clearly sees a problem:

    However, in Mountain Lion... if you don’t carefully (and manually) check each outgoing message, you might find that you’re sending messages from an unintended account. This can have serious consequences if, for example, you end up sending work email from a personal account or vice-versa... I have no idea why Apple made this change... and on the whole I think it was a pretty bad move... We can only hope Apple changes this in an update to OS X.

     

    Amen! While I have no argument with anyone who likes the ML behavior, my request to Apple stands: if it's a bug, please fix it; if it's intentional, please offer an option to use the behavior of the past 10+ years.

  • etresoft Level 7 Level 7 (25,870 points)

    As far as I can tell, the change in Mountain Lion is the bug fix. Apple has millions of users to think about. Just because you haven't been impacted doesn't mean other people have not. An e-mail server can be (and should be) configured to reject a request to send a message from an account other than that used to send the message.

     

    If you were able to send messages like this, then you may have been using old, insecure authentication methods. This may have been fine back in the day when everyone had a desktop and DSL. But today, with mobile devices and WiFi hotspots, you don't want to broadcast your e-mail account and password in the clear. That can get you intro trouble very quickly.

     

    There is a solution. Use "reply-to". That is what it is there for. If you want to send feedback to Apple, tell Apple to automatically set "reply-to" when composing a reply in this situation. That would be a nice improvement.

  • Blaine Damage Level 1 Level 1 (0 points)

    Sorry this is well documented in other threads and reputable publications like this one:

     

     

    Mail replies from wrong address

    As reported by Kirk McElhearn (who cites an Apple Support Communities thread on the matter), the new version of Mail in Mountain Lion has trouble assigning the correct address for email replies. If you have multiple email accounts, when you select to reply to an email, Mail should use the account that received the message as your “from” address. This should override any selection you have made for a default address to use with new messages. That’s the way things worked in Lion.

     

     

    Read the rest here:

     

    http://www.macworld.com/article/1168016/bugs_and_fixes_troubleshooting_mountain_ lion.html

  • suncat100 Level 1 Level 1 (0 points)

    etresoft: you have misunderstood completely. For each outgoing e-mail address, I also have separate dedicated SMTP e-mails assigned ... Obviously this is necessary to counter-act spam amongst other things as you seem to be aware of. I still collect all e-mail through a single "inbox" (which does not mean a single e-mail address), and now Mail defaults a single e-mail for reply (instead of the recipient of the e-mail).

     

    Mountain Lion is not the bug fix, it is the broken.

  • etresoft Level 7 Level 7 (25,870 points)

    Blaine Damage wrote:

     

    Sorry this is well documented in other threads and reputable publications like this one:

     

    http://www.macworld.com/article/1168016/bugs_and_fixes_troubleshooting_mountain_ lion.html

    You cannot cite a document in this thread which uses this same thread as its basis. You can't believe everything you read on the internet. People don't do fact checking. The just post. The person who reported this "bug" is 100% wrong.

  • etresoft Level 7 Level 7 (25,870 points)

    suncat100 wrote:

     

    I still collect all e-mail through a single "inbox" (which does not mean a single e-mail address), and now Mail defaults a single e-mail for reply (instead of the recipient of the e-mail).

    Maybe you shouldn't do that. Each inbox should be matched with an SMTP server. You can have a single SMTP server used for multiple inboxes, but you can't have multiple SMTP servers with a single incoming account. Well, you can, but it will work as you describe.

     

    I have six separate e-mail accounts and a number of forwarded aliases. Only two of those accounts share the same server. The rest are a mix of everything under the sun. When I reply to e-mail in each inbox, Mountain Lion Mail always selects the appropriate SMTP server in each case.

     

    How can it be broken, when it isn't?

  • suncat100 Level 1 Level 1 (0 points)

    It's funny to read, because basically you don't even understand the bug, yet you are ranting on as if you do ...

     

    "Maybe" I shouldn't? Excuse me, but what is your reasoning for this, you just take it from thin air? I pre-collect perhaps a dozen e-mail accounts into a single gmail account, because this has several benefits. To mention a few: improved spam protection, superior web-based access, easier sorting (i can go on).

     

    These e-mails arrive in my Mail inbox, correctly addressed to various e-mail addresses (but same inbox) ... Just as I want it (and just like it works in Google). So when I click reply, I want to reply from the recipient address of the e-mail ... Strange? no. This is how it works prior to ML, this is how it works in gmail, this is how it works in other mail apps. There is nothing insecure or wrong about this setup. Its a move from Apple they didn't consider properly.

  • thefranko Level 1 Level 1 (0 points)

    suncat100 wrote:

     

    It's funny to read, because basically you don't even understand the bug, yet you are ranting on as if you do ...

     

    "Maybe" I shouldn't? Excuse me, but what is your reasoning for this, you just take it from thin air? I pre-collect perhaps a dozen e-mail accounts into a single gmail account, because this has several benefits. To mention a few: improved spam protection, superior web-based access, easier sorting (i can go on).

     

    These e-mails arrive in my Mail inbox, correctly addressed to various e-mail addresses (but same inbox) ... Just as I want it (and just like it works in Google). So when I click reply, I want to reply from the recipient address of the e-mail ... Strange? no. This is how it works prior to ML, this is how it works in gmail, this is how it works in other mail apps. There is nothing insecure or wrong about this setup. Its a move from Apple they didn't consider properly.

    etresoft clearly doesn't understand the bug (yes, it's a bug). He's either genuinely mistaken and has decided to be completely tactless in the process, or he's a troll. Either way, his comments are way off base and provide no help to the situation.

  • jesmith Level 1 Level 1 (10 points)

    etresoft is trolling. Don't take the bait.

  • AuPhalanx Level 2 Level 2 (435 points)

    I don't think etresoft is a troll, as he is a Level 6 here on the boards. I think that he doesn't exactly understand our issue.

     

    etresoft, here's how the issue affects me. I hope this gives you insight into what we are discussing.

     

    I have multiple e-mail accounts for the various aspects of my business, most POP3 accounts. In order to sync my e-mails across my different machines, I use Mail rules to move ALL e-mails I receive, regardless of the e-mail account, to the iCloud account Inbox. Thus, regardless of which machine gets the e-mail, whether it is my iMac or my Air, the e-mails go to my iCloud Inbox and are then synced between all machines.

     

    Prior to Mountain Lion, even with all the e-mails in the iCloud Inbox, when I replied to an e-mail, the "reply-from" address and account used was the one to which the e-mail was addressed. When sent, it would use the information of that account (that account's servers) to do the send.

     

    Here's an example to make things more clear:

     

    I receive an e-mail addressed to pop@pop.com. Mail receives it and applies the rule that moves it to iCloud Inbox (the e-mail address of that account being icloud@me.com). When I reply, the reply-from address used, as well as all the setting for that address, was pop@pop.com. Mail sent. Done.

     

    That's how things worked in Lion -- and in every e-mail client and operating system I've ever used. (Yes, even Windows.)

     

    Now, in Mountain Lion, the reply-from address is changed to the iCloud account -- icloud@me.com in our example.

     

    Try it now for yourself. Move one of your e-mails that you received addressed to a non-iCloud account to our iCloud Inbox. Reply to that e-mail. You will see that the reply-from address will be changed to your iCloud e-mail account. It shouldn't do that. There isn't an e-mail client that I know of that does that.

     

    As I noted, this is how things worked in Lion -- and continue to work that way. I know it does as I have a machine that is still running Lion.

     

    If it isn't obvious, this can be rather irksome to those of us who have multiple e-mail addresses. I want to reply with the correct e-mail address. I also want to keep my @me.com address somewhat private so as to separate work and play. This bug -- and it IS a bug -- makes it so that EVERY time I reply to an e-mail, I must manually change the reply-from account. Believe me, doing that a hundred times a day gets tiresome. It even gets frustrating when I forget to make that change, send the e-mail, I discover days later that the recipient didn't get the e-mail because it got caught in their spam filter because my @me.com address was not in their address book.

     

    So that's the problem. That's the bug. I hope this helps you to understand our plight.

     

    All the BEST!

     

    T.

  • jesmith Level 1 Level 1 (10 points)

    OK, fair enough. But he sure does write like a troll.

     

    Anyway, for those who were wondering, my bug reports were "closed as duplicate" and the "related problem" has state "Open". I think that means Apple knows that this is a bug.

     

    We all know there is no work-around.

     

    So all there is to do at this point is breath deeply and wait.

  • AuPhalanx Level 2 Level 2 (435 points)

    Hi jesmith!

     

    Well, I guess making close to 20,000 posts on a forum can become trying for anyone.

     

    My bug report was also closed as a duplicate. Hopefully, we'll have a fix in 10.8.2.

     

    T.

  • Kawanaut Level 1 Level 1 (50 points)

    AuPhalanx, you nailed it - that's a very good explanation of this bug!

     

    It seems more and more bug reports are coming up as "closed as duplicate", so I'm still hoping that this will be fixed. It wasn't fixed in 10.8.1, so I'm crossing all fingers and toes it will be fixed in 10.8.2, otherwise I hope there are some good Mail.app alternatives out there, which is too sad cause I basically like everything about Mail.app, except this bug.

  • jtibbetts Level 1 Level 1 (0 points)

    AuPhalanx's explanation is a good one, but I think the bug can be described more succinctly as:

     

    If an email is in an Inbox and you reply to it, the correct "reply-from" address (i.e. the address it was sent to) will be selected.

     

    If you move THE SAME EMAIL from the Inbox into a folder (via a Mail Rule or manually) and then reply to it, the default account set up for Mail will be used *not* the address it was sent to.

  • AuPhalanx Level 2 Level 2 (435 points)

    @Kawanaut

     

    THANKS! I am thinking that it will be fixed. It seems they made a few mistakes in redoing Mail. There's the "reply-all" bug, which includes your e-mail address in the copy-to field. And the redesigned headers are pretty lame. So, here's hoping for a fix.

     

    @jtibbetts

     

    Yes! I was never known for my succintness. My personal OS seems to be stuck in verbose mode.

     

    T.

Previous 1 5 6 7 8 9 Next