Previous 1 2 3 Next 43 Replies Latest reply: May 11, 2013 12:41 PM by aelogica.sts Go to original post
  • betadecay Level 1 Level 1

    I think your right with your guess that it is a hardware related problem. I can rember one time when i moved the display a little bit and thus the cable and suddenly it fell into sleep...

  • Richatom Level 1 Level 1

    Problem has come back on my thunderbolt. I think now it might be Parallels that causes the problem, as it only happens if I leave parallels running.

  • Barry Breen Level 1 Level 1

    Richatom, inconsistency is the signature of this hardware problem. You likely have the SAME problem that others had (not Parallels, not fidgiting with power up/down, not the order of plugging in cables, not software patches). As you have learned through all of this, none of those permanently fix or cause the problem. The ONLY thing that I found that oonsistently created a situation whereby the display and its ports, sound and camera worked properly was to bypass the All-in-One Firewire portion of the cable coming from the display. I previously wrote about this, and it does two things. It proves this is a hardware issue in the display (its cable or electronics, etc.) and it provides a temporary workaround. Yes, to prove it to yourself you would need an extra apple Thunderbolt cable, but barring this, my guess is you will not find any other permanent solution via technique or software (that simply is not the issue, and by now, you have come to this conclusion). Others who have had their displays repaired or replaced (or who have used the workaround I included in this thread) now have correctly working displays. I'm just trying to help you from wasting lots more time experiencing this issue. If you can't get the display repaired or replaced, invest in an extra Apple Thunderbolt cable (about $50); it's probably a good idea to have one anyway. Good Luck, Barry

  • bigdave1357 Level 1 Level 1

    I agree with Barry that a good workaround is better than nothing. I have not yet tried the seperate cable trick, but I am getting close to this step. Currently I'm working through a very similar set of problems. I have two MacBook Pro units (13 and 17) both of which suffer the same problem when connected to my Thunderbolt 27 - the TBD does not wake from sleep. For the 17 this occurs about 1 time in 3 and for the 13 it occurs every time.


    I recently had my TBD back to Apple for repair who concluded that with both the 13 and 17 displaying the same problem, it could not be a machine issue. Of course it could be a software issue but I decided to go ahead with hardware repair to rule this out. My "repaired" TBD came back and there is no change whatsoever - problem is still there.


    Having read this thread through, and others like it, I'm also thinking that virtual machine software could be a problem. The other thing both my 13 and 17 have in common is they both run VMware Fusion all the time.


    I shutdown Fusion on the 13 and it works perfectly. I can repeat this every single time: run Fusion and the 13 will not wake the TBD from sleep. Stop Fusion and it wakes it every time. With the 17 the result is the same.


    So, there might well be multiple problems here, looking back at the thread, but for me and possibly others, I think VMware or Parallels might be a contributory factor. Now, the question is where is the bug? Something common to both VMWare and Parallels or something lower down within OSX or drivers that is only precipitated when running VM products?


    Assuming I'm right I am now looking at workaround solutions (perhaps minimising Fusion before sleep etc) to see if I can find a stop gap solution. I have also reported the bug to vmware and I'll report back here when I find out what they say. I might also try Barry's solution to see if that adds further to the pool of knowledge.

  • bigdave1357 Level 1 Level 1

    After three days of testing I'm pretty certain that having VMware running is a contributory factor. Whereas before, with VMware running continuously I had continuous problems, without VMware running I have no problems. Of course I want to leave VMWare running, so I've reported the problem to VMware who, as yet, have not gotten around to locating a TBD to test out my report....


    In another strange development I also found the following very useful...



    It seems that on waking from hibernation, having the safesleep image on disk affects the way in which the machine wakes up and this can also be a problem.


    With VMWare running and safesleep turned off, so far, this seems to have cured the problem for me. Don't know why but there are plenty of others on other threads that claim the safesleep fix to be a good solution for them.


    After only 3 days it might be a bit premature to call it a solution - workaround at best - but definately worth a try.

  • Richatom Level 1 Level 1

    Yes, I agree with bigdave. I only consistently have this problem if I have Parallels8 running.


    Even if Parallels8 is running, sometimes it works ok. On the occasions when it doesn't work, I sometimes get a message about a USB port problem. I therefore suspect it may be something to do with USB port not sending a signal to the TBD to wake it up.


    Anyway, my work around is to turn off sleep on my MBP.

  • ron523 Level 1 Level 1

    Hi Folks,    I have exactly the same problem intermittently,  although it seems to have been getting much worse with successive OS updates.  The thing is - I don't have any VMWare running on this machine and I have used a fresh Thunderbolt cable to connect the display to the MBA (instead of the integral one).  So,  unfortunately , in my case the "Parallels" and ""new Thunderbolt cable" theories do not do anything to solve the problem.

  • Barry Breen Level 1 Level 1



    Indeed curious. So, you unplugged all cables except power from your MacBook Pro (what year/month?). You plugged power into your Thunderbolt display, and you have utilized a spare Apple Thunderbolt cable to plug into the Thunderbolt port on the display and a Thunderbolt port on the MacBook Pro. Is this correct?



  • ron523 Level 1 Level 1

    Hi Barry,


    Yes - That's pretty much it.  Computer is MBA, about 10 months old with Thunderbolt screen.   I don't use either the integral power cable or thunderbolt cable from the screen and have replaced both with separate cables.  There is nothing else plugged in to the MBA so it's really very simple.  The Thunderbolt screen just has an Ethernet attached and that's it.    I experience both the intermittent lack of wake-up of the screen as well as the audio switching itself back to the MBA.  Procedure to clear it is to open the MBA,  remove and insert the Thunderbolt connector from the MBA then it all comes back to life.   It was only happening about 2 or 3 times a week previously but now happens every time the computer sleeps for more than a few hours.

  • bigdave1357 Level 1 Level 1

    Hi Ron523,


    I would definitely try turning off safe sleep - see my previous post. It fixed the problem (or at least it's a workaround that really worked) for me on both a pro 17 and 13. It's been 6 days since I applied these changes and I've not seen the problem since.

  • ron523 Level 1 Level 1

    OK - trying that - will let you know

  • ron523 Level 1 Level 1

    Well - turning off Safe Sleep has made a big positive difference.   It's not a complete cure - I have had two recurrences of the problem in the last 2 weeks,  but it's way better than previously when it was happening almost every time the computer had been idle for more than a couple of hours.   


    Thanks bigdave1357  

  • elwud Level 1 Level 1

    i was having the same problem and just got off w/ apple care and they fixed the problem at least for the time being.  i am using my TBD w/ an iMac.   unplug everything from the iMac..power, TBD cord, speakers, any and all USBs...unplug the power from TBD...hold down the power button on iMac for at least 10 seconds....plug everything back in and power up.   this worked for me, hope it works for y'all.   apparently that resets something or another in the system and kick starts the TBD back alive.   they couldnt really give me a good reason on why it happens in the first place.    

  • aelogica.sts Level 1 Level 1

    I experienced this unti I reset the Power settings to default and crucially I believe, installed the Thunderbolt firmware update that was pending.  My mid 2012 MBA now reports 10.8.3. (12D78)    Seems to be working.  I also purchased(!) the MagSafe to MagSafe2 adapter which the salesperson at the apple store carefully explained was not guranteed to work.   Anyway I'm hoping this helps someone.  Make sure your firmware is up to date.

Previous 1 2 3 Next